Really minor fixes/cleanups.
[linux-2.6.git] / kernel-2.6.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 Summary: The Linux kernel (the core of the Linux operating system)
7
8 # What parts do we want to build?  We must build at least one kernel.
9 # These are the kernels that are built IF the architecture allows it.
10
11 %define buildup 1
12 %define builduml 0
13 %define buildxen 0
14 %define builddoc 0
15
16 # Versions of various parts
17
18 # for module-tag.py - sublevel is used for the version (middle) part of tag names
19 %define name linux-2.6
20 %define module_version_varname sublevel
21 %define taglevel 1
22
23 #
24 # Polite request for people who spin their own kernel rpms:
25 # please modify the "release" field in a way that identifies
26 # that the kernel isn't the stock distribution kernel, for example by
27 # adding some text to the end of the version number.
28 #
29 %define sublevel 22
30 %define patchlevel 14
31 %define kversion 2.6.%{sublevel}
32 %define rpmversion 2.6.%{sublevel}%{?patchlevel:.%{patchlevel}}
33
34 %define vsversion 2.3.0.29
35
36 # Will go away when VServer supports NetNS in mainline. Currently, it must be 
37 # updated every time the PL kernel is updated.
38 %define vini_pl_patch 561
39
40 %define release vs%{vsversion}.%{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
41
42 %{!?pldistro:%global pldistro planetlab}
43
44 %define signmodules 0
45 %define make_target bzImage
46 %define KVERREL %{PACKAGE_VERSION}-%{PACKAGE_RELEASE}
47
48 # Override generic defaults with per-arch defaults
49
50 %define image_install_path boot
51
52 #
53 # Three sets of minimum package version requirements in the form of Conflicts:
54 # to versions below the minimum
55 #
56
57 #
58 # First the general kernel 2.6 required versions as per
59 # Documentation/Changes
60 #
61 %define kernel_dot_org_conflicts  ppp <= 2.3.15, pcmcia-cs <= 3.1.20, isdn4k-utils <= 3.0, mount < 2.10r-5, nfs-utils < 1.0.3, e2fsprogs < 1.29, util-linux < 2.10, jfsutils < 1.0.14, reiserfsprogs < 3.6.3, xfsprogs < 2.1.0, procps < 2.0.9, oprofile < 0.5.3
62
63
64 # Then a series of requirements that are distribution specific, either 
65 # because we add patches for something, or the older versions have 
66 # problems with the newer kernel or lack certain things that make 
67 # integration in the distro harder than needed.
68 #
69 %define package_conflicts  cipe < 1.4.5, kudzu <= 0.92, initscripts < 7.23, dev < 3.2-7, iptables < 1.2.5-3, bcm5820 < 1.81, nvidia-rh72 <= 1.0 selinux-policy-targeted < 1.23.16-1
70
71 #
72 # Several packages had bugs in them that became obvious when the NPTL
73 # threading code got integrated.
74 #
75 %define nptl_conflicts SysVinit < 2.84-13, pam < 0.75-48, vixie-cron < 3.0.1-73, privoxy < 3.0.0-8, spamassassin < 2.44-4.8.x,  cups < 1.1.17-13
76
77 #
78 # The ld.so.conf.d file we install uses syntax older ldconfig's don't grok.
79 #
80
81 # MEF commented out
82 # %define xen_conflicts glibc < 2.3.5-1
83
84 #
85 # Packages that need to be installed before the kernel is, because the %post
86 # scripts use them.
87 #
88 %define kernel_prereq  fileutils, module-init-tools, initscripts >= 5.83, mkinitrd >= 3.5.5
89
90 Vendor: PlanetLab
91 Packager: PlanetLab Central <support@planet-lab.org>
92 Distribution: PlanetLab %{plrelease}
93 URL: %(echo %{url} | cut -d ' ' -f 2)
94
95 Name: kernel
96 Group: System Environment/Kernel
97 License: GPLv2
98 Version: %{rpmversion}
99 Release: %{release}
100 ExclusiveOS: Linux
101 Provides: kernel = %{version}
102 Provides: kernel-drm = 4.3.0
103 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}
104 Provides: kernel-smp = %{rpmversion}-%{release}
105 Provides: kernel-smp-%{_target_cpu} = %{rpmversion}-%{release}
106 Prereq: %{kernel_prereq}
107 Conflicts: %{kernel_dot_org_conflicts}
108 Conflicts: %{package_conflicts}
109 Conflicts: %{nptl_conflicts}
110 # We can't let RPM do the dependencies automatic because it'll then pick up
111 # a correct but undesirable perl dependency from the module headers which
112 # isn't required for the kernel proper to function
113 AutoReqProv: no
114
115 #
116 # List the packages used during the kernel build
117 #
118 BuildPreReq: module-init-tools, patch >= 2.5.4, bash >= 2.03, sh-utils, tar
119 BuildPreReq: bzip2, findutils, gzip, m4, perl, make >= 3.78, gnupg, diffutils
120 BuildRequires: gcc >= 3.3.3, binutils >= 2.12, redhat-rpm-config
121 BuildConflicts: rhbuildsys(DiskFree) < 500Mb
122
123
124 Source0: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-%{kversion}.tar.bz2
125
126 Source10: %{pldistro}-%{kversion}-i586.config
127 Source11: %{pldistro}-%{kversion}-i686.config
128 Source12: %{pldistro}-%{kversion}-x86_64.config
129 %if %{builduml}
130 Source20: %{pldistro}-%{kversion}-i686-uml.config
131 %endif
132 %if %{buildxen}
133 Source30: %{pldistro}-%{kversion}-i686-xenU.config
134 %endif
135
136 # Mainline patches
137 %if "0%{patchlevel}"
138 Patch000: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/patch-%{rpmversion}.bz2
139 %endif
140
141 Patch010: linux-2.6-010-e1000e.patch
142 Patch020: linux-2.6-020-build-id.patch
143 Patch030: linux-2.6-030-netns.patch
144
145 # These are patches picked up from Fedora/RHEL
146 Patch100: linux-2.6-100-build-nonintconfig.patch
147
148 # Linux-VServer
149 Patch200: patch-%{rpmversion}-vs%{vsversion}.diff
150 Patch210: linux-2.6-210-vserver-cpu-sched.patch
151
152 # IP sets
153 Patch250: linux-2.6-250-ipsets.patch
154
155 # PlanetLab
156 Patch500: linux-2.6-500-vserver-filesharing.patch
157 Patch510: linux-2.6-510-ipod.patch
158 Patch520: linux-2.6-520-vnet+.patch
159 Patch530: linux-2.6-530-built-by-support.patch
160 Patch540: linux-2.6-540-oom-kill.patch
161 Patch550: linux-2.6-550-raise-default-nfile-ulimit.patch
162 Patch560: linux-2.6-560-mmconf.patch
163 Patch570: linux-2.6-570-tagxid.patch
164
165 # See also the file named 'sources' here for the related checksums
166 # NOTE. iwlwifi should be in-kernel starting from 2.6.24
167 # see http://bughost.org/bugzilla/show_bug.cgi?id=1584
168 %define mac80211_version 10.0.4
169 Patch600: http://intellinuxwireless.org/mac80211/downloads/mac80211-%{mac80211_version}.tgz
170 %define iwlwifi_version 1.2.23
171 Patch601: http://intellinuxwireless.org/iwlwifi/downloads/iwlwifi-%{iwlwifi_version}.tgz
172
173 BuildRoot: %{_tmppath}/kernel-%{KVERREL}-root
174
175 %description
176 The kernel package contains the Linux kernel (vmlinuz), the core of any
177 Linux operating system.  The kernel handles the basic functions
178 of the operating system:  memory allocation, process allocation, device
179 input and output, etc.
180
181 %package devel
182 Summary: Development package for building kernel modules to match the kernel.
183 Group: System Environment/Kernel
184 AutoReqProv: no
185 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}
186 Provides: kernel-smp-devel = %{rpmversion}-%{release}
187 Provides: kernel-smp-devel-%{_target_cpu} = %{rpmversion}-%{release}
188 Prereq: /usr/bin/find
189
190 %description devel
191 This package provides kernel headers and makefiles sufficient to build modules
192 against the kernel package.
193
194
195 %package doc
196 Summary: Various documentation bits found in the kernel source.
197 Group: Documentation
198
199 %description doc
200 This package contains documentation files from the kernel
201 source. Various bits of information about the Linux kernel and the
202 device drivers shipped with it are documented in these files.
203
204 You'll want to install this package if you need a reference to the
205 options that can be passed to Linux kernel modules at load time.
206
207 %package xenU
208 Summary: The Linux kernel compiled for unprivileged Xen guest VMs
209
210 Group: System Environment/Kernel
211 Provides: kernel = %{version}
212 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}xenU
213 Prereq: %{kernel_prereq}
214 Conflicts: %{kernel_dot_org_conflicts}
215 Conflicts: %{package_conflicts}
216 Conflicts: %{nptl_conflicts}
217
218 # MEF commented out 
219 # Conflicts: %{xen_conflicts}
220
221 # We can't let RPM do the dependencies automatic because it'll then pick up
222 # a correct but undesirable perl dependency from the module headers which
223 # isn't required for the kernel proper to function
224 AutoReqProv: no
225
226 %description xenU
227 This package includes a version of the Linux kernel which
228 runs in Xen unprivileged guest VMs.  This should be installed
229 both inside the unprivileged guest (for the modules) and in
230 the guest0 domain.
231
232 %package xenU-devel
233 Summary: Development package for building kernel modules to match the kernel.
234 Group: System Environment/Kernel
235 AutoReqProv: no
236 Provides: kernel-xenU-devel-%{_target_cpu} = %{rpmversion}-%{release}
237 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}xenU
238 Provides: kernel-devel = %{rpmversion}-%{release}xenU
239 Prereq: /usr/sbin/hardlink, /usr/bin/find
240
241 %description xenU-devel
242 This package provides kernel headers and makefiles sufficient to build modules
243 against the kernel package.
244
245 %package uml
246 Summary: The Linux kernel compiled for use in user mode (User Mode Linux).
247
248 Group: System Environment/Kernel
249
250 %description uml
251 This package includes a user mode version of the Linux kernel.
252
253 %package uml-devel
254 Summary: Development package for building kernel modules to match the UML kernel.
255 Group: System Environment/Kernel
256 Provides: kernel-uml-devel-%{_target_cpu} = %{rpmversion}-%{release}
257 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}smp
258 Provides: kernel-devel = %{rpmversion}-%{release}smp
259 AutoReqProv: no
260 Prereq: /usr/sbin/hardlink, /usr/bin/find
261
262 %description uml-devel
263 This package provides kernel headers and makefiles sufficient to build modules
264 against the User Mode Linux kernel package.
265
266 %package uml-modules
267 Summary: The Linux kernel modules compiled for use in user mode (User Mode Linux).
268
269 Group: System Environment/Kernel
270
271 %description uml-modules
272 This package includes a user mode version of the Linux kernel modules.
273
274 %package vserver
275 Summary: A placeholder RPM that provides kernel and kernel-drm
276
277 Group: System Environment/Kernel
278 Provides: kernel = %{version}
279 Provides: kernel-drm = 4.3.0
280 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}
281
282 %description vserver
283 VServers do not require and cannot use kernels, but some RPMs have
284 implicit or explicit dependencies on the "kernel" package
285 (e.g. tcpdump). This package installs no files but provides the
286 necessary dependencies to make rpm and yum happy.
287
288
289 %prep
290 # First we unpack the kernel tarball.
291 # If this isn't the first make prep, we use links to the existing clean tarball
292 # which speeds things up quite a bit.
293 if [ ! -d kernel-%{kversion}/vanilla ]; then
294   # Ok, first time we do a make prep.
295   rm -f pax_global_header
296 %setup -q -n %{name}-%{kversion} -c
297   mv linux-%{kversion} vanilla
298 else
299   # We already have a vanilla dir.
300   cd kernel-%{kversion}
301 fi
302
303 KERNEL_PREVIOUS=vanilla
304 # Dark RPM-magic to apply each patch to a hardlinked copy of the tree.
305 %define ApplyPatch() \
306   rm -fr linux-%{kversion}-%1                           \
307   cp -al $KERNEL_PREVIOUS linux-%{kversion}-%1          \
308   patchflag=-p1                                         \
309   test "%2" != "%%2" && patchflag="%2"                  \
310   PATCH="%{expand:%{PATCH%1}}"                          \
311   if test ! -e "$PATCH"; then                           \
312     echo "Patch %1 does not exist!"                     \
313     exit 1                                              \
314   fi                                                    \
315   case "$PATCH" in                                      \
316     *.bz2)  bzcat "$PATCH";;                            \
317     *.gz)   zcat "$PATCH";;                             \
318     *)      cat "$PATCH";;                              \
319   esac | patch -F1 -s -d linux-%{kversion}-%1 $patchflag \
320   KERNEL_PREVIOUS=linux-%{kversion}-%1
321
322 # This is where the patches get applied
323 %if 0%{?patchlevel}
324 %ApplyPatch 0
325 %endif
326
327 %ApplyPatch 10
328 %ApplyPatch 20
329
330 # NetNS patch for VINI
331 %if 0%{?with_netns}
332 %ApplyPatch 30
333 %endif
334
335 %ApplyPatch 100
336
337 %ApplyPatch 200
338 %ApplyPatch 210
339
340 %ApplyPatch 250
341
342 %ApplyPatch 500
343 %ApplyPatch 510
344 %ApplyPatch 520
345 %ApplyPatch 530
346 %ApplyPatch 540
347 %ApplyPatch 550
348 %ApplyPatch 560
349 %ApplyPatch 570
350
351 # NetNS conflict-resolving patch for VINI. Will work with patch vini_pl_patch-1 but may
352 # break with later patches.
353
354 %if 0%{?with_netns}
355 %ApplyPatch %vini_pl_patch
356 %endif
357
358 # Run the mac80211 stuff in the kernel tree holding the last patch
359 tar -xzf %{PATCH600}
360 pushd mac80211-%{mac80211_version}
361 mac80211_makeflags="KSRC=../$KERNEL_PREVIOUS"
362 make $mac80211_makeflags modified
363 make $mac80211_makeflags source
364 make $mac80211_makeflags patch_kernel
365 popd
366
367 # Untar iwlwifi in the same place - needs to be compiled later
368 tar -xzf %{PATCH601}
369 # the install target is broken: first it does not pass the right -b flag to depmod
370 # second we do not need to invoke depmod at this stage anyway
371 # let's add our own patch/stuff in this Makefile for manual install later on
372 pushd iwlwifi-%{iwlwifi_version}
373 cat >> Makefile <<EOF
374 module-list:
375         @echo \$(addprefix \$(DIR),\$(addsuffix .ko,\$(list-m)))
376 EOF
377 popd
378
379 rm -fr linux-%{kversion}
380 ln -sf $KERNEL_PREVIOUS linux-%{kversion}
381 cd linux-%{kversion}
382
383
384 # make sure the kernel has the sublevel we know it has. This looks weird
385 # but for -pre and -rc versions we need it since we only want to use
386 # the higher version when the final kernel is released.
387 perl -p -i -e "s/^SUBLEVEL.*/SUBLEVEL = %{sublevel}/" Makefile
388 perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = -prep/" Makefile
389
390 # get rid of unwanted files resulting from patch fuzz
391 find . \( -name "*.orig" -o -name "*~" \) -exec rm -f {} \; >/dev/null
392
393
394 ###
395 ### build
396 ###
397 %build
398
399 BuildKernel() {
400     MakeTarget=$1
401     Arch=$2
402     Flavour=$3
403
404     rm -rf linux-%{_target_cpu}-%{kversion}$Flavour
405     cp -rl linux-%{kversion}/ linux-%{_target_cpu}-%{kversion}$Flavour
406     cd linux-%{_target_cpu}-%{kversion}$Flavour
407
408     # Pick the right config file for the kernel we're building
409     if [ -n "$Flavour" ] ; then
410       Config=%{pldistro}-%{kversion}-%{_target_cpu}-$Flavour.config
411       DevelDir=/usr/src/kernels/%{KVERREL}-$Flavour-%{_target_cpu}
412       DevelLink=/usr/src/kernels/%{KVERREL}$Flavour-%{_target_cpu}
413     else
414       Config=%{pldistro}-%{kversion}-%{_target_cpu}.config
415       DevelDir=/usr/src/kernels/%{KVERREL}-%{_target_cpu}
416       DevelLink=
417     fi
418
419     KernelVer=%{version}-%{release}$Flavour
420     echo BUILDING A KERNEL FOR $Flavour %{_target_cpu}...
421
422     # make sure EXTRAVERSION says what we want it to say
423     perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = %{?patchlevel:.%{patchlevel}}-%{release}$Flavour/" Makefile
424
425     # and now to start the build process
426
427     make -s mrproper
428     cp %{_sourcedir}/$Config .config
429
430     #Arch=`head -1 .config | cut -b 3-`
431     echo USING ARCH=$Arch
432
433     make -s ARCH=$Arch nonint_oldconfig > /dev/null
434     make -s ARCH=$Arch %{?_smp_mflags} $MakeTarget
435     make -s ARCH=$Arch %{?_smp_mflags} modules || exit 1
436
437     # build the iwlwifi driver
438     make -C %{_builddir}/kernel-%{kversion}/iwlwifi-%{iwlwifi_version} ARCH=$Arch \
439          KSRC=%{_builddir}/kernel-%{kversion}/linux-%{_target_cpu}-%{kversion}$Flavour
440
441     # Start installing the results
442
443 %if "%{_enable_debug_packages}" == "1"
444     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/boot
445 %endif
446     mkdir -p $RPM_BUILD_ROOT/%{image_install_path}
447     install -m 644 .config $RPM_BUILD_ROOT/boot/config-$KernelVer
448     install -m 644 System.map $RPM_BUILD_ROOT/boot/System.map-$KernelVer
449     if [ -f arch/$Arch/boot/bzImage ]; then
450       cp arch/$Arch/boot/bzImage $RPM_BUILD_ROOT/%{image_install_path}/vmlinuz-$KernelVer
451     fi
452     if [ -f arch/$Arch/boot/zImage.stub ]; then
453       cp arch/$Arch/boot/zImage.stub $RPM_BUILD_ROOT/%{image_install_path}/zImage.stub-$KernelVer || :
454     fi
455     if [ "$Flavour" = "uml" ] ; then
456         install -D -m 755 linux $RPM_BUILD_ROOT/%{_bindir}/linux
457     fi
458
459     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer
460     make -s ARCH=$Arch INSTALL_MOD_PATH=$RPM_BUILD_ROOT modules_install KERNELRELEASE=$KernelVer
461
462     # install iwlwifi
463 #    make -C %{_builddir}/kernel-%{kversion}/iwlwifi-%{iwlwifi_version} ARCH=$Arch \
464 #         KSRC=%{_builddir}/kernel-%{kversion}/linux-%{_target_cpu}-%{kversion}$Flavour \
465 #        KMISC=$RPM_BUILD_ROOT/lib/modules/$KernelVer/kernel/drivers/net/wireless install
466     pushd %{_builddir}/kernel-%{kversion}/iwlwifi-%{iwlwifi_version}
467     iwlwifi_dest=$RPM_BUILD_ROOT/lib/modules/$KernelVer/kernel/drivers/net/wireless
468     # get the list and location of modules to install - no need to pass KSRC nor anything, let's keep it simple
469     iwlwifi_modules=$(make --no-print-directory module-list)
470     install -d $iwlwifi_dest
471     install -m 644 -c $iwlwifi_modules $iwlwifi_dest
472     popd
473
474     # And save the headers/makefiles etc for building modules against
475     #
476     # This all looks scary, but the end result is supposed to be:
477     # * all arch relevant include/ files
478     # * all Makefile/Kconfig files
479     # * all script/ files
480
481     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
482     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/source
483     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
484     (cd $RPM_BUILD_ROOT/lib/modules/$KernelVer ; ln -s build source)
485     # dirs for additional modules per module-init-tools, kbuild/modules.txt
486     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/extra
487     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/updates
488     # first copy everything
489     cp --parents `find  -type f -name "Makefile*" -o -name "Kconfig*"` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build 
490         cp Module.symvers $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
491     if [ "$Flavour" = "uml" ] ; then
492       cp --parents -a `find arch/um -name include` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
493     fi
494     # then drop all but the needed Makefiles/Kconfig files
495     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Documentation
496     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts
497     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
498     cp arch/%{_arch}/kernel/asm-offsets.s $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/kernel || :
499     cp .config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
500     cp -a scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
501     if [ -d arch/%{_arch}/scripts ]; then
502       cp -a arch/%{_arch}/scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch} || :
503     fi
504     if [ -f arch/%{_arch}/*lds ]; then
505       cp -a arch/%{_arch}/*lds $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/ || :
506     fi
507     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*.o
508     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*/*.o
509     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
510     cd include
511     cp -a acpi config keys linux math-emu media mtd net pcmcia rdma rxrpc scsi sound video asm asm-generic $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
512     cp -a `readlink asm` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
513     if [ "$Arch" = "x86_64" ]; then
514       cp -a asm-i386 $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
515     fi
516 %if %{buildxen}
517     if [ "$Flavour" = "xenU" ]; then
518       cp -a xen $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
519       cp -a asm-i386 $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
520     fi
521 %endif
522 %if %{builduml}
523     if [ "$Flavour" = "uml" ] ; then
524       cp -a `readlink -f asm/arch` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
525     fi
526 %endif
527     # While arch/powerpc/include/asm is still a symlink to the old
528     # include/asm-ppc{64,} directory, include that in kernel-devel too.
529     if [ "$Arch" = "powerpc" -a -r ../arch/powerpc/include/asm ]; then
530       cp -a `readlink ../arch/powerpc/include/asm` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
531       mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/$Arch/include
532       pushd $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/$Arch/include
533       ln -sf ../../../include/asm-ppc* asm
534       popd
535     fi
536
537     # Make sure the Makefile and version.h have a matching timestamp so that
538     # external modules can be built
539     touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Makefile $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/version.h
540     touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/.config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/autoconf.h
541     cd ..
542
543     #
544     # save the vmlinux file for kernel debugging into the kernel-debuginfo rpm
545     #
546 %if "%{_enable_debug_packages}" == "1"
547     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
548     cp vmlinux $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
549 %endif
550 %if %{buildxen}
551     if [ -f vmlinuz ]; then
552       cp vmlinuz $RPM_BUILD_ROOT/%{image_install_path}/vmlinuz-$KernelVer
553     fi
554 %endif
555
556     find $RPM_BUILD_ROOT/lib/modules/$KernelVer -name "*.ko" -type f >modnames
557
558     # mark modules executable so that strip-to-file can strip them
559     cat modnames | xargs chmod u+x
560
561     # remove files that will be auto generated by depmod at rpm -i time
562     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/modules.*
563
564     # Move the devel headers out of the root file system
565     mkdir -p $RPM_BUILD_ROOT/usr/src/kernels
566     mv $RPM_BUILD_ROOT/lib/modules/$KernelVer/build $RPM_BUILD_ROOT/$DevelDir
567     ln -sf ../../..$DevelDir $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
568     [ -z "$DevelLink" ] || ln -sf `basename $DevelDir` $RPM_BUILD_ROOT/$DevelLink
569 }
570
571 ###
572 # DO it...
573 ###
574
575 # prepare directories
576 rm -rf $RPM_BUILD_ROOT
577 mkdir -p $RPM_BUILD_ROOT/boot
578
579 %if "%{_target_cpu}" == "x86_64"
580 %define kernel_arch %{_target_cpu}
581 %endif
582 %if "%{_target_cpu}" == "i586"
583 %define kernel_arch i386
584 %endif
585 %if "%{_target_cpu}" == "i686"
586 %define kernel_arch i386
587 %endif
588
589 %if %{buildup}
590 BuildKernel %make_target %kernel_arch
591 %endif
592
593 %ifarch i686
594 %if %{builduml}
595 BuildKernel linux um uml
596 %endif
597
598 %if %{buildxen}
599 BuildKernel vmlinuz %kernel_arch xenU
600 %endif
601 %endif
602
603 ###
604 ### install
605 ###
606
607 %install
608
609 cd vanilla
610
611 %if %{buildxen} && "%{_target_cpu}" == "i686"
612 mkdir -p $RPM_BUILD_ROOT/etc/ld.so.conf.d
613 rm -f $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
614 cat > $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf <<\EOF
615 # This directive teaches ldconfig to search in nosegneg subdirectories
616 # and cache the DSOs there with extra bit 0 set in their hwcap match
617 # fields.  In Xen guest kernels, the vDSO tells the dynamic linker to
618 # search in nosegneg subdirectories and to match this extra hwcap bit
619 # in the ld.so.cache file.
620 hwcap 0 nosegneg
621 EOF
622 chmod 444 $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
623 %endif
624
625 %if %{builddoc}
626 mkdir -p $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}/Documentation
627
628 # sometimes non-world-readable files sneak into the kernel source tree
629 chmod -R a+r *
630 # copy the source over
631 tar cf - Documentation | tar xf - -C $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}
632 %endif
633
634 ###
635 ### clean
636 ###
637
638 %clean
639 rm -rf $RPM_BUILD_ROOT
640
641 ###
642 ### scripts
643 ###
644
645 # load the loop module for upgrades...in case the old modules get removed we have
646 # loopback in the kernel so that mkinitrd will work.
647 %pre
648 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
649 exit 0
650
651 %post
652 if [ -f /etc/sysconfig/kernel ]; then
653   /bin/sed -i -e 's/^DEFAULTKERNEL=kernel-smp$/DEFAULTKERNEL=kernel/' /etc/sysconfig/kernel
654 fi
655
656 # trick mkinitrd in case the current environment does not have device mapper
657 rootdev=$(awk '/^[ \t]*[^#]/ { if ($2 == "/") { print $1; }}' /etc/fstab)
658 if echo $rootdev |grep -q /dev/mapper 2>/dev/null ; then
659     if [ ! -f $rootdev ]; then
660         fake_root_lvm=1
661         mkdir -p $(dirname $rootdev)
662         touch $rootdev
663     fi
664 fi
665
666 [ ! -x /usr/sbin/module_upgrade ] || /usr/sbin/module_upgrade %{rpmversion}-%{release}
667 #/sbin/new-kernel-pkg --package kernel --mkinitrd --depmod --install %{KVERREL}
668 # Older modutils do not support --package option
669 /sbin/new-kernel-pkg --mkinitrd --depmod --install %{KVERREL}
670
671 # remove fake handle
672 if [ -n "$fake_root_lvm" ]; then
673     rm -f $rootdev
674 fi
675
676 # make some useful links
677 pushd /boot > /dev/null ; {
678         ln -sf config-%{KVERREL} config
679         ln -sf config-%{KVERREL} configsmp
680         ln -sf initrd-%{KVERREL}.img initrd-boot
681         ln -sf initrd-%{KVERREL}.img initrd-bootsmp
682         ln -sf vmlinuz-%{KVERREL} kernel-boot
683         ln -sf vmlinuz-%{KVERREL} kernel-bootsmp
684 }
685 popd > /dev/null
686
687 # ask for a reboot
688 mkdir -p /etc/planetlab
689 touch /etc/planetlab/update-reboot
690
691 %post devel
692 [ -f /etc/sysconfig/kernel ] && . /etc/sysconfig/kernel
693 if [ "$HARDLINK" != "no" -a -x /usr/sbin/hardlink ] ; then
694   pushd /usr/src/kernels/%{KVERREL}-%{_target_cpu} > /dev/null
695   /usr/bin/find . -type f | while read f; do hardlink -c /usr/src/kernels/*FC*/$f $f ; done
696   popd > /dev/null
697 fi
698
699 %post xenU
700 [ ! -x /usr/sbin/module_upgrade ] || /usr/sbin/module_upgrade
701 [ ! -x /sbin/ldconfig ] || /sbin/ldconfig -X
702
703 %post xenU-devel
704 [ -f /etc/sysconfig/kernel ] && . /etc/sysconfig/kernel
705 if [ "$HARDLINK" != "no" -a -x /usr/sbin/hardlink ] ; then
706   pushd /usr/src/kernels/%{KVERREL}-xenU-%{_target_cpu} > /dev/null
707   /usr/bin/find . -type f | while read f; do hardlink -c /usr/src/kernels/*FC*/$f $f ; done
708   popd > /dev/null
709 fi
710
711 %post uml-modules
712 depmod -ae %{KVERREL}uml
713
714 %preun
715 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
716 /sbin/new-kernel-pkg --rminitrd --rmmoddep --remove %{KVERREL}
717
718 %preun xenU
719 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
720 /sbin/new-kernel-pkg --rmmoddep --remove %{KVERREL}xenU
721
722 %preun uml-modules
723 rm -f /lib/modules/%{KVERREL}uml/modules.*
724
725
726 ###
727 ### file lists
728 ###
729
730 %if %{buildup}
731 %files 
732 %defattr(-,root,root)
733 /%{image_install_path}/vmlinuz-%{KVERREL}
734 /boot/System.map-%{KVERREL}
735 /boot/config-%{KVERREL}
736 %dir /lib/modules/%{KVERREL}
737 /lib/modules/%{KVERREL}/kernel
738 /lib/modules/%{KVERREL}/build
739 /lib/modules/%{KVERREL}/source
740 /lib/modules/%{KVERREL}/extra
741 /lib/modules/%{KVERREL}/updates
742
743 %files devel
744 %defattr(-,root,root)
745 %verify(not mtime) /usr/src/kernels/%{KVERREL}-%{_target_cpu}
746 %endif
747
748 %if %{builduml} && "%{_target_cpu}" == "i686"
749 %files uml
750 %defattr(-,root,root)
751 %{_bindir}/linux
752
753 %files uml-devel
754 %defattr(-,root,root)
755 %verify(not mtime) /usr/src/kernels/%{KVERREL}-uml-%{_target_cpu}
756 /usr/src/kernels/%{KVERREL}uml-%{_target_cpu}
757
758 %files uml-modules
759 %defattr(-,root,root)
760 /boot/System.map-%{KVERREL}uml
761 /boot/config-%{KVERREL}uml
762 %dir /lib/modules/%{KVERREL}uml
763 /lib/modules/%{KVERREL}uml/kernel
764 /lib/modules/%{KVERREL}uml/build
765 /lib/modules/%{KVERREL}uml/source
766 /lib/modules/%{KVERREL}uml/extra
767 /lib/modules/%{KVERREL}uml/updates
768 %endif
769
770 %if %{buildxen} && "%{_target_cpu}" == "i686"
771 %files xenU
772 %defattr(-,root,root)
773 /%{image_install_path}/vmlinuz-%{KVERREL}xenU
774 /boot/System.map-%{KVERREL}xenU
775 /boot/config-%{KVERREL}xenU
776 %dir /lib/modules/%{KVERREL}xenU
777 /lib/modules/%{KVERREL}xenU/kernel
778 /lib/modules/%{KVERREL}xenU/build
779 /lib/modules/%{KVERREL}xenU/source
780 /lib/modules/%{KVERREL}xenU/extra
781 /lib/modules/%{KVERREL}xenU/updates
782 /etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
783
784 %files xenU-devel
785 %defattr(-,root,root)
786 %verify(not mtime) /usr/src/kernels/%{KVERREL}-xenU-%{_target_cpu}
787 /usr/src/kernels/%{KVERREL}xenU-%{_target_cpu}
788 %endif
789
790 %files vserver
791 %defattr(-,root,root)
792 # no files
793
794 # only some architecture builds need kernel-doc
795
796 %if %{builddoc}
797 %files doc
798 %defattr(-,root,root)
799 %{_datadir}/doc/kernel-doc-%{kversion}/Documentation/*
800 %dir %{_datadir}/doc/kernel-doc-%{kversion}/Documentation
801 %dir %{_datadir}/doc/kernel-doc-%{kversion}
802 %endif
803
804 %changelog
805 * Tue Jul 11 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2142_FC4]
806 - 2.6.17.4
807 - Disable split pagetable lock.
808
809 * Wed Jul  5 2006 Dave Jones <davej@redhat.com>
810 - Get rid of stack backtrace on panic, which in most
811   cases actually caused a loss of info instead of a gain.
812
813 * Fri Jun 30 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2141_FC4]
814 - 2.6.17.3
815
816 * Fri Jun 30 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2140_FC4]
817 - 2.6.17.2
818 - Fix up the alsa list_add bug.
819
820 * Mon Jun 26 2006 Dave Jones <davej@redhat.com>
821 - Fix up various stupidities incurred by the last big rebase.
822   - Reenable SMP x86-64 builds.
823   - Reenable SMBFS.
824 - Enable PCI fake hotplug driver.
825 - Enable gameport/joystick on i586 builds. (#196581)
826
827 * Sat Jun 24 2006 Dave Jones <davej@redhat.com>
828 - Enable profiling for 586 kernels.
829
830 * Fri Jun 23 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2139_FC4]
831 - Rebuild with slab debug off.
832
833 * Tue Jun 20 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2138_FC4]
834 - 2.6.17.1
835
836 * Mon Jun  5 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2115_FC4]
837 - 2.6.16.20
838
839 * Tue May 30 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2114_FC4]
840 - 2.6.16.19
841
842 * Mon May 29 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2113_FC4]
843 - Improved list_head debugging.
844
845 * Tue May 23 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2112_FC4]
846 - 2.6.16.18
847
848 * Sat May 20 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2111_FC4]
849 - 2.6.16.17
850
851 * Wed May 10 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2110_FC4]
852 - 2.6.16.16
853
854 * Tue May  9 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2109_FC4]
855 - 2.6.16.15
856 - make 16C950 UARTs work (again). (#126403)
857 - Fix exec-shield default, which should fix a few programs that
858   stopped running.
859
860 * Thu May  4 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2108_FC4]
861 - 2.6.16.14
862
863 * Tue May  2 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2107_FC4]
864 - 2.6.16.13
865
866 * Mon May  1 2006 Dave Jones <davej@redhat.com>
867 - 2.6.16.12
868
869 * Tue Apr 25 2006 Dave Jones <davej@redhat.com>
870 - Fix up SCSI errors with mymusix usb mp3 player (#186187)
871
872 * Mon Apr 24 2006 Dave Jones <davej@redhat.com>
873 - 2.6.16.11
874
875 * Wed Apr 19 2006 Dave Jones <davej@redhat.com>
876 - Enable PCI MSI support.
877
878 * Tue Apr 18 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2096_FC4]
879 - 2.6.16.9
880
881 * Tue Apr 18 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2093_FC4]
882 - 2.6.16.7
883
884 * Mon Apr 17 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2092_FC4]
885 - 2.6.16.6
886
887 * Sun Apr 16 2006 Dave Jones <davej@redhat.com>
888 - 2.6.16.5
889
890 * Fri Apr  7 2006 Dave Jones <davej@redhat.com>
891 - 2.6.16.2
892
893 * Tue Apr  4 2006 Dave Jones <davej@redhat.com>
894 - Reenable non-standard serial ports. (#187466)
895 - Reenable snd-es18xx for x86-32 (#187733)
896
897 * Thu Mar 30 2006 Dave Jones <davej@redhat.com>
898 - ship the .kernelrelease file in -devel too.
899 - Disable EDAC debug.
900
901 * Tue Mar 26 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2069_FC4]
902 - 2.6.16.1
903
904 * Mon Mar 25 2006 Dave Jones <davej@redhat.com>
905 - Include patches posted for review for inclusion in 2.6.16.1
906 - Updated new audit msg types.
907 - Reenable HDLC driver (#186257)
908 - Make acpi-cpufreq 'sticky'
909 - Fix broken x86-64 32bit vDSO (#186924)
910
911 * Tue Mar 21 2006 Dave Jones <davej@redhat.com>
912 - Improve spinlock scalability on big machines.
913
914 * Mon Mar 20 2006 Dave Jones <davej@redhat.com>
915 - Sync with FC5's 2.6.16 kernel.
916 - Update Tux & Exec-shield to latest.
917