catch up with code running at PLE for nicer layout
[myplc.git] / myplc-docs.spec
1 %define name myplc-docs
2 %define version 5.1
3 %define taglevel 1
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central (PLC) online documentation
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: Applications/Systems
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15 BuildArch: noarch
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21
22 BuildRequires: docbook-dtds, docbook-utils-pdf
23
24 %define debug_package %{nil}
25
26 %description
27 This package contains the online documentation for MyPLC, i.e. the
28 reference manuals for the two APIs provided: PLCAPI and NMAPI. A
29 more general introduction to the MyPLC system can be found at
30 http://svn.planet-lab.org/wiki/MyPLCUserGuide
31
32 %prep
33 %setup -q
34
35 %build
36 rm -rf $RPM_BUILD_ROOT
37
38 # using the new lowercase names, and handling legacy
39 [ -d myplc ] || ln -s MyPLC myplc
40 [ -d plcapi ] || ln -s PLCAPI plcapi
41 [ -d nodemanager ] || ln -s NodeManager nodemanager
42 [ -d monitor ] || ln -s Monitor monitor 
43
44 pushd plcapi
45 # june2011 & f12, latex issues weird warnings, might need to try twice
46 make -C doc PLCAPI.pdf || make -C doc PLCAPI.pdf 
47 # beware that making the pdf file somehow overwrites the html
48 rm -f doc/PLCAPI.html
49 make -C doc PLCAPI.html || make -C doc PLCAPI.html 
50 popd
51
52 pushd nodemanager
53 # beware that making the pdf file somehow overwrites the html
54 make -C doc NMAPI.pdf || make -C doc NMAPI.pdf
55 rm -f doc/NMAPI.html
56 make -C doc NMAPI.html || make -C doc NMAPI.html 
57 popd
58
59 # not everyone rebuilds monitor, so make it optional
60 if [ -d monitor ] ; then
61 pushd monitor
62 # beware that making the pdf file somehow overwrites the html
63 make -C docs Monitor.pdf || make -C docs Monitor.pdf 
64 rm -f docs/Monitor.html
65 make -C docs Monitor.html || make -C docs Monitor.html 
66 popd
67 fi
68
69 %install
70
71 for ext in pdf html; do
72     install -D -m 444 plcapi/doc/PLCAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.$ext
73     install -D -m 444 nodemanager/doc/NMAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.$ext
74     if [ -d monitor ] ; then
75     install -D -m 444 monitor/docs/Monitor.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.$ext
76     fi
77 done
78
79 ./myplc/docbook2drupal.sh "PLC API Documentation (%{pldistro})" \
80     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.html \
81     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.php 
82 ./myplc/docbook2drupal.sh "Node Manager API Documentation (%{pldistro})" \
83     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.html \
84     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.php 
85 if [ -d monitor ] ; then
86 ./myplc/docbook2drupal.sh "Monitor API Documentation (%{pldistro})" \
87     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.html \
88     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.php 
89 fi
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %files
95 %defattr(-,root,root,-)
96 /var/www/html/planetlab/doc/
97
98 %changelog
99 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-1
100 - use nodeimage package instead of deprecated bootstrapfs
101 - has systemd-friendly startup script
102 - plc_reload moved to functions/ - no more service plc reload
103 - no svn keywords anymore
104
105 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-19
106 - new maintenance/monitoring script spot-aliens to look for glitches in refreshpeer+sfa
107
108 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-18
109 - new settings for myslice (comon&tophat) and monitor (db)
110 - removed mentions of chroot in description
111 - can redo myplc-docs on broken f12-latex
112 - set short_open_tag in php.ini
113 - fixes in gen-sites-xml (is that still used ?)
114 - partial-repo.sh has moved to 'build' where it more belongs
115 - tweaks in convenience tool 'mtail'
116
117 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-17
118 - fixed changelog, no change from 5.0-16
119
120 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-16
121 - requires ed for the plc.d/packages step
122 - sirius initscript to handle stop and restart
123
124 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-15
125 - ignore steps in db-config.d if they have a '.' or '~' in their name
126
127 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-14
128 - can redo myplc-docs without the doc for monitor
129
130 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-13
131 - no semantic change - just fixed specfile for git URL
132
133 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
134 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
135
136 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
137 - add missing files to rpm package
138
139 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
140 - mtail.py -s for SFA
141 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
142
143 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
144 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
145
146 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
147 - plc-config-tty now has a validator on booleans
148 - e.g. entering 'True' now is rejected rather than silently recording 'false'
149
150 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
151 - disable mod_wsgi
152
153 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
154 - module name changes
155 - start wsgi support
156
157 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
158 - new setting PLC_RESERVATION_GRANULARITY
159
160 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
161 - * partial-repo.sh script
162 - * preserve key along with certificates
163
164 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
165 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
166
167 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
168 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
169 - new OMF category in the config
170 - create the drl system slice
171
172 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
173 - first working version of 5.0:
174 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
175 - nodefamily is 3-fold with pldistro-fcdistro-arch
176 - new PLC_FLAVOUR config category
177 - reviewed module layout
178 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
179
180 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
181 - support for fedora 12
182 - new package myplc-config for use by sfa
183 - drupal user registration turned off
184
185 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
186 - - fix to make sure when API, BOOT, MONITOR are on the same
187 - machine as WWW that the SSL key,cert for WWW takes precedence.
188 - - Do proper setup for SSL CA certficate to be used as the server
189 - chain.
190
191 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
192 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
193
194 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
195 - depend on pcucontrol
196
197 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
198 - * validate input according to type in plc_config
199 - * added the _genicw system slice
200 - * add tag types for sites and persons
201 - * add new tags for nodes and slices for exemption from myops
202
203 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
204 - turn off drupal on a box that acts as BOOT server but not as WWW server
205 - cleanup some obsolete code for old chroot-jail packaging in the process
206 - new bootcd-kernel script for keeping bootcd variants up2date
207
208 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
209 - Make the /etc/hosts manipulation optional.
210
211 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
212 - Fix SetRole.
213
214 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
215 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
216 - into the DB.
217 - - Added the root ssh key handling support back into plc.d/ssh and the
218 - default xml file.  This should be identical to the way it was in
219 - rc12.
220 - - Added support in the db-config.d/01-init script to register the root
221 - ssh public key with the default administrator.  In this way the root
222 - ssh key will make it into the root account on the nodes by means of
223 - NodeManager's specialaccounts plugin.
224
225 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
226 - db-config ignores sliver tags
227 - sirius's db-config script renamed (was sirious)
228
229 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
230 - fix for silverauth - missing tag types now created at plc startup time
231
232 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
233 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
234
235 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
236 - companion to NM's specialaccounts plugin
237 - do not generate /etc/planetlab/root_ssh_key* anymore
238 - remove related config. variables and conf_files
239
240 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
241 - clarified description text to refer only to plcrt and not other optional
242 - packages.
243
244 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
245 - fixed a bug setting slice multiple attributes with the same tag name
246
247 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
248 - SSL setup for monitor box, and related new config variables
249 - new conf_file for /etc/planetlab/extensions
250 - various tweaks in db-config internals, about initscripts among others
251 - also more messages defined in the db
252
253 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
254 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
255
256 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
257 - bugfix in db-config, tag 4.3-19 would not fly
258
259 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
260 - Refactored db-config into snippets in db-config.d/.
261
262 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
263 - oops, tag 4.3-17 was broken and would not work
264
265 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
266 - bugfix - escape sequences inserted in xml configs
267
268 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
269 - Handle db-config.d files properly.
270
271 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
272 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
273 - than the log file
274 - - Fix db-config to be a bit more cautious when
275 - /etc/planetlab/db-config.d doesn't exist
276 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
277 - .orig files.
278 - - Refactor generic plc-config-tty code into plc_config.py.
279 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
280 - and the list of validated variables and the corresponding
281 - validator() function. This refactoring lets one reuse plc_config.py
282 - as a generic cmdline configuration tool for highly customer MyPLC
283 - like software.
284
285 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
286 - update PCU Type descriptions.
287 - updates to init scripts
288
289 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
290 - requires monitor-pcucontrol so register-wizard can work
291
292 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
293 - cleaned up plc-config-tty, no more need to configure plc-devel
294
295 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
296 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
297
298 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
299 - tighter right permissions on site_admin's authorized keys for more robustness
300
301 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
302 - fix issue in db-config that prevented correct operation
303
304 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
305 - remove support for chroot-based packaging - no crond nor syslog step anymore
306 - plc init script now named plc.init instead of former guest.init
307
308 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
309 - add Monitor to docs build
310
311 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
312 - plc_config.py and plc-config-tty: generalized to work for more diverse
313 - MyPLC configurations.
314 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
315 - deployments and increase the memory limits in php.ini
316 - plc.d/crond: add --full option to vacuumdb
317
318 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
319 - avoid generating ssl certificates for disabled services among www api boot
320
321 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
322 - cleaned up old entries in db-config
323 - mtail more robust
324
325 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
326 - php include path tweaked for plekit includes
327 - reviewed myplc (fka native) packaging dependencies
328 - renumbered 4.3
329
330 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
331 - rename myplc into myplc-chroot and myplc-native into myplc
332 - new settings (shortname & hrn_root) for local peer
333
334 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
335 - First iteration of new data model
336 - Bunch of various fixes
337
338 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
339 - Removed proper ops from planetflow slice.
340
341 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
342 - myplc-native requires myplc-docs
343 - fixed doc build by locating locally installed DTDs at build-time
344
345 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
346 - turn myplc-docs off for now
347
348 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
349 - figures in doc package
350
351 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
352 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
353 - chroot packaging does not have docs anymore
354 - 'cvs' and 'dev' not required from myplc-native anymore
355 - cosmetic change in kml output
356
357
358 %define module_current_branch 4.3