Setting tag myplc-7.0-0
[myplc.git] / myplc-docs.spec
1 %define name myplc-docs
2 %define version 7.0
3 %define taglevel 0
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central (PLC) online documentation
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: Applications/Systems
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15 BuildArch: noarch
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21
22 BuildRequires: docbook-dtds, docbook-utils-pdf
23
24 %define debug_package %{nil}
25
26 %description
27 This package contains the online documentation for MyPLC, i.e. the
28 reference manuals for the two APIs provided: PLCAPI and NMAPI. A
29 more general introduction to the MyPLC system can be found at
30 http://svn.planet-lab.org/wiki/MyPLCUserGuide
31
32 %prep
33 %setup -q
34
35 %build
36 rm -rf $RPM_BUILD_ROOT
37
38 # using the new lowercase names, and handling legacy
39 [ -d myplc ] || ln -s MyPLC myplc
40 [ -d plcapi ] || ln -s PLCAPI plcapi
41 [ -d nodemanager ] || ln -s NodeManager nodemanager
42 [ -d monitor ] || ln -s Monitor monitor 
43
44 pushd plcapi
45 # june2011 & f12, latex issues weird warnings, might need to try twice
46 make -C doc PLCAPI.pdf || make -C doc PLCAPI.pdf 
47 # beware that making the pdf file somehow overwrites the html
48 rm -f doc/PLCAPI.html
49 make -C doc PLCAPI.html || make -C doc PLCAPI.html 
50 popd
51
52 pushd nodemanager
53 # beware that making the pdf file somehow overwrites the html
54 make -C doc NMAPI.pdf || make -C doc NMAPI.pdf
55 rm -f doc/NMAPI.html
56 make -C doc NMAPI.html || make -C doc NMAPI.html 
57 popd
58
59 # not everyone rebuilds monitor, so make it optional
60 if [ -d monitor ] ; then
61 pushd monitor
62 # beware that making the pdf file somehow overwrites the html
63 make -C docs Monitor.pdf || make -C docs Monitor.pdf 
64 rm -f docs/Monitor.html
65 make -C docs Monitor.html || make -C docs Monitor.html 
66 popd
67 fi
68
69 %install
70
71 for ext in pdf html; do
72     install -D -m 444 plcapi/doc/PLCAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.$ext
73     install -D -m 444 nodemanager/doc/NMAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.$ext
74     if [ -d monitor ] ; then
75     install -D -m 444 monitor/docs/Monitor.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.$ext
76     fi
77 done
78
79 ./myplc/docbook2drupal.sh "PLC API Documentation (%{pldistro})" \
80     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.html \
81     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.php 
82 ./myplc/docbook2drupal.sh "Node Manager API Documentation (%{pldistro})" \
83     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.html \
84     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.php 
85 if [ -d monitor ] ; then
86 ./myplc/docbook2drupal.sh "Monitor API Documentation (%{pldistro})" \
87     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.html \
88     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.php 
89 fi
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %files
95 %defattr(-,root,root,-)
96 /var/www/html/planetlab/doc/
97
98 %changelog
99 * Mon Jan 07 2019 Thierry Parmentelat <thierry.parmentelat@inria.fr> - myplc-7.0-0
100 - suitable for python3 on both f27 and f29
101
102 * Sun Jul 16 2017 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-4
103 - takes care of creating plcapi log file
104
105 * Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-3
106 - tweaked renew_reminder for federation
107
108 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-2
109 - tweaks in check-hrns.py
110 - do not require PyXML any more
111
112 * Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-1
113 - review check-hrns for plcapi-5.3
114 - add PLC_HRN_ROOT in usual plc-config-tty's settings
115
116 * Thu Oct 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-5
117 - reduce the scope of check-hrns.py script, now that the SFA layer handles this natively
118 - add an rpm-sign dependency on feedora>=16
119
120 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-4
121 - drop PLC_OMF_XMPP_{USER,PASSWORD} from config
122
123 * Tue Apr 23 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-3
124 - plc.d/gpg now does not rm /dev/random but preserves it
125 - this is because libvirt won't let us run mknod
126
127 * Wed Apr 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-2
128 - fix typo in check-hrns - used to print 'host' while dealing with persons
129
130 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-1
131 - supports httpd config for either mod_python (preferred) or mod_wsgi
132 - requires mod_wsgi on f18 only, otherwise mod_python
133 - supports httpd config for apache 2.4 (f18)
134 - new config variable PLC_FLAVOUR_VIRT_MAP to set 'virt' from fcdistro
135
136 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-6
137 - bugfix in check-vsys-defaults.py
138
139 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-5
140 - define open_basedir in php.ini to stop confidentiality leak
141 - new utility slice_ssh_keys.py for showing sliver keys (OMF interop)
142 - new config setting PLC_VSYS_DEFAULTS for vsys tags granted to all
143 - new utilities check-hrns.py and check-vsys-defaults.py
144
145 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-4
146 - set TimeoutSec to 300 in plc.service
147 - remove ref to deprecated svn $URL$ in db-config usage
148
149 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-3
150 - expose mtail.py as simply mtail
151
152 * Mon May 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-2
153 - plc-kml.py now has support for nodegroups
154
155 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-1
156 - use nodeimage package instead of deprecated bootstrapfs
157 - has systemd-friendly startup script
158 - plc_reload moved to functions/ - no more service plc reload
159 - no svn keywords anymore
160
161 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-19
162 - new maintenance/monitoring script spot-aliens to look for glitches in refreshpeer+sfa
163
164 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-18
165 - new settings for myslice (comon&tophat) and monitor (db)
166 - removed mentions of chroot in description
167 - can redo myplc-docs on broken f12-latex
168 - set short_open_tag in php.ini
169 - fixes in gen-sites-xml (is that still used ?)
170 - partial-repo.sh has moved to 'build' where it more belongs
171 - tweaks in convenience tool 'mtail'
172
173 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-17
174 - fixed changelog, no change from 5.0-16
175
176 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-16
177 - requires ed for the plc.d/packages step
178 - sirius initscript to handle stop and restart
179
180 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-15
181 - ignore steps in db-config.d if they have a '.' or '~' in their name
182
183 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-14
184 - can redo myplc-docs without the doc for monitor
185
186 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-13
187 - no semantic change - just fixed specfile for git URL
188
189 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
190 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
191
192 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
193 - add missing files to rpm package
194
195 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
196 - mtail.py -s for SFA
197 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
198
199 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
200 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
201
202 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
203 - plc-config-tty now has a validator on booleans
204 - e.g. entering 'True' now is rejected rather than silently recording 'false'
205
206 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
207 - disable mod_wsgi
208
209 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
210 - module name changes
211 - start wsgi support
212
213 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
214 - new setting PLC_RESERVATION_GRANULARITY
215
216 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
217 - * partial-repo.sh script
218 - * preserve key along with certificates
219
220 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
221 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
222
223 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
224 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
225 - new OMF category in the config
226 - create the drl system slice
227
228 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
229 - first working version of 5.0:
230 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
231 - nodefamily is 3-fold with pldistro-fcdistro-arch
232 - new PLC_FLAVOUR config category
233 - reviewed module layout
234 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
235
236 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
237 - support for fedora 12
238 - new package myplc-config for use by sfa
239 - drupal user registration turned off
240
241 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
242 - - fix to make sure when API, BOOT, MONITOR are on the same
243 - machine as WWW that the SSL key,cert for WWW takes precedence.
244 - - Do proper setup for SSL CA certficate to be used as the server
245 - chain.
246
247 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
248 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
249
250 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
251 - depend on pcucontrol
252
253 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
254 - * validate input according to type in plc_config
255 - * added the _genicw system slice
256 - * add tag types for sites and persons
257 - * add new tags for nodes and slices for exemption from myops
258
259 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
260 - turn off drupal on a box that acts as BOOT server but not as WWW server
261 - cleanup some obsolete code for old chroot-jail packaging in the process
262 - new bootcd-kernel script for keeping bootcd variants up2date
263
264 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
265 - Make the /etc/hosts manipulation optional.
266
267 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
268 - Fix SetRole.
269
270 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
271 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
272 - into the DB.
273 - - Added the root ssh key handling support back into plc.d/ssh and the
274 - default xml file.  This should be identical to the way it was in
275 - rc12.
276 - - Added support in the db-config.d/01-init script to register the root
277 - ssh public key with the default administrator.  In this way the root
278 - ssh key will make it into the root account on the nodes by means of
279 - NodeManager's specialaccounts plugin.
280
281 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
282 - db-config ignores sliver tags
283 - sirius's db-config script renamed (was sirious)
284
285 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
286 - fix for silverauth - missing tag types now created at plc startup time
287
288 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
289 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
290
291 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
292 - companion to NM's specialaccounts plugin
293 - do not generate /etc/planetlab/root_ssh_key* anymore
294 - remove related config. variables and conf_files
295
296 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
297 - clarified description text to refer only to plcrt and not other optional
298 - packages.
299
300 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
301 - fixed a bug setting slice multiple attributes with the same tag name
302
303 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
304 - SSL setup for monitor box, and related new config variables
305 - new conf_file for /etc/planetlab/extensions
306 - various tweaks in db-config internals, about initscripts among others
307 - also more messages defined in the db
308
309 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
310 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
311
312 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
313 - bugfix in db-config, tag 4.3-19 would not fly
314
315 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
316 - Refactored db-config into snippets in db-config.d/.
317
318 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
319 - oops, tag 4.3-17 was broken and would not work
320
321 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
322 - bugfix - escape sequences inserted in xml configs
323
324 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
325 - Handle db-config.d files properly.
326
327 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
328 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
329 - than the log file
330 - - Fix db-config to be a bit more cautious when
331 - /etc/planetlab/db-config.d doesn't exist
332 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
333 - .orig files.
334 - - Refactor generic plc-config-tty code into plc_config.py.
335 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
336 - and the list of validated variables and the corresponding
337 - validator() function. This refactoring lets one reuse plc_config.py
338 - as a generic cmdline configuration tool for highly customer MyPLC
339 - like software.
340
341 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
342 - update PCU Type descriptions.
343 - updates to init scripts
344
345 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
346 - requires monitor-pcucontrol so register-wizard can work
347
348 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
349 - cleaned up plc-config-tty, no more need to configure plc-devel
350
351 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
352 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
353
354 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
355 - tighter right permissions on site_admin's authorized keys for more robustness
356
357 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
358 - fix issue in db-config that prevented correct operation
359
360 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
361 - remove support for chroot-based packaging - no crond nor syslog step anymore
362 - plc init script now named plc.init instead of former guest.init
363
364 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
365 - add Monitor to docs build
366
367 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
368 - plc_config.py and plc-config-tty: generalized to work for more diverse
369 - MyPLC configurations.
370 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
371 - deployments and increase the memory limits in php.ini
372 - plc.d/crond: add --full option to vacuumdb
373
374 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
375 - avoid generating ssl certificates for disabled services among www api boot
376
377 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
378 - cleaned up old entries in db-config
379 - mtail more robust
380
381 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
382 - php include path tweaked for plekit includes
383 - reviewed myplc (fka native) packaging dependencies
384 - renumbered 4.3
385
386 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
387 - rename myplc into myplc-chroot and myplc-native into myplc
388 - new settings (shortname & hrn_root) for local peer
389
390 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
391 - First iteration of new data model
392 - Bunch of various fixes
393
394 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
395 - Removed proper ops from planetflow slice.
396
397 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
398 - myplc-native requires myplc-docs
399 - fixed doc build by locating locally installed DTDs at build-time
400
401 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
402 - turn myplc-docs off for now
403
404 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
405 - figures in doc package
406
407 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
408 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
409 - chroot packaging does not have docs anymore
410 - 'cvs' and 'dev' not required from myplc-native anymore
411 - cosmetic change in kml output
412
413
414 %define module_current_branch 4.3