Merge branch '4.3' of git.verivue.com:/git/planetlab/myplc into origin-4.3
[myplc.git] / myplc-docs.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-docs
7 %define version 4.3
8 %define taglevel 49
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) online documentation
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 BuildRequires: docbook-dtds, docbook-utils-pdf
28
29 %define debug_package %{nil}
30
31 %description
32 This package contains the online documentation for MyPLC, i.e. the
33 reference manuals for the two APIs provided: PLCAPI and NMAPI. A
34 more general introduction to the MyPLC system can be found at
35 http://svn.planet-lab.org/wiki/MyPLCUserGuide
36
37 %prep
38 %setup -q
39
40 %build
41 rm -rf $RPM_BUILD_ROOT
42
43 # using the new lowercase names, and handling legacy
44 [ -d PLCAPI ] || ln -s plcapi PLCAPI
45 [ -d NodeManager ] || ln -s nodemanager NodeManager
46 [ -d MyPLC ] || ln -s myplc MyPLC
47
48 pushd PLCAPI
49 # beware that making the pdf file somehow overwrites the html
50 make -C doc PLCAPI.pdf 
51 rm -f doc/PLCAPI.html
52 make -C doc PLCAPI.html 
53 popd
54
55 pushd NodeManager
56 # beware that making the pdf file somehow overwrites the html
57 make -C doc NMAPI.pdf 
58 rm -f doc/NMAPI.html
59 make -C doc NMAPI.html 
60 popd
61
62 %install
63
64 for ext in pdf html; do
65     install -D -m 444 PLCAPI/doc/PLCAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.$ext
66     install -D -m 444 NodeManager/doc/NMAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.$ext
67 done
68
69 ./MyPLC/docbook2drupal.sh "PLC API Documentation (%{pldistro})" \
70     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.html \
71     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.php 
72 ./MyPLC/docbook2drupal.sh "Node Manager API Documentation (%{pldistro})" \
73     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.html \
74     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.php 
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %files
80 %defattr(-,root,root,-)
81 /var/www/html/planetlab/doc/
82
83 %changelog
84 * Thu Apr 07 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-49
85 - Remove Monitor references from spec file
86
87 * Wed Apr 06 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-48
88 - Introduce staticroute tagtype
89
90 * Mon Mar 21 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-47
91 - attempt to fix small glitches
92
93 * Wed Mar 16 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-46
94 - enable short_open_tag for backward compatibility
95
96 * Tue Mar 15 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-45
97 - Cherry-pick PHP5 timezone fix form master
98
99 * Thu Feb 03 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-44
100 - pick the greatest version as a kernel
101
102 * Thu Jan 06 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-43
103 - handle directory name changes for myplc-docs package as well
104
105 * Thu Jan 06 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-42
106 - handle directory name changes
107
108 * Thu Nov 18 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-41
109 - Use correct resolv.conf file.
110
111 * Wed Nov 17 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-40
112 - Make dnsmasq usable.
113
114 * Wed Nov 17 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-39
115 - Allow dnsmasq configuration to be extended.
116
117 * Thu Jul 22 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-38
118 - Add DRL slice.
119 - Generalize bootcd-kernel.
120
121 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
122 - support for fedora 12
123 - new package myplc-config for use by sfa
124 - drupal user registration turned off
125
126 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
127 - - fix to make sure when API, BOOT, MONITOR are on the same
128 - machine as WWW that the SSL key,cert for WWW takes precedence.
129 - - Do proper setup for SSL CA certficate to be used as the server
130 - chain.
131
132 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
133 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
134
135 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
136 - depend on pcucontrol
137
138 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
139 - * validate input according to type in plc_config
140 - * added the _genicw system slice
141 - * add tag types for sites and persons
142 - * add new tags for nodes and slices for exemption from myops
143
144 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
145 - turn off drupal on a box that acts as BOOT server but not as WWW server
146 - cleanup some obsolete code for old chroot-jail packaging in the process
147 - new bootcd-kernel script for keeping bootcd variants up2date
148
149 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
150 - Make the /etc/hosts manipulation optional.
151
152 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
153 - Fix SetRole.
154
155 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
156 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
157 - into the DB.
158 - - Added the root ssh key handling support back into plc.d/ssh and the
159 - default xml file.  This should be identical to the way it was in
160 - rc12.
161 - - Added support in the db-config.d/01-init script to register the root
162 - ssh public key with the default administrator.  In this way the root
163 - ssh key will make it into the root account on the nodes by means of
164 - NodeManager's specialaccounts plugin.
165
166 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
167 - db-config ignores sliver tags
168 - sirius's db-config script renamed (was sirious)
169
170 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
171 - fix for silverauth - missing tag types now created at plc startup time
172
173 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
174 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
175
176 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
177 - companion to NM's specialaccounts plugin
178 - do not generate /etc/planetlab/root_ssh_key* anymore
179 - remove related config. variables and conf_files
180
181 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
182 - clarified description text to refer only to plcrt and not other optional
183 - packages.
184
185 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
186 - fixed a bug setting slice multiple attributes with the same tag name
187
188 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
189 - SSL setup for monitor box, and related new config variables
190 - new conf_file for /etc/planetlab/extensions
191 - various tweaks in db-config internals, about initscripts among others
192 - also more messages defined in the db
193
194 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
195 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
196
197 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
198 - bugfix in db-config, tag 4.3-19 would not fly
199
200 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
201 - Refactored db-config into snippets in db-config.d/.
202
203 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
204 - oops, tag 4.3-17 was broken and would not work
205
206 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
207 - bugfix - escape sequences inserted in xml configs
208
209 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
210 - Handle db-config.d files properly.
211
212 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
213 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
214 - than the log file
215 - - Fix db-config to be a bit more cautious when
216 - /etc/planetlab/db-config.d doesn't exist
217 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
218 - .orig files.
219 - - Refactor generic plc-config-tty code into plc_config.py.
220 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
221 - and the list of validated variables and the corresponding
222 - validator() function. This refactoring lets one reuse plc_config.py
223 - as a generic cmdline configuration tool for highly customer MyPLC
224 - like software.
225
226 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
227 - update PCU Type descriptions.
228 - updates to init scripts
229
230 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
231 - requires monitor-pcucontrol so register-wizard can work
232
233 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
234 - cleaned up plc-config-tty, no more need to configure plc-devel
235
236 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
237 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
238
239 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
240 - tighter right permissions on site_admin's authorized keys for more robustness
241
242 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
243 - fix issue in db-config that prevented correct operation
244
245 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
246 - remove support for chroot-based packaging - no crond nor syslog step anymore
247 - plc init script now named plc.init instead of former guest.init
248
249 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
250 - add Monitor to docs build
251
252 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
253 - plc_config.py and plc-config-tty: generalized to work for more diverse
254 - MyPLC configurations.
255 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
256 - deployments and increase the memory limits in php.ini
257 - plc.d/crond: add --full option to vacuumdb
258
259 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
260 - avoid generating ssl certificates for disabled services among www api boot
261
262 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
263 - cleaned up old entries in db-config
264 - mtail more robust
265
266 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
267 - php include path tweaked for plekit includes
268 - reviewed myplc (fka native) packaging dependencies
269 - renumbered 4.3
270
271 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
272 - rename myplc into myplc-chroot and myplc-native into myplc
273 - new settings (shortname & hrn_root) for local peer
274
275 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
276 - First iteration of new data model
277 - Bunch of various fixes
278
279 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
280 - Removed proper ops from planetflow slice.
281
282 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
283 - myplc-native requires myplc-docs
284 - fixed doc build by locating locally installed DTDs at build-time
285
286 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
287 - turn myplc-docs off for now
288
289 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
290 - figures in doc package
291
292 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
293 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
294 - chroot packaging does not have docs anymore
295 - 'cvs' and 'dev' not required from myplc-native anymore
296 - cosmetic change in kml output
297
298
299 %define module_current_branch 4.2