httpd takes care of /var/log/plcapi.log and permissions
[myplc.git] / myplc-docs.spec
1 %define name myplc-docs
2 %define version 5.3
3 %define taglevel 3
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central (PLC) online documentation
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: Applications/Systems
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15 BuildArch: noarch
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21
22 BuildRequires: docbook-dtds, docbook-utils-pdf
23
24 %define debug_package %{nil}
25
26 %description
27 This package contains the online documentation for MyPLC, i.e. the
28 reference manuals for the two APIs provided: PLCAPI and NMAPI. A
29 more general introduction to the MyPLC system can be found at
30 http://svn.planet-lab.org/wiki/MyPLCUserGuide
31
32 %prep
33 %setup -q
34
35 %build
36 rm -rf $RPM_BUILD_ROOT
37
38 # using the new lowercase names, and handling legacy
39 [ -d myplc ] || ln -s MyPLC myplc
40 [ -d plcapi ] || ln -s PLCAPI plcapi
41 [ -d nodemanager ] || ln -s NodeManager nodemanager
42 [ -d monitor ] || ln -s Monitor monitor 
43
44 pushd plcapi
45 # june2011 & f12, latex issues weird warnings, might need to try twice
46 make -C doc PLCAPI.pdf || make -C doc PLCAPI.pdf 
47 # beware that making the pdf file somehow overwrites the html
48 rm -f doc/PLCAPI.html
49 make -C doc PLCAPI.html || make -C doc PLCAPI.html 
50 popd
51
52 pushd nodemanager
53 # beware that making the pdf file somehow overwrites the html
54 make -C doc NMAPI.pdf || make -C doc NMAPI.pdf
55 rm -f doc/NMAPI.html
56 make -C doc NMAPI.html || make -C doc NMAPI.html 
57 popd
58
59 # not everyone rebuilds monitor, so make it optional
60 if [ -d monitor ] ; then
61 pushd monitor
62 # beware that making the pdf file somehow overwrites the html
63 make -C docs Monitor.pdf || make -C docs Monitor.pdf 
64 rm -f docs/Monitor.html
65 make -C docs Monitor.html || make -C docs Monitor.html 
66 popd
67 fi
68
69 %install
70
71 for ext in pdf html; do
72     install -D -m 444 plcapi/doc/PLCAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.$ext
73     install -D -m 444 nodemanager/doc/NMAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.$ext
74     if [ -d monitor ] ; then
75     install -D -m 444 monitor/docs/Monitor.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.$ext
76     fi
77 done
78
79 ./myplc/docbook2drupal.sh "PLC API Documentation (%{pldistro})" \
80     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.html \
81     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.php 
82 ./myplc/docbook2drupal.sh "Node Manager API Documentation (%{pldistro})" \
83     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.html \
84     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.php 
85 if [ -d monitor ] ; then
86 ./myplc/docbook2drupal.sh "Monitor API Documentation (%{pldistro})" \
87     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.html \
88     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.php 
89 fi
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %files
95 %defattr(-,root,root,-)
96 /var/www/html/planetlab/doc/
97
98 %changelog
99 * Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-3
100 - tweaked renew_reminder for federation
101
102 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-2
103 - tweaks in check-hrns.py
104 - do not require PyXML any more
105
106 * Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-1
107 - review check-hrns for plcapi-5.3
108 - add PLC_HRN_ROOT in usual plc-config-tty's settings
109
110 * Thu Oct 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-5
111 - reduce the scope of check-hrns.py script, now that the SFA layer handles this natively
112 - add an rpm-sign dependency on feedora>=16
113
114 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-4
115 - drop PLC_OMF_XMPP_{USER,PASSWORD} from config
116
117 * Tue Apr 23 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-3
118 - plc.d/gpg now does not rm /dev/random but preserves it
119 - this is because libvirt won't let us run mknod
120
121 * Wed Apr 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-2
122 - fix typo in check-hrns - used to print 'host' while dealing with persons
123
124 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-1
125 - supports httpd config for either mod_python (preferred) or mod_wsgi
126 - requires mod_wsgi on f18 only, otherwise mod_python
127 - supports httpd config for apache 2.4 (f18)
128 - new config variable PLC_FLAVOUR_VIRT_MAP to set 'virt' from fcdistro
129
130 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-6
131 - bugfix in check-vsys-defaults.py
132
133 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-5
134 - define open_basedir in php.ini to stop confidentiality leak
135 - new utility slice_ssh_keys.py for showing sliver keys (OMF interop)
136 - new config setting PLC_VSYS_DEFAULTS for vsys tags granted to all
137 - new utilities check-hrns.py and check-vsys-defaults.py
138
139 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-4
140 - set TimeoutSec to 300 in plc.service
141 - remove ref to deprecated svn $URL$ in db-config usage
142
143 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-3
144 - expose mtail.py as simply mtail
145
146 * Mon May 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-2
147 - plc-kml.py now has support for nodegroups
148
149 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-1
150 - use nodeimage package instead of deprecated bootstrapfs
151 - has systemd-friendly startup script
152 - plc_reload moved to functions/ - no more service plc reload
153 - no svn keywords anymore
154
155 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-19
156 - new maintenance/monitoring script spot-aliens to look for glitches in refreshpeer+sfa
157
158 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-18
159 - new settings for myslice (comon&tophat) and monitor (db)
160 - removed mentions of chroot in description
161 - can redo myplc-docs on broken f12-latex
162 - set short_open_tag in php.ini
163 - fixes in gen-sites-xml (is that still used ?)
164 - partial-repo.sh has moved to 'build' where it more belongs
165 - tweaks in convenience tool 'mtail'
166
167 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-17
168 - fixed changelog, no change from 5.0-16
169
170 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-16
171 - requires ed for the plc.d/packages step
172 - sirius initscript to handle stop and restart
173
174 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-15
175 - ignore steps in db-config.d if they have a '.' or '~' in their name
176
177 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-14
178 - can redo myplc-docs without the doc for monitor
179
180 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-13
181 - no semantic change - just fixed specfile for git URL
182
183 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
184 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
185
186 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
187 - add missing files to rpm package
188
189 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
190 - mtail.py -s for SFA
191 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
192
193 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
194 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
195
196 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
197 - plc-config-tty now has a validator on booleans
198 - e.g. entering 'True' now is rejected rather than silently recording 'false'
199
200 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
201 - disable mod_wsgi
202
203 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
204 - module name changes
205 - start wsgi support
206
207 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
208 - new setting PLC_RESERVATION_GRANULARITY
209
210 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
211 - * partial-repo.sh script
212 - * preserve key along with certificates
213
214 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
215 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
216
217 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
218 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
219 - new OMF category in the config
220 - create the drl system slice
221
222 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
223 - first working version of 5.0:
224 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
225 - nodefamily is 3-fold with pldistro-fcdistro-arch
226 - new PLC_FLAVOUR config category
227 - reviewed module layout
228 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
229
230 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
231 - support for fedora 12
232 - new package myplc-config for use by sfa
233 - drupal user registration turned off
234
235 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
236 - - fix to make sure when API, BOOT, MONITOR are on the same
237 - machine as WWW that the SSL key,cert for WWW takes precedence.
238 - - Do proper setup for SSL CA certficate to be used as the server
239 - chain.
240
241 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
242 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
243
244 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
245 - depend on pcucontrol
246
247 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
248 - * validate input according to type in plc_config
249 - * added the _genicw system slice
250 - * add tag types for sites and persons
251 - * add new tags for nodes and slices for exemption from myops
252
253 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
254 - turn off drupal on a box that acts as BOOT server but not as WWW server
255 - cleanup some obsolete code for old chroot-jail packaging in the process
256 - new bootcd-kernel script for keeping bootcd variants up2date
257
258 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
259 - Make the /etc/hosts manipulation optional.
260
261 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
262 - Fix SetRole.
263
264 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
265 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
266 - into the DB.
267 - - Added the root ssh key handling support back into plc.d/ssh and the
268 - default xml file.  This should be identical to the way it was in
269 - rc12.
270 - - Added support in the db-config.d/01-init script to register the root
271 - ssh public key with the default administrator.  In this way the root
272 - ssh key will make it into the root account on the nodes by means of
273 - NodeManager's specialaccounts plugin.
274
275 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
276 - db-config ignores sliver tags
277 - sirius's db-config script renamed (was sirious)
278
279 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
280 - fix for silverauth - missing tag types now created at plc startup time
281
282 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
283 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
284
285 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
286 - companion to NM's specialaccounts plugin
287 - do not generate /etc/planetlab/root_ssh_key* anymore
288 - remove related config. variables and conf_files
289
290 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
291 - clarified description text to refer only to plcrt and not other optional
292 - packages.
293
294 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
295 - fixed a bug setting slice multiple attributes with the same tag name
296
297 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
298 - SSL setup for monitor box, and related new config variables
299 - new conf_file for /etc/planetlab/extensions
300 - various tweaks in db-config internals, about initscripts among others
301 - also more messages defined in the db
302
303 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
304 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
305
306 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
307 - bugfix in db-config, tag 4.3-19 would not fly
308
309 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
310 - Refactored db-config into snippets in db-config.d/.
311
312 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
313 - oops, tag 4.3-17 was broken and would not work
314
315 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
316 - bugfix - escape sequences inserted in xml configs
317
318 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
319 - Handle db-config.d files properly.
320
321 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
322 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
323 - than the log file
324 - - Fix db-config to be a bit more cautious when
325 - /etc/planetlab/db-config.d doesn't exist
326 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
327 - .orig files.
328 - - Refactor generic plc-config-tty code into plc_config.py.
329 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
330 - and the list of validated variables and the corresponding
331 - validator() function. This refactoring lets one reuse plc_config.py
332 - as a generic cmdline configuration tool for highly customer MyPLC
333 - like software.
334
335 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
336 - update PCU Type descriptions.
337 - updates to init scripts
338
339 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
340 - requires monitor-pcucontrol so register-wizard can work
341
342 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
343 - cleaned up plc-config-tty, no more need to configure plc-devel
344
345 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
346 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
347
348 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
349 - tighter right permissions on site_admin's authorized keys for more robustness
350
351 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
352 - fix issue in db-config that prevented correct operation
353
354 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
355 - remove support for chroot-based packaging - no crond nor syslog step anymore
356 - plc init script now named plc.init instead of former guest.init
357
358 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
359 - add Monitor to docs build
360
361 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
362 - plc_config.py and plc-config-tty: generalized to work for more diverse
363 - MyPLC configurations.
364 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
365 - deployments and increase the memory limits in php.ini
366 - plc.d/crond: add --full option to vacuumdb
367
368 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
369 - avoid generating ssl certificates for disabled services among www api boot
370
371 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
372 - cleaned up old entries in db-config
373 - mtail more robust
374
375 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
376 - php include path tweaked for plekit includes
377 - reviewed myplc (fka native) packaging dependencies
378 - renumbered 4.3
379
380 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
381 - rename myplc into myplc-chroot and myplc-native into myplc
382 - new settings (shortname & hrn_root) for local peer
383
384 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
385 - First iteration of new data model
386 - Bunch of various fixes
387
388 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
389 - Removed proper ops from planetflow slice.
390
391 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
392 - myplc-native requires myplc-docs
393 - fixed doc build by locating locally installed DTDs at build-time
394
395 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
396 - turn myplc-docs off for now
397
398 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
399 - figures in doc package
400
401 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
402 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
403 - chroot packaging does not have docs anymore
404 - 'cvs' and 'dev' not required from myplc-native anymore
405 - cosmetic change in kml output
406
407
408 %define module_current_branch 4.3