fix resolv.conf issue on plc
[myplc.git] / myplc-docs.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-docs
7 %define version 4.3
8 %define taglevel 53
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) online documentation
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 BuildRequires: docbook-dtds, docbook-utils-pdf
28
29 %define debug_package %{nil}
30
31 %description
32 This package contains the online documentation for MyPLC, i.e. the
33 reference manuals for the two APIs provided: PLCAPI and NMAPI. A
34 more general introduction to the MyPLC system can be found at
35 http://svn.planet-lab.org/wiki/MyPLCUserGuide
36
37 %prep
38 %setup -q
39
40 %build
41 rm -rf $RPM_BUILD_ROOT
42
43 # using the new lowercase names, and handling legacy
44 [ -d PLCAPI ] || ln -s plcapi PLCAPI
45 [ -d NodeManager ] || ln -s nodemanager NodeManager
46 [ -d MyPLC ] || ln -s myplc MyPLC
47
48 pushd PLCAPI
49 # beware that making the pdf file somehow overwrites the html
50 make -C doc PLCAPI.pdf 
51 rm -f doc/PLCAPI.html
52 make -C doc PLCAPI.html 
53 popd
54
55 pushd NodeManager
56 # beware that making the pdf file somehow overwrites the html
57 make -C doc NMAPI.pdf 
58 rm -f doc/NMAPI.html
59 make -C doc NMAPI.html 
60 popd
61
62 %install
63
64 for ext in pdf html; do
65     install -D -m 444 PLCAPI/doc/PLCAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.$ext
66     install -D -m 444 NodeManager/doc/NMAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.$ext
67 done
68
69 ./MyPLC/docbook2drupal.sh "PLC API Documentation (%{pldistro})" \
70     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.html \
71     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.php 
72 ./MyPLC/docbook2drupal.sh "Node Manager API Documentation (%{pldistro})" \
73     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.html \
74     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.php 
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %files
80 %defattr(-,root,root,-)
81 /var/www/html/planetlab/doc/
82
83 %changelog
84 * Wed May 04 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-53
85 - VCDN-333: Node Statistics selected incorrect interface and accordingly COMON gets no stats from node. : Now node name can only be used for primary interface
86 - fix gpg update.
87 - this issue raises in gpg2 (hangs in SL6), but it's considered as a bug in gpg1
88 - https://bugs.g10code.com/gnupg/issue1122
89
90 * Tue May 03 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-52
91 - use lower case variable names to workaround http://projects.puppetlabs.com/issues/3939
92
93 * Tue May 03 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-51
94 - generate plc_config.rb via plc-config
95
96 * Fri Apr 08 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-50
97 - Do not preserve /etc/planetlab on upgrade operations
98
99 * Thu Apr 07 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-49
100 - Remove Monitor references from spec file
101
102 * Wed Apr 06 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-48
103 - Introduce staticroute tagtype
104
105 * Mon Mar 21 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-47
106 - attempt to fix small glitches
107
108 * Wed Mar 16 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-46
109 - enable short_open_tag for backward compatibility
110
111 * Tue Mar 15 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-45
112 - Cherry-pick PHP5 timezone fix form master
113
114 * Thu Feb 03 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-44
115 - pick the greatest version as a kernel
116
117 * Thu Jan 06 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-43
118 - handle directory name changes for myplc-docs package as well
119
120 * Thu Jan 06 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-42
121 - handle directory name changes
122
123 * Thu Nov 18 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-41
124 - Use correct resolv.conf file.
125
126 * Wed Nov 17 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-40
127 - Make dnsmasq usable.
128
129 * Wed Nov 17 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-39
130 - Allow dnsmasq configuration to be extended.
131
132 * Thu Jul 22 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-38
133 - Add DRL slice.
134 - Generalize bootcd-kernel.
135
136 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
137 - support for fedora 12
138 - new package myplc-config for use by sfa
139 - drupal user registration turned off
140
141 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
142 - - fix to make sure when API, BOOT, MONITOR are on the same
143 - machine as WWW that the SSL key,cert for WWW takes precedence.
144 - - Do proper setup for SSL CA certficate to be used as the server
145 - chain.
146
147 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
148 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
149
150 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
151 - depend on pcucontrol
152
153 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
154 - * validate input according to type in plc_config
155 - * added the _genicw system slice
156 - * add tag types for sites and persons
157 - * add new tags for nodes and slices for exemption from myops
158
159 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
160 - turn off drupal on a box that acts as BOOT server but not as WWW server
161 - cleanup some obsolete code for old chroot-jail packaging in the process
162 - new bootcd-kernel script for keeping bootcd variants up2date
163
164 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
165 - Make the /etc/hosts manipulation optional.
166
167 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
168 - Fix SetRole.
169
170 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
171 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
172 - into the DB.
173 - - Added the root ssh key handling support back into plc.d/ssh and the
174 - default xml file.  This should be identical to the way it was in
175 - rc12.
176 - - Added support in the db-config.d/01-init script to register the root
177 - ssh public key with the default administrator.  In this way the root
178 - ssh key will make it into the root account on the nodes by means of
179 - NodeManager's specialaccounts plugin.
180
181 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
182 - db-config ignores sliver tags
183 - sirius's db-config script renamed (was sirious)
184
185 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
186 - fix for silverauth - missing tag types now created at plc startup time
187
188 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
189 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
190
191 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
192 - companion to NM's specialaccounts plugin
193 - do not generate /etc/planetlab/root_ssh_key* anymore
194 - remove related config. variables and conf_files
195
196 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
197 - clarified description text to refer only to plcrt and not other optional
198 - packages.
199
200 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
201 - fixed a bug setting slice multiple attributes with the same tag name
202
203 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
204 - SSL setup for monitor box, and related new config variables
205 - new conf_file for /etc/planetlab/extensions
206 - various tweaks in db-config internals, about initscripts among others
207 - also more messages defined in the db
208
209 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
210 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
211
212 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
213 - bugfix in db-config, tag 4.3-19 would not fly
214
215 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
216 - Refactored db-config into snippets in db-config.d/.
217
218 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
219 - oops, tag 4.3-17 was broken and would not work
220
221 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
222 - bugfix - escape sequences inserted in xml configs
223
224 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
225 - Handle db-config.d files properly.
226
227 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
228 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
229 - than the log file
230 - - Fix db-config to be a bit more cautious when
231 - /etc/planetlab/db-config.d doesn't exist
232 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
233 - .orig files.
234 - - Refactor generic plc-config-tty code into plc_config.py.
235 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
236 - and the list of validated variables and the corresponding
237 - validator() function. This refactoring lets one reuse plc_config.py
238 - as a generic cmdline configuration tool for highly customer MyPLC
239 - like software.
240
241 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
242 - update PCU Type descriptions.
243 - updates to init scripts
244
245 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
246 - requires monitor-pcucontrol so register-wizard can work
247
248 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
249 - cleaned up plc-config-tty, no more need to configure plc-devel
250
251 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
252 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
253
254 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
255 - tighter right permissions on site_admin's authorized keys for more robustness
256
257 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
258 - fix issue in db-config that prevented correct operation
259
260 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
261 - remove support for chroot-based packaging - no crond nor syslog step anymore
262 - plc init script now named plc.init instead of former guest.init
263
264 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
265 - add Monitor to docs build
266
267 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
268 - plc_config.py and plc-config-tty: generalized to work for more diverse
269 - MyPLC configurations.
270 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
271 - deployments and increase the memory limits in php.ini
272 - plc.d/crond: add --full option to vacuumdb
273
274 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
275 - avoid generating ssl certificates for disabled services among www api boot
276
277 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
278 - cleaned up old entries in db-config
279 - mtail more robust
280
281 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
282 - php include path tweaked for plekit includes
283 - reviewed myplc (fka native) packaging dependencies
284 - renumbered 4.3
285
286 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
287 - rename myplc into myplc-chroot and myplc-native into myplc
288 - new settings (shortname & hrn_root) for local peer
289
290 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
291 - First iteration of new data model
292 - Bunch of various fixes
293
294 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
295 - Removed proper ops from planetflow slice.
296
297 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
298 - myplc-native requires myplc-docs
299 - fixed doc build by locating locally installed DTDs at build-time
300
301 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
302 - turn myplc-docs off for now
303
304 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
305 - figures in doc package
306
307 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
308 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
309 - chroot packaging does not have docs anymore
310 - 'cvs' and 'dev' not required from myplc-native anymore
311 - cosmetic change in kml output
312
313
314 %define module_current_branch 4.2