egrep is obsolete
[myplc.git] / myplc-docs.spec
1 %define name myplc-docs
2 %define version 7.1
3 %define taglevel 0
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central (PLC) online documentation
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: Applications/Systems
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15 BuildArch: noarch
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21
22 BuildRequires: docbook-dtds, docbook-utils-pdf
23
24 %define debug_package %{nil}
25
26 %description
27 This package contains the online documentation for MyPLC, i.e. the
28 reference manuals for the two APIs provided: PLCAPI and NMAPI. A
29 more general introduction to the MyPLC system can be found at
30 http://svn.planet-lab.org/wiki/MyPLCUserGuide
31
32 %prep
33 %setup -q
34
35 %build
36 rm -rf $RPM_BUILD_ROOT
37
38 # using the new lowercase names, and handling legacy
39 [ -d myplc ] || ln -s MyPLC myplc
40 [ -d plcapi ] || ln -s PLCAPI plcapi
41 [ -d nodemanager ] || ln -s NodeManager nodemanager
42 [ -d monitor ] || ln -s Monitor monitor
43
44 pushd plcapi
45 # june2011 & f12, latex issues weird warnings, might need to try twice
46 make -C doc PLCAPI.pdf || make -C doc PLCAPI.pdf
47 # beware that making the pdf file somehow overwrites the html
48 rm -f doc/PLCAPI.html
49 make -C doc PLCAPI.html || make -C doc PLCAPI.html
50 popd
51
52 # nodemanager is now optional
53 if [ -d nodemanager/doc ] ; then
54 pushd nodemanager
55 # beware that making the pdf file somehow overwrites the html
56 make -C doc NMAPI.pdf || make -C doc NMAPI.pdf
57 rm -f doc/NMAPI.html
58 make -C doc NMAPI.html || make -C doc NMAPI.html
59 popd
60 fi
61
62 # not everyone rebuilds monitor, so make it optional
63 if [ -d monitor/docs ] ; then
64 pushd monitor
65 # beware that making the pdf file somehow overwrites the html
66 make -C docs Monitor.pdf || make -C docs Monitor.pdf
67 rm -f docs/Monitor.html
68 make -C docs Monitor.html || make -C docs Monitor.html
69 popd
70 fi
71
72 %install
73
74 for ext in pdf html; do
75     install -D -m 444 plcapi/doc/PLCAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.$ext
76     if [ -d nodemanager/doc ] ; then
77     install -D -m 444 nodemanager/doc/NMAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.$ext
78     fi
79     if [ -d monitor/docs ] ; then
80     install -D -m 444 monitor/docs/Monitor.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.$ext
81     fi
82 done
83
84 ./myplc/docbook2drupal.sh "PLC API Documentation (%{pldistro})" \
85     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.html \
86     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.php
87 if [ -d nodemanager/doc ] ; then
88 ./myplc/docbook2drupal.sh "Node Manager API Documentation (%{pldistro})" \
89     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.html \
90     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.php
91 fi
92 if [ -d monitor/docs ] ; then
93 ./myplc/docbook2drupal.sh "Monitor API Documentation (%{pldistro})" \
94     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.html \
95     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.php
96 fi
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %files
102 %defattr(-,root,root,-)
103 /var/www/html/planetlab/doc/
104
105 %changelog
106 * Sat Apr 30 2022 Thierry Parmentelat <thierry.parmentelat@inria.fr> - myplc-7.1-0
107 - ready on f35
108
109 * Mon Jan 07 2019 Thierry Parmentelat <thierry.parmentelat@inria.fr> - myplc-7.0-0
110 - suitable for python3 on both f27 and f29
111
112 * Sun Jul 16 2017 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-4
113 - takes care of creating plcapi log file
114
115 * Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-3
116 - tweaked renew_reminder for federation
117
118 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-2
119 - tweaks in check-hrns.py
120 - do not require PyXML any more
121
122 * Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-1
123 - review check-hrns for plcapi-5.3
124 - add PLC_HRN_ROOT in usual plc-config-tty's settings
125
126 * Thu Oct 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-5
127 - reduce the scope of check-hrns.py script, now that the SFA layer handles this natively
128 - add an rpm-sign dependency on feedora>=16
129
130 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-4
131 - drop PLC_OMF_XMPP_{USER,PASSWORD} from config
132
133 * Tue Apr 23 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-3
134 - plc.d/gpg now does not rm /dev/random but preserves it
135 - this is because libvirt won't let us run mknod
136
137 * Wed Apr 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-2
138 - fix typo in check-hrns - used to print 'host' while dealing with persons
139
140 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-1
141 - supports httpd config for either mod_python (preferred) or mod_wsgi
142 - requires mod_wsgi on f18 only, otherwise mod_python
143 - supports httpd config for apache 2.4 (f18)
144 - new config variable PLC_FLAVOUR_VIRT_MAP to set 'virt' from fcdistro
145
146 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-6
147 - bugfix in check-vsys-defaults.py
148
149 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-5
150 - define open_basedir in php.ini to stop confidentiality leak
151 - new utility slice_ssh_keys.py for showing sliver keys (OMF interop)
152 - new config setting PLC_VSYS_DEFAULTS for vsys tags granted to all
153 - new utilities check-hrns.py and check-vsys-defaults.py
154
155 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-4
156 - set TimeoutSec to 300 in plc.service
157 - remove ref to deprecated svn $URL$ in db-config usage
158
159 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-3
160 - expose mtail.py as simply mtail
161
162 * Mon May 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-2
163 - plc-kml.py now has support for nodegroups
164
165 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-1
166 - use nodeimage package instead of deprecated bootstrapfs
167 - has systemd-friendly startup script
168 - plc_reload moved to functions/ - no more service plc reload
169 - no svn keywords anymore
170
171 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-19
172 - new maintenance/monitoring script spot-aliens to look for glitches in refreshpeer+sfa
173
174 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-18
175 - new settings for myslice (comon&tophat) and monitor (db)
176 - removed mentions of chroot in description
177 - can redo myplc-docs on broken f12-latex
178 - set short_open_tag in php.ini
179 - fixes in gen-sites-xml (is that still used ?)
180 - partial-repo.sh has moved to 'build' where it more belongs
181 - tweaks in convenience tool 'mtail'
182
183 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-17
184 - fixed changelog, no change from 5.0-16
185
186 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-16
187 - requires ed for the plc.d/packages step
188 - sirius initscript to handle stop and restart
189
190 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-15
191 - ignore steps in db-config.d if they have a '.' or '~' in their name
192
193 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-14
194 - can redo myplc-docs without the doc for monitor
195
196 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-13
197 - no semantic change - just fixed specfile for git URL
198
199 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
200 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
201
202 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
203 - add missing files to rpm package
204
205 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
206 - mtail.py -s for SFA
207 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
208
209 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
210 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
211
212 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
213 - plc-config-tty now has a validator on booleans
214 - e.g. entering 'True' now is rejected rather than silently recording 'false'
215
216 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
217 - disable mod_wsgi
218
219 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
220 - module name changes
221 - start wsgi support
222
223 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
224 - new setting PLC_RESERVATION_GRANULARITY
225
226 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
227 - * partial-repo.sh script
228 - * preserve key along with certificates
229
230 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
231 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
232
233 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
234 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
235 - new OMF category in the config
236 - create the drl system slice
237
238 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
239 - first working version of 5.0:
240 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
241 - nodefamily is 3-fold with pldistro-fcdistro-arch
242 - new PLC_FLAVOUR config category
243 - reviewed module layout
244 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
245
246 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
247 - support for fedora 12
248 - new package myplc-config for use by sfa
249 - drupal user registration turned off
250
251 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
252 - - fix to make sure when API, BOOT, MONITOR are on the same
253 - machine as WWW that the SSL key,cert for WWW takes precedence.
254 - - Do proper setup for SSL CA certficate to be used as the server
255 - chain.
256
257 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
258 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
259
260 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
261 - depend on pcucontrol
262
263 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
264 - * validate input according to type in plc_config
265 - * added the _genicw system slice
266 - * add tag types for sites and persons
267 - * add new tags for nodes and slices for exemption from myops
268
269 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
270 - turn off drupal on a box that acts as BOOT server but not as WWW server
271 - cleanup some obsolete code for old chroot-jail packaging in the process
272 - new bootcd-kernel script for keeping bootcd variants up2date
273
274 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
275 - Make the /etc/hosts manipulation optional.
276
277 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
278 - Fix SetRole.
279
280 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
281 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
282 - into the DB.
283 - - Added the root ssh key handling support back into plc.d/ssh and the
284 - default xml file.  This should be identical to the way it was in
285 - rc12.
286 - - Added support in the db-config.d/01-init script to register the root
287 - ssh public key with the default administrator.  In this way the root
288 - ssh key will make it into the root account on the nodes by means of
289 - NodeManager's specialaccounts plugin.
290
291 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
292 - db-config ignores sliver tags
293 - sirius's db-config script renamed (was sirious)
294
295 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
296 - fix for silverauth - missing tag types now created at plc startup time
297
298 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
299 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
300
301 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
302 - companion to NM's specialaccounts plugin
303 - do not generate /etc/planetlab/root_ssh_key* anymore
304 - remove related config. variables and conf_files
305
306 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
307 - clarified description text to refer only to plcrt and not other optional
308 - packages.
309
310 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
311 - fixed a bug setting slice multiple attributes with the same tag name
312
313 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
314 - SSL setup for monitor box, and related new config variables
315 - new conf_file for /etc/planetlab/extensions
316 - various tweaks in db-config internals, about initscripts among others
317 - also more messages defined in the db
318
319 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
320 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
321
322 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
323 - bugfix in db-config, tag 4.3-19 would not fly
324
325 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
326 - Refactored db-config into snippets in db-config.d/.
327
328 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
329 - oops, tag 4.3-17 was broken and would not work
330
331 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
332 - bugfix - escape sequences inserted in xml configs
333
334 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
335 - Handle db-config.d files properly.
336
337 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
338 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
339 - than the log file
340 - - Fix db-config to be a bit more cautious when
341 - /etc/planetlab/db-config.d doesn't exist
342 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
343 - .orig files.
344 - - Refactor generic plc-config-tty code into plc_config.py.
345 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
346 - and the list of validated variables and the corresponding
347 - validator() function. This refactoring lets one reuse plc_config.py
348 - as a generic cmdline configuration tool for highly customer MyPLC
349 - like software.
350
351 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
352 - update PCU Type descriptions.
353 - updates to init scripts
354
355 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
356 - requires monitor-pcucontrol so register-wizard can work
357
358 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
359 - cleaned up plc-config-tty, no more need to configure plc-devel
360
361 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
362 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
363
364 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
365 - tighter right permissions on site_admin's authorized keys for more robustness
366
367 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
368 - fix issue in db-config that prevented correct operation
369
370 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
371 - remove support for chroot-based packaging - no crond nor syslog step anymore
372 - plc init script now named plc.init instead of former guest.init
373
374 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
375 - add Monitor to docs build
376
377 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
378 - plc_config.py and plc-config-tty: generalized to work for more diverse
379 - MyPLC configurations.
380 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
381 - deployments and increase the memory limits in php.ini
382 - plc.d/crond: add --full option to vacuumdb
383
384 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
385 - avoid generating ssl certificates for disabled services among www api boot
386
387 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
388 - cleaned up old entries in db-config
389 - mtail more robust
390
391 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
392 - php include path tweaked for plekit includes
393 - reviewed myplc (fka native) packaging dependencies
394 - renumbered 4.3
395
396 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
397 - rename myplc into myplc-chroot and myplc-native into myplc
398 - new settings (shortname & hrn_root) for local peer
399
400 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
401 - First iteration of new data model
402 - Bunch of various fixes
403
404 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
405 - Removed proper ops from planetflow slice.
406
407 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
408 - myplc-native requires myplc-docs
409 - fixed doc build by locating locally installed DTDs at build-time
410
411 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
412 - turn myplc-docs off for now
413
414 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
415 - figures in doc package
416
417 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
418 - no more doc packaged outside of myplc-docs - doc/ cleaned up
419 - chroot packaging does not have docs anymore
420 - 'cvs' and 'dev' not required from myplc-native anymore
421 - cosmetic change in kml output
422
423
424 %define module_current_branch 4.3