Merge branch '4.3' of ssh://git.planet-lab.org/git/myplc into 4.3
[myplc.git] / myplc-docs.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-docs
7 %define version 4.3
8 %define taglevel 42
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) online documentation
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 BuildRequires: docbook-dtds, docbook-utils-pdf
28
29 %define debug_package %{nil}
30
31 %description
32 This package contains the online documentation for MyPLC, i.e. the
33 reference manuals for the two APIs provided: PLCAPI and NMAPI. A
34 more general introduction to the MyPLC system can be found at
35 http://svn.planet-lab.org/wiki/MyPLCUserGuide
36
37 %prep
38 %setup -q
39
40 %build
41 rm -rf $RPM_BUILD_ROOT
42
43 # using the new lowercase names, and handling legacy
44 [ -d PLCAPI ] || ln -s plcapi PLCAPI
45 [ -d Monitor ] || ln -s monitor Monitor
46 [ -d NodeManager ] || ln -s nodemanager NodeManager
47 [ -d MyPLC ] || ln -s myplc MyPLC
48
49 pushd PLCAPI
50 # beware that making the pdf file somehow overwrites the html
51 make -C doc PLCAPI.pdf 
52 rm -f doc/PLCAPI.html
53 make -C doc PLCAPI.html 
54 popd
55
56 pushd NodeManager
57 # beware that making the pdf file somehow overwrites the html
58 make -C doc NMAPI.pdf 
59 rm -f doc/NMAPI.html
60 make -C doc NMAPI.html 
61 popd
62
63 pushd Monitor
64 # beware that making the pdf file somehow overwrites the html
65 make -C docs Monitor.pdf 
66 rm -f docs/Monitor.html
67 make -C docs Monitor.html 
68 popd
69
70 %install
71
72 for ext in pdf html; do
73     install -D -m 444 PLCAPI/doc/PLCAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.$ext
74     install -D -m 444 NodeManager/doc/NMAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.$ext
75     install -D -m 444 Monitor/docs/Monitor.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.$ext
76 done
77
78 ./MyPLC/docbook2drupal.sh "PLC API Documentation (%{pldistro})" \
79     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.html \
80     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.php 
81 ./MyPLC/docbook2drupal.sh "Node Manager API Documentation (%{pldistro})" \
82     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.html \
83     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.php 
84 ./MyPLC/docbook2drupal.sh "Monitor API Documentation (%{pldistro})" \
85     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.html \
86     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.php 
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %files
92 %defattr(-,root,root,-)
93 /var/www/html/planetlab/doc/
94
95 %changelog
96 * Thu Jan 06 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-42
97 - handle directory name changes
98
99 * Thu Nov 18 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-41
100 - Use correct resolv.conf file.
101
102 * Wed Nov 17 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-40
103 - Make dnsmasq usable.
104
105 * Wed Nov 17 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-39
106 - Allow dnsmasq configuration to be extended.
107
108 * Thu Jul 22 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-38
109 - Add DRL slice.
110 - Generalize bootcd-kernel.
111
112 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
113 - support for fedora 12
114 - new package myplc-config for use by sfa
115 - drupal user registration turned off
116
117 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
118 - - fix to make sure when API, BOOT, MONITOR are on the same
119 - machine as WWW that the SSL key,cert for WWW takes precedence.
120 - - Do proper setup for SSL CA certficate to be used as the server
121 - chain.
122
123 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
124 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
125
126 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
127 - depend on pcucontrol
128
129 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
130 - * validate input according to type in plc_config
131 - * added the _genicw system slice
132 - * add tag types for sites and persons
133 - * add new tags for nodes and slices for exemption from myops
134
135 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
136 - turn off drupal on a box that acts as BOOT server but not as WWW server
137 - cleanup some obsolete code for old chroot-jail packaging in the process
138 - new bootcd-kernel script for keeping bootcd variants up2date
139
140 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
141 - Make the /etc/hosts manipulation optional.
142
143 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
144 - Fix SetRole.
145
146 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
147 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
148 - into the DB.
149 - - Added the root ssh key handling support back into plc.d/ssh and the
150 - default xml file.  This should be identical to the way it was in
151 - rc12.
152 - - Added support in the db-config.d/01-init script to register the root
153 - ssh public key with the default administrator.  In this way the root
154 - ssh key will make it into the root account on the nodes by means of
155 - NodeManager's specialaccounts plugin.
156
157 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
158 - db-config ignores sliver tags
159 - sirius's db-config script renamed (was sirious)
160
161 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
162 - fix for silverauth - missing tag types now created at plc startup time
163
164 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
165 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
166
167 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
168 - companion to NM's specialaccounts plugin
169 - do not generate /etc/planetlab/root_ssh_key* anymore
170 - remove related config. variables and conf_files
171
172 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
173 - clarified description text to refer only to plcrt and not other optional
174 - packages.
175
176 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
177 - fixed a bug setting slice multiple attributes with the same tag name
178
179 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
180 - SSL setup for monitor box, and related new config variables
181 - new conf_file for /etc/planetlab/extensions
182 - various tweaks in db-config internals, about initscripts among others
183 - also more messages defined in the db
184
185 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
186 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
187
188 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
189 - bugfix in db-config, tag 4.3-19 would not fly
190
191 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
192 - Refactored db-config into snippets in db-config.d/.
193
194 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
195 - oops, tag 4.3-17 was broken and would not work
196
197 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
198 - bugfix - escape sequences inserted in xml configs
199
200 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
201 - Handle db-config.d files properly.
202
203 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
204 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
205 - than the log file
206 - - Fix db-config to be a bit more cautious when
207 - /etc/planetlab/db-config.d doesn't exist
208 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
209 - .orig files.
210 - - Refactor generic plc-config-tty code into plc_config.py.
211 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
212 - and the list of validated variables and the corresponding
213 - validator() function. This refactoring lets one reuse plc_config.py
214 - as a generic cmdline configuration tool for highly customer MyPLC
215 - like software.
216
217 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
218 - update PCU Type descriptions.
219 - updates to init scripts
220
221 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
222 - requires monitor-pcucontrol so register-wizard can work
223
224 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
225 - cleaned up plc-config-tty, no more need to configure plc-devel
226
227 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
228 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
229
230 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
231 - tighter right permissions on site_admin's authorized keys for more robustness
232
233 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
234 - fix issue in db-config that prevented correct operation
235
236 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
237 - remove support for chroot-based packaging - no crond nor syslog step anymore
238 - plc init script now named plc.init instead of former guest.init
239
240 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
241 - add Monitor to docs build
242
243 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
244 - plc_config.py and plc-config-tty: generalized to work for more diverse
245 - MyPLC configurations.
246 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
247 - deployments and increase the memory limits in php.ini
248 - plc.d/crond: add --full option to vacuumdb
249
250 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
251 - avoid generating ssl certificates for disabled services among www api boot
252
253 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
254 - cleaned up old entries in db-config
255 - mtail more robust
256
257 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
258 - php include path tweaked for plekit includes
259 - reviewed myplc (fka native) packaging dependencies
260 - renumbered 4.3
261
262 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
263 - rename myplc into myplc-chroot and myplc-native into myplc
264 - new settings (shortname & hrn_root) for local peer
265
266 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
267 - First iteration of new data model
268 - Bunch of various fixes
269
270 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
271 - Removed proper ops from planetflow slice.
272
273 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
274 - myplc-native requires myplc-docs
275 - fixed doc build by locating locally installed DTDs at build-time
276
277 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
278 - turn myplc-docs off for now
279
280 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
281 - figures in doc package
282
283 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
284 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
285 - chroot packaging does not have docs anymore
286 - 'cvs' and 'dev' not required from myplc-native anymore
287 - cosmetic change in kml output
288
289
290 %define module_current_branch 4.2