Setting tag myplc-5.2-5
[myplc.git] / myplc-docs.spec
1 %define name myplc-docs
2 %define version 5.2
3 %define taglevel 5
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central (PLC) online documentation
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: Applications/Systems
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15 BuildArch: noarch
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21
22 BuildRequires: docbook-dtds, docbook-utils-pdf
23
24 %define debug_package %{nil}
25
26 %description
27 This package contains the online documentation for MyPLC, i.e. the
28 reference manuals for the two APIs provided: PLCAPI and NMAPI. A
29 more general introduction to the MyPLC system can be found at
30 http://svn.planet-lab.org/wiki/MyPLCUserGuide
31
32 %prep
33 %setup -q
34
35 %build
36 rm -rf $RPM_BUILD_ROOT
37
38 # using the new lowercase names, and handling legacy
39 [ -d myplc ] || ln -s MyPLC myplc
40 [ -d plcapi ] || ln -s PLCAPI plcapi
41 [ -d nodemanager ] || ln -s NodeManager nodemanager
42 [ -d monitor ] || ln -s Monitor monitor 
43
44 pushd plcapi
45 # june2011 & f12, latex issues weird warnings, might need to try twice
46 make -C doc PLCAPI.pdf || make -C doc PLCAPI.pdf 
47 # beware that making the pdf file somehow overwrites the html
48 rm -f doc/PLCAPI.html
49 make -C doc PLCAPI.html || make -C doc PLCAPI.html 
50 popd
51
52 pushd nodemanager
53 # beware that making the pdf file somehow overwrites the html
54 make -C doc NMAPI.pdf || make -C doc NMAPI.pdf
55 rm -f doc/NMAPI.html
56 make -C doc NMAPI.html || make -C doc NMAPI.html 
57 popd
58
59 # not everyone rebuilds monitor, so make it optional
60 if [ -d monitor ] ; then
61 pushd monitor
62 # beware that making the pdf file somehow overwrites the html
63 make -C docs Monitor.pdf || make -C docs Monitor.pdf 
64 rm -f docs/Monitor.html
65 make -C docs Monitor.html || make -C docs Monitor.html 
66 popd
67 fi
68
69 %install
70
71 for ext in pdf html; do
72     install -D -m 444 plcapi/doc/PLCAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.$ext
73     install -D -m 444 nodemanager/doc/NMAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.$ext
74     if [ -d monitor ] ; then
75     install -D -m 444 monitor/docs/Monitor.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.$ext
76     fi
77 done
78
79 ./myplc/docbook2drupal.sh "PLC API Documentation (%{pldistro})" \
80     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.html \
81     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.php 
82 ./myplc/docbook2drupal.sh "Node Manager API Documentation (%{pldistro})" \
83     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.html \
84     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.php 
85 if [ -d monitor ] ; then
86 ./myplc/docbook2drupal.sh "Monitor API Documentation (%{pldistro})" \
87     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.html \
88     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.php 
89 fi
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %files
95 %defattr(-,root,root,-)
96 /var/www/html/planetlab/doc/
97
98 %changelog
99 * Thu Oct 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-5
100 - reduce the scope of check-hrns.py script, now that the SFA layer handles this natively
101 - add an rpm-sign dependency on feedora>=16
102
103 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-4
104 - drop PLC_OMF_XMPP_{USER,PASSWORD} from config
105
106 * Tue Apr 23 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-3
107 - plc.d/gpg now does not rm /dev/random but preserves it
108 - this is because libvirt won't let us run mknod
109
110 * Wed Apr 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-2
111 - fix typo in check-hrns - used to print 'host' while dealing with persons
112
113 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-1
114 - supports httpd config for either mod_python (preferred) or mod_wsgi
115 - requires mod_wsgi on f18 only, otherwise mod_python
116 - supports httpd config for apache 2.4 (f18)
117 - new config variable PLC_FLAVOUR_VIRT_MAP to set 'virt' from fcdistro
118
119 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-6
120 - bugfix in check-vsys-defaults.py
121
122 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-5
123 - define open_basedir in php.ini to stop confidentiality leak
124 - new utility slice_ssh_keys.py for showing sliver keys (OMF interop)
125 - new config setting PLC_VSYS_DEFAULTS for vsys tags granted to all
126 - new utilities check-hrns.py and check-vsys-defaults.py
127
128 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-4
129 - set TimeoutSec to 300 in plc.service
130 - remove ref to deprecated svn $URL$ in db-config usage
131
132 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-3
133 - expose mtail.py as simply mtail
134
135 * Mon May 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-2
136 - plc-kml.py now has support for nodegroups
137
138 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-1
139 - use nodeimage package instead of deprecated bootstrapfs
140 - has systemd-friendly startup script
141 - plc_reload moved to functions/ - no more service plc reload
142 - no svn keywords anymore
143
144 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-19
145 - new maintenance/monitoring script spot-aliens to look for glitches in refreshpeer+sfa
146
147 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-18
148 - new settings for myslice (comon&tophat) and monitor (db)
149 - removed mentions of chroot in description
150 - can redo myplc-docs on broken f12-latex
151 - set short_open_tag in php.ini
152 - fixes in gen-sites-xml (is that still used ?)
153 - partial-repo.sh has moved to 'build' where it more belongs
154 - tweaks in convenience tool 'mtail'
155
156 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-17
157 - fixed changelog, no change from 5.0-16
158
159 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-16
160 - requires ed for the plc.d/packages step
161 - sirius initscript to handle stop and restart
162
163 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-15
164 - ignore steps in db-config.d if they have a '.' or '~' in their name
165
166 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-14
167 - can redo myplc-docs without the doc for monitor
168
169 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-13
170 - no semantic change - just fixed specfile for git URL
171
172 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
173 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
174
175 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
176 - add missing files to rpm package
177
178 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
179 - mtail.py -s for SFA
180 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
181
182 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
183 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
184
185 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
186 - plc-config-tty now has a validator on booleans
187 - e.g. entering 'True' now is rejected rather than silently recording 'false'
188
189 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
190 - disable mod_wsgi
191
192 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
193 - module name changes
194 - start wsgi support
195
196 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
197 - new setting PLC_RESERVATION_GRANULARITY
198
199 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
200 - * partial-repo.sh script
201 - * preserve key along with certificates
202
203 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
204 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
205
206 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
207 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
208 - new OMF category in the config
209 - create the drl system slice
210
211 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
212 - first working version of 5.0:
213 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
214 - nodefamily is 3-fold with pldistro-fcdistro-arch
215 - new PLC_FLAVOUR config category
216 - reviewed module layout
217 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
218
219 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
220 - support for fedora 12
221 - new package myplc-config for use by sfa
222 - drupal user registration turned off
223
224 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
225 - - fix to make sure when API, BOOT, MONITOR are on the same
226 - machine as WWW that the SSL key,cert for WWW takes precedence.
227 - - Do proper setup for SSL CA certficate to be used as the server
228 - chain.
229
230 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
231 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
232
233 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
234 - depend on pcucontrol
235
236 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
237 - * validate input according to type in plc_config
238 - * added the _genicw system slice
239 - * add tag types for sites and persons
240 - * add new tags for nodes and slices for exemption from myops
241
242 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
243 - turn off drupal on a box that acts as BOOT server but not as WWW server
244 - cleanup some obsolete code for old chroot-jail packaging in the process
245 - new bootcd-kernel script for keeping bootcd variants up2date
246
247 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
248 - Make the /etc/hosts manipulation optional.
249
250 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
251 - Fix SetRole.
252
253 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
254 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
255 - into the DB.
256 - - Added the root ssh key handling support back into plc.d/ssh and the
257 - default xml file.  This should be identical to the way it was in
258 - rc12.
259 - - Added support in the db-config.d/01-init script to register the root
260 - ssh public key with the default administrator.  In this way the root
261 - ssh key will make it into the root account on the nodes by means of
262 - NodeManager's specialaccounts plugin.
263
264 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
265 - db-config ignores sliver tags
266 - sirius's db-config script renamed (was sirious)
267
268 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
269 - fix for silverauth - missing tag types now created at plc startup time
270
271 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
272 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
273
274 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
275 - companion to NM's specialaccounts plugin
276 - do not generate /etc/planetlab/root_ssh_key* anymore
277 - remove related config. variables and conf_files
278
279 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
280 - clarified description text to refer only to plcrt and not other optional
281 - packages.
282
283 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
284 - fixed a bug setting slice multiple attributes with the same tag name
285
286 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
287 - SSL setup for monitor box, and related new config variables
288 - new conf_file for /etc/planetlab/extensions
289 - various tweaks in db-config internals, about initscripts among others
290 - also more messages defined in the db
291
292 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
293 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
294
295 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
296 - bugfix in db-config, tag 4.3-19 would not fly
297
298 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
299 - Refactored db-config into snippets in db-config.d/.
300
301 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
302 - oops, tag 4.3-17 was broken and would not work
303
304 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
305 - bugfix - escape sequences inserted in xml configs
306
307 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
308 - Handle db-config.d files properly.
309
310 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
311 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
312 - than the log file
313 - - Fix db-config to be a bit more cautious when
314 - /etc/planetlab/db-config.d doesn't exist
315 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
316 - .orig files.
317 - - Refactor generic plc-config-tty code into plc_config.py.
318 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
319 - and the list of validated variables and the corresponding
320 - validator() function. This refactoring lets one reuse plc_config.py
321 - as a generic cmdline configuration tool for highly customer MyPLC
322 - like software.
323
324 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
325 - update PCU Type descriptions.
326 - updates to init scripts
327
328 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
329 - requires monitor-pcucontrol so register-wizard can work
330
331 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
332 - cleaned up plc-config-tty, no more need to configure plc-devel
333
334 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
335 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
336
337 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
338 - tighter right permissions on site_admin's authorized keys for more robustness
339
340 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
341 - fix issue in db-config that prevented correct operation
342
343 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
344 - remove support for chroot-based packaging - no crond nor syslog step anymore
345 - plc init script now named plc.init instead of former guest.init
346
347 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
348 - add Monitor to docs build
349
350 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
351 - plc_config.py and plc-config-tty: generalized to work for more diverse
352 - MyPLC configurations.
353 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
354 - deployments and increase the memory limits in php.ini
355 - plc.d/crond: add --full option to vacuumdb
356
357 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
358 - avoid generating ssl certificates for disabled services among www api boot
359
360 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
361 - cleaned up old entries in db-config
362 - mtail more robust
363
364 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
365 - php include path tweaked for plekit includes
366 - reviewed myplc (fka native) packaging dependencies
367 - renumbered 4.3
368
369 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
370 - rename myplc into myplc-chroot and myplc-native into myplc
371 - new settings (shortname & hrn_root) for local peer
372
373 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
374 - First iteration of new data model
375 - Bunch of various fixes
376
377 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
378 - Removed proper ops from planetflow slice.
379
380 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
381 - myplc-native requires myplc-docs
382 - fixed doc build by locating locally installed DTDs at build-time
383
384 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
385 - turn myplc-docs off for now
386
387 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
388 - figures in doc package
389
390 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
391 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
392 - chroot packaging does not have docs anymore
393 - 'cvs' and 'dev' not required from myplc-native anymore
394 - cosmetic change in kml output
395
396
397 %define module_current_branch 4.3