fix broken target make sync
[myplc.git] / myplc-docs.spec
1 %define name myplc-docs
2 %define version 5.0
3 %define taglevel 19
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central (PLC) online documentation
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: Applications/Systems
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15 BuildArch: noarch
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21
22 BuildRequires: docbook-dtds, docbook-utils-pdf
23
24 %define debug_package %{nil}
25
26 %description
27 This package contains the online documentation for MyPLC, i.e. the
28 reference manuals for the two APIs provided: PLCAPI and NMAPI. A
29 more general introduction to the MyPLC system can be found at
30 http://svn.planet-lab.org/wiki/MyPLCUserGuide
31
32 %prep
33 %setup -q
34
35 %build
36 rm -rf $RPM_BUILD_ROOT
37
38 # using the new lowercase names, and handling legacy
39 [ -d myplc ] || ln -s MyPLC myplc
40 [ -d plcapi ] || ln -s PLCAPI plcapi
41 [ -d nodemanager ] || ln -s NodeManager nodemanager
42 [ -d monitor ] || ln -s Monitor monitor 
43
44 pushd plcapi
45 # june2011 & f12, latex issues weird warnings, might need to try twice
46 make -C doc PLCAPI.pdf || make -C doc PLCAPI.pdf 
47 # beware that making the pdf file somehow overwrites the html
48 rm -f doc/PLCAPI.html
49 make -C doc PLCAPI.html || make -C doc PLCAPI.html 
50 popd
51
52 pushd nodemanager
53 # beware that making the pdf file somehow overwrites the html
54 make -C doc NMAPI.pdf || make -C doc NMAPI.pdf
55 rm -f doc/NMAPI.html
56 make -C doc NMAPI.html || make -C doc NMAPI.html 
57 popd
58
59 # not everyone rebuilds monitor, so make it optional
60 if [ -d monitor ] ; then
61 pushd monitor
62 # beware that making the pdf file somehow overwrites the html
63 make -C docs Monitor.pdf || make -C docs Monitor.pdf 
64 rm -f docs/Monitor.html
65 make -C docs Monitor.html || make -C docs Monitor.html 
66 popd
67 fi
68
69 %install
70
71 for ext in pdf html; do
72     install -D -m 444 plcapi/doc/PLCAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.$ext
73     install -D -m 444 nodemanager/doc/NMAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.$ext
74     if [ -d monitor ] ; then
75     install -D -m 444 monitor/docs/Monitor.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.$ext
76     fi
77 done
78
79 ./myplc/docbook2drupal.sh "PLC API Documentation (%{pldistro})" \
80     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.html \
81     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.php 
82 ./myplc/docbook2drupal.sh "Node Manager API Documentation (%{pldistro})" \
83     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.html \
84     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.php 
85 if [ -d monitor ] ; then
86 ./myplc/docbook2drupal.sh "Monitor API Documentation (%{pldistro})" \
87     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.html \
88     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.php 
89 fi
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %files
95 %defattr(-,root,root,-)
96 /var/www/html/planetlab/doc/
97
98 %changelog
99 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-19
100 - new maintenance/monitoring script spot-aliens to look for glitches in refreshpeer+sfa
101
102 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-18
103 - new settings for myslice (comon&tophat) and monitor (db)
104 - removed mentions of chroot in description
105 - can redo myplc-docs on broken f12-latex
106 - set short_open_tag in php.ini
107 - fixes in gen-sites-xml (is that still used ?)
108 - partial-repo.sh has moved to 'build' where it more belongs
109 - tweaks in convenience tool 'mtail'
110
111 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-17
112 - fixed changelog, no change from 5.0-16
113
114 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-16
115 - requires ed for the plc.d/packages step
116 - sirius initscript to handle stop and restart
117
118 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-15
119 - ignore steps in db-config.d if they have a '.' or '~' in their name
120
121 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-14
122 - can redo myplc-docs without the doc for monitor
123
124 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-13
125 - no semantic change - just fixed specfile for git URL
126
127 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
128 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
129
130 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
131 - add missing files to rpm package
132
133 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
134 - mtail.py -s for SFA
135 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
136
137 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
138 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
139
140 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
141 - plc-config-tty now has a validator on booleans
142 - e.g. entering 'True' now is rejected rather than silently recording 'false'
143
144 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
145 - disable mod_wsgi
146
147 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
148 - module name changes
149 - start wsgi support
150
151 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
152 - new setting PLC_RESERVATION_GRANULARITY
153
154 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
155 - * partial-repo.sh script
156 - * preserve key along with certificates
157
158 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
159 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
160
161 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
162 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
163 - new OMF category in the config
164 - create the drl system slice
165
166 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
167 - first working version of 5.0:
168 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
169 - nodefamily is 3-fold with pldistro-fcdistro-arch
170 - new PLC_FLAVOUR config category
171 - reviewed module layout
172 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
173
174 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
175 - support for fedora 12
176 - new package myplc-config for use by sfa
177 - drupal user registration turned off
178
179 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
180 - - fix to make sure when API, BOOT, MONITOR are on the same
181 - machine as WWW that the SSL key,cert for WWW takes precedence.
182 - - Do proper setup for SSL CA certficate to be used as the server
183 - chain.
184
185 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
186 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
187
188 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
189 - depend on pcucontrol
190
191 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
192 - * validate input according to type in plc_config
193 - * added the _genicw system slice
194 - * add tag types for sites and persons
195 - * add new tags for nodes and slices for exemption from myops
196
197 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
198 - turn off drupal on a box that acts as BOOT server but not as WWW server
199 - cleanup some obsolete code for old chroot-jail packaging in the process
200 - new bootcd-kernel script for keeping bootcd variants up2date
201
202 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
203 - Make the /etc/hosts manipulation optional.
204
205 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
206 - Fix SetRole.
207
208 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
209 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
210 - into the DB.
211 - - Added the root ssh key handling support back into plc.d/ssh and the
212 - default xml file.  This should be identical to the way it was in
213 - rc12.
214 - - Added support in the db-config.d/01-init script to register the root
215 - ssh public key with the default administrator.  In this way the root
216 - ssh key will make it into the root account on the nodes by means of
217 - NodeManager's specialaccounts plugin.
218
219 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
220 - db-config ignores sliver tags
221 - sirius's db-config script renamed (was sirious)
222
223 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
224 - fix for silverauth - missing tag types now created at plc startup time
225
226 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
227 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
228
229 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
230 - companion to NM's specialaccounts plugin
231 - do not generate /etc/planetlab/root_ssh_key* anymore
232 - remove related config. variables and conf_files
233
234 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
235 - clarified description text to refer only to plcrt and not other optional
236 - packages.
237
238 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
239 - fixed a bug setting slice multiple attributes with the same tag name
240
241 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
242 - SSL setup for monitor box, and related new config variables
243 - new conf_file for /etc/planetlab/extensions
244 - various tweaks in db-config internals, about initscripts among others
245 - also more messages defined in the db
246
247 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
248 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
249
250 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
251 - bugfix in db-config, tag 4.3-19 would not fly
252
253 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
254 - Refactored db-config into snippets in db-config.d/.
255
256 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
257 - oops, tag 4.3-17 was broken and would not work
258
259 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
260 - bugfix - escape sequences inserted in xml configs
261
262 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
263 - Handle db-config.d files properly.
264
265 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
266 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
267 - than the log file
268 - - Fix db-config to be a bit more cautious when
269 - /etc/planetlab/db-config.d doesn't exist
270 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
271 - .orig files.
272 - - Refactor generic plc-config-tty code into plc_config.py.
273 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
274 - and the list of validated variables and the corresponding
275 - validator() function. This refactoring lets one reuse plc_config.py
276 - as a generic cmdline configuration tool for highly customer MyPLC
277 - like software.
278
279 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
280 - update PCU Type descriptions.
281 - updates to init scripts
282
283 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
284 - requires monitor-pcucontrol so register-wizard can work
285
286 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
287 - cleaned up plc-config-tty, no more need to configure plc-devel
288
289 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
290 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
291
292 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
293 - tighter right permissions on site_admin's authorized keys for more robustness
294
295 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
296 - fix issue in db-config that prevented correct operation
297
298 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
299 - remove support for chroot-based packaging - no crond nor syslog step anymore
300 - plc init script now named plc.init instead of former guest.init
301
302 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
303 - add Monitor to docs build
304
305 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
306 - plc_config.py and plc-config-tty: generalized to work for more diverse
307 - MyPLC configurations.
308 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
309 - deployments and increase the memory limits in php.ini
310 - plc.d/crond: add --full option to vacuumdb
311
312 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
313 - avoid generating ssl certificates for disabled services among www api boot
314
315 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
316 - cleaned up old entries in db-config
317 - mtail more robust
318
319 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
320 - php include path tweaked for plekit includes
321 - reviewed myplc (fka native) packaging dependencies
322 - renumbered 4.3
323
324 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
325 - rename myplc into myplc-chroot and myplc-native into myplc
326 - new settings (shortname & hrn_root) for local peer
327
328 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
329 - First iteration of new data model
330 - Bunch of various fixes
331
332 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
333 - Removed proper ops from planetflow slice.
334
335 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
336 - myplc-native requires myplc-docs
337 - fixed doc build by locating locally installed DTDs at build-time
338
339 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
340 - turn myplc-docs off for now
341
342 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
343 - figures in doc package
344
345 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
346 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
347 - chroot packaging does not have docs anymore
348 - 'cvs' and 'dev' not required from myplc-native anymore
349 - cosmetic change in kml output
350
351
352 %define module_current_branch 4.3