Setting tag myplc-4.3-44
[myplc.git] / myplc-docs.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-docs
7 %define version 4.3
8 %define taglevel 44
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) online documentation
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 BuildRequires: docbook-dtds, docbook-utils-pdf
28
29 %define debug_package %{nil}
30
31 %description
32 This package contains the online documentation for MyPLC, i.e. the
33 reference manuals for the two APIs provided: PLCAPI and NMAPI. A
34 more general introduction to the MyPLC system can be found at
35 http://svn.planet-lab.org/wiki/MyPLCUserGuide
36
37 %prep
38 %setup -q
39
40 %build
41 rm -rf $RPM_BUILD_ROOT
42
43 # using the new lowercase names, and handling legacy
44 [ -d PLCAPI ] || ln -s plcapi PLCAPI
45 [ -d Monitor ] || ln -s monitor Monitor
46 [ -d NodeManager ] || ln -s nodemanager NodeManager
47 [ -d MyPLC ] || ln -s myplc MyPLC
48
49 pushd PLCAPI
50 # beware that making the pdf file somehow overwrites the html
51 make -C doc PLCAPI.pdf 
52 rm -f doc/PLCAPI.html
53 make -C doc PLCAPI.html 
54 popd
55
56 pushd NodeManager
57 # beware that making the pdf file somehow overwrites the html
58 make -C doc NMAPI.pdf 
59 rm -f doc/NMAPI.html
60 make -C doc NMAPI.html 
61 popd
62
63 pushd Monitor
64 # beware that making the pdf file somehow overwrites the html
65 make -C docs Monitor.pdf 
66 rm -f docs/Monitor.html
67 make -C docs Monitor.html 
68 popd
69
70 %install
71
72 for ext in pdf html; do
73     install -D -m 444 PLCAPI/doc/PLCAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.$ext
74     install -D -m 444 NodeManager/doc/NMAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.$ext
75     install -D -m 444 Monitor/docs/Monitor.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.$ext
76 done
77
78 ./MyPLC/docbook2drupal.sh "PLC API Documentation (%{pldistro})" \
79     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.html \
80     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.php 
81 ./MyPLC/docbook2drupal.sh "Node Manager API Documentation (%{pldistro})" \
82     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.html \
83     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.php 
84 ./MyPLC/docbook2drupal.sh "Monitor API Documentation (%{pldistro})" \
85     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.html \
86     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.php 
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %files
92 %defattr(-,root,root,-)
93 /var/www/html/planetlab/doc/
94
95 %changelog
96 * Thu Feb 03 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-44
97 - pick the greatest version as a kernel
98
99 * Thu Jan 06 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-43
100 - handle directory name changes for myplc-docs package as well
101
102 * Thu Jan 06 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-42
103 - handle directory name changes
104
105 * Thu Nov 18 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-41
106 - Use correct resolv.conf file.
107
108 * Wed Nov 17 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-40
109 - Make dnsmasq usable.
110
111 * Wed Nov 17 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-39
112 - Allow dnsmasq configuration to be extended.
113
114 * Thu Jul 22 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-38
115 - Add DRL slice.
116 - Generalize bootcd-kernel.
117
118 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
119 - support for fedora 12
120 - new package myplc-config for use by sfa
121 - drupal user registration turned off
122
123 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
124 - - fix to make sure when API, BOOT, MONITOR are on the same
125 - machine as WWW that the SSL key,cert for WWW takes precedence.
126 - - Do proper setup for SSL CA certficate to be used as the server
127 - chain.
128
129 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
130 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
131
132 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
133 - depend on pcucontrol
134
135 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
136 - * validate input according to type in plc_config
137 - * added the _genicw system slice
138 - * add tag types for sites and persons
139 - * add new tags for nodes and slices for exemption from myops
140
141 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
142 - turn off drupal on a box that acts as BOOT server but not as WWW server
143 - cleanup some obsolete code for old chroot-jail packaging in the process
144 - new bootcd-kernel script for keeping bootcd variants up2date
145
146 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
147 - Make the /etc/hosts manipulation optional.
148
149 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
150 - Fix SetRole.
151
152 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
153 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
154 - into the DB.
155 - - Added the root ssh key handling support back into plc.d/ssh and the
156 - default xml file.  This should be identical to the way it was in
157 - rc12.
158 - - Added support in the db-config.d/01-init script to register the root
159 - ssh public key with the default administrator.  In this way the root
160 - ssh key will make it into the root account on the nodes by means of
161 - NodeManager's specialaccounts plugin.
162
163 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
164 - db-config ignores sliver tags
165 - sirius's db-config script renamed (was sirious)
166
167 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
168 - fix for silverauth - missing tag types now created at plc startup time
169
170 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
171 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
172
173 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
174 - companion to NM's specialaccounts plugin
175 - do not generate /etc/planetlab/root_ssh_key* anymore
176 - remove related config. variables and conf_files
177
178 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
179 - clarified description text to refer only to plcrt and not other optional
180 - packages.
181
182 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
183 - fixed a bug setting slice multiple attributes with the same tag name
184
185 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
186 - SSL setup for monitor box, and related new config variables
187 - new conf_file for /etc/planetlab/extensions
188 - various tweaks in db-config internals, about initscripts among others
189 - also more messages defined in the db
190
191 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
192 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
193
194 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
195 - bugfix in db-config, tag 4.3-19 would not fly
196
197 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
198 - Refactored db-config into snippets in db-config.d/.
199
200 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
201 - oops, tag 4.3-17 was broken and would not work
202
203 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
204 - bugfix - escape sequences inserted in xml configs
205
206 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
207 - Handle db-config.d files properly.
208
209 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
210 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
211 - than the log file
212 - - Fix db-config to be a bit more cautious when
213 - /etc/planetlab/db-config.d doesn't exist
214 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
215 - .orig files.
216 - - Refactor generic plc-config-tty code into plc_config.py.
217 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
218 - and the list of validated variables and the corresponding
219 - validator() function. This refactoring lets one reuse plc_config.py
220 - as a generic cmdline configuration tool for highly customer MyPLC
221 - like software.
222
223 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
224 - update PCU Type descriptions.
225 - updates to init scripts
226
227 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
228 - requires monitor-pcucontrol so register-wizard can work
229
230 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
231 - cleaned up plc-config-tty, no more need to configure plc-devel
232
233 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
234 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
235
236 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
237 - tighter right permissions on site_admin's authorized keys for more robustness
238
239 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
240 - fix issue in db-config that prevented correct operation
241
242 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
243 - remove support for chroot-based packaging - no crond nor syslog step anymore
244 - plc init script now named plc.init instead of former guest.init
245
246 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
247 - add Monitor to docs build
248
249 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
250 - plc_config.py and plc-config-tty: generalized to work for more diverse
251 - MyPLC configurations.
252 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
253 - deployments and increase the memory limits in php.ini
254 - plc.d/crond: add --full option to vacuumdb
255
256 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
257 - avoid generating ssl certificates for disabled services among www api boot
258
259 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
260 - cleaned up old entries in db-config
261 - mtail more robust
262
263 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
264 - php include path tweaked for plekit includes
265 - reviewed myplc (fka native) packaging dependencies
266 - renumbered 4.3
267
268 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
269 - rename myplc into myplc-chroot and myplc-native into myplc
270 - new settings (shortname & hrn_root) for local peer
271
272 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
273 - First iteration of new data model
274 - Bunch of various fixes
275
276 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
277 - Removed proper ops from planetflow slice.
278
279 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
280 - myplc-native requires myplc-docs
281 - fixed doc build by locating locally installed DTDs at build-time
282
283 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
284 - turn myplc-docs off for now
285
286 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
287 - figures in doc package
288
289 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
290 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
291 - chroot packaging does not have docs anymore
292 - 'cvs' and 'dev' not required from myplc-native anymore
293 - cosmetic change in kml output
294
295
296 %define module_current_branch 4.2