drop PLC_OMF_XMPP_USER and PLC_OMF_XMPP_PASSWORD from config
[myplc.git] / myplc-docs.spec
1 %define name myplc-docs
2 %define version 5.2
3 %define taglevel 3
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central (PLC) online documentation
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: Applications/Systems
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15 BuildArch: noarch
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21
22 BuildRequires: docbook-dtds, docbook-utils-pdf
23
24 %define debug_package %{nil}
25
26 %description
27 This package contains the online documentation for MyPLC, i.e. the
28 reference manuals for the two APIs provided: PLCAPI and NMAPI. A
29 more general introduction to the MyPLC system can be found at
30 http://svn.planet-lab.org/wiki/MyPLCUserGuide
31
32 %prep
33 %setup -q
34
35 %build
36 rm -rf $RPM_BUILD_ROOT
37
38 # using the new lowercase names, and handling legacy
39 [ -d myplc ] || ln -s MyPLC myplc
40 [ -d plcapi ] || ln -s PLCAPI plcapi
41 [ -d nodemanager ] || ln -s NodeManager nodemanager
42 [ -d monitor ] || ln -s Monitor monitor 
43
44 pushd plcapi
45 # june2011 & f12, latex issues weird warnings, might need to try twice
46 make -C doc PLCAPI.pdf || make -C doc PLCAPI.pdf 
47 # beware that making the pdf file somehow overwrites the html
48 rm -f doc/PLCAPI.html
49 make -C doc PLCAPI.html || make -C doc PLCAPI.html 
50 popd
51
52 pushd nodemanager
53 # beware that making the pdf file somehow overwrites the html
54 make -C doc NMAPI.pdf || make -C doc NMAPI.pdf
55 rm -f doc/NMAPI.html
56 make -C doc NMAPI.html || make -C doc NMAPI.html 
57 popd
58
59 # not everyone rebuilds monitor, so make it optional
60 if [ -d monitor ] ; then
61 pushd monitor
62 # beware that making the pdf file somehow overwrites the html
63 make -C docs Monitor.pdf || make -C docs Monitor.pdf 
64 rm -f docs/Monitor.html
65 make -C docs Monitor.html || make -C docs Monitor.html 
66 popd
67 fi
68
69 %install
70
71 for ext in pdf html; do
72     install -D -m 444 plcapi/doc/PLCAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.$ext
73     install -D -m 444 nodemanager/doc/NMAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.$ext
74     if [ -d monitor ] ; then
75     install -D -m 444 monitor/docs/Monitor.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.$ext
76     fi
77 done
78
79 ./myplc/docbook2drupal.sh "PLC API Documentation (%{pldistro})" \
80     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.html \
81     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.php 
82 ./myplc/docbook2drupal.sh "Node Manager API Documentation (%{pldistro})" \
83     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.html \
84     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.php 
85 if [ -d monitor ] ; then
86 ./myplc/docbook2drupal.sh "Monitor API Documentation (%{pldistro})" \
87     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.html \
88     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.php 
89 fi
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %files
95 %defattr(-,root,root,-)
96 /var/www/html/planetlab/doc/
97
98 %changelog
99 * Tue Apr 23 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-3
100 - plc.d/gpg now does not rm /dev/random but preserves it
101 - this is because libvirt won't let us run mknod
102
103 * Wed Apr 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-2
104 - fix typo in check-hrns - used to print 'host' while dealing with persons
105
106 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-1
107 - supports httpd config for either mod_python (preferred) or mod_wsgi
108 - requires mod_wsgi on f18 only, otherwise mod_python
109 - supports httpd config for apache 2.4 (f18)
110 - new config variable PLC_FLAVOUR_VIRT_MAP to set 'virt' from fcdistro
111
112 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-6
113 - bugfix in check-vsys-defaults.py
114
115 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-5
116 - define open_basedir in php.ini to stop confidentiality leak
117 - new utility slice_ssh_keys.py for showing sliver keys (OMF interop)
118 - new config setting PLC_VSYS_DEFAULTS for vsys tags granted to all
119 - new utilities check-hrns.py and check-vsys-defaults.py
120
121 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-4
122 - set TimeoutSec to 300 in plc.service
123 - remove ref to deprecated svn $URL$ in db-config usage
124
125 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-3
126 - expose mtail.py as simply mtail
127
128 * Mon May 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-2
129 - plc-kml.py now has support for nodegroups
130
131 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-1
132 - use nodeimage package instead of deprecated bootstrapfs
133 - has systemd-friendly startup script
134 - plc_reload moved to functions/ - no more service plc reload
135 - no svn keywords anymore
136
137 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-19
138 - new maintenance/monitoring script spot-aliens to look for glitches in refreshpeer+sfa
139
140 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-18
141 - new settings for myslice (comon&tophat) and monitor (db)
142 - removed mentions of chroot in description
143 - can redo myplc-docs on broken f12-latex
144 - set short_open_tag in php.ini
145 - fixes in gen-sites-xml (is that still used ?)
146 - partial-repo.sh has moved to 'build' where it more belongs
147 - tweaks in convenience tool 'mtail'
148
149 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-17
150 - fixed changelog, no change from 5.0-16
151
152 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-16
153 - requires ed for the plc.d/packages step
154 - sirius initscript to handle stop and restart
155
156 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-15
157 - ignore steps in db-config.d if they have a '.' or '~' in their name
158
159 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-14
160 - can redo myplc-docs without the doc for monitor
161
162 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-13
163 - no semantic change - just fixed specfile for git URL
164
165 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
166 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
167
168 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
169 - add missing files to rpm package
170
171 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
172 - mtail.py -s for SFA
173 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
174
175 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
176 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
177
178 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
179 - plc-config-tty now has a validator on booleans
180 - e.g. entering 'True' now is rejected rather than silently recording 'false'
181
182 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
183 - disable mod_wsgi
184
185 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
186 - module name changes
187 - start wsgi support
188
189 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
190 - new setting PLC_RESERVATION_GRANULARITY
191
192 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
193 - * partial-repo.sh script
194 - * preserve key along with certificates
195
196 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
197 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
198
199 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
200 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
201 - new OMF category in the config
202 - create the drl system slice
203
204 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
205 - first working version of 5.0:
206 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
207 - nodefamily is 3-fold with pldistro-fcdistro-arch
208 - new PLC_FLAVOUR config category
209 - reviewed module layout
210 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
211
212 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
213 - support for fedora 12
214 - new package myplc-config for use by sfa
215 - drupal user registration turned off
216
217 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
218 - - fix to make sure when API, BOOT, MONITOR are on the same
219 - machine as WWW that the SSL key,cert for WWW takes precedence.
220 - - Do proper setup for SSL CA certficate to be used as the server
221 - chain.
222
223 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
224 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
225
226 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
227 - depend on pcucontrol
228
229 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
230 - * validate input according to type in plc_config
231 - * added the _genicw system slice
232 - * add tag types for sites and persons
233 - * add new tags for nodes and slices for exemption from myops
234
235 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
236 - turn off drupal on a box that acts as BOOT server but not as WWW server
237 - cleanup some obsolete code for old chroot-jail packaging in the process
238 - new bootcd-kernel script for keeping bootcd variants up2date
239
240 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
241 - Make the /etc/hosts manipulation optional.
242
243 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
244 - Fix SetRole.
245
246 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
247 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
248 - into the DB.
249 - - Added the root ssh key handling support back into plc.d/ssh and the
250 - default xml file.  This should be identical to the way it was in
251 - rc12.
252 - - Added support in the db-config.d/01-init script to register the root
253 - ssh public key with the default administrator.  In this way the root
254 - ssh key will make it into the root account on the nodes by means of
255 - NodeManager's specialaccounts plugin.
256
257 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
258 - db-config ignores sliver tags
259 - sirius's db-config script renamed (was sirious)
260
261 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
262 - fix for silverauth - missing tag types now created at plc startup time
263
264 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
265 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
266
267 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
268 - companion to NM's specialaccounts plugin
269 - do not generate /etc/planetlab/root_ssh_key* anymore
270 - remove related config. variables and conf_files
271
272 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
273 - clarified description text to refer only to plcrt and not other optional
274 - packages.
275
276 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
277 - fixed a bug setting slice multiple attributes with the same tag name
278
279 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
280 - SSL setup for monitor box, and related new config variables
281 - new conf_file for /etc/planetlab/extensions
282 - various tweaks in db-config internals, about initscripts among others
283 - also more messages defined in the db
284
285 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
286 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
287
288 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
289 - bugfix in db-config, tag 4.3-19 would not fly
290
291 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
292 - Refactored db-config into snippets in db-config.d/.
293
294 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
295 - oops, tag 4.3-17 was broken and would not work
296
297 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
298 - bugfix - escape sequences inserted in xml configs
299
300 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
301 - Handle db-config.d files properly.
302
303 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
304 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
305 - than the log file
306 - - Fix db-config to be a bit more cautious when
307 - /etc/planetlab/db-config.d doesn't exist
308 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
309 - .orig files.
310 - - Refactor generic plc-config-tty code into plc_config.py.
311 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
312 - and the list of validated variables and the corresponding
313 - validator() function. This refactoring lets one reuse plc_config.py
314 - as a generic cmdline configuration tool for highly customer MyPLC
315 - like software.
316
317 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
318 - update PCU Type descriptions.
319 - updates to init scripts
320
321 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
322 - requires monitor-pcucontrol so register-wizard can work
323
324 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
325 - cleaned up plc-config-tty, no more need to configure plc-devel
326
327 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
328 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
329
330 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
331 - tighter right permissions on site_admin's authorized keys for more robustness
332
333 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
334 - fix issue in db-config that prevented correct operation
335
336 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
337 - remove support for chroot-based packaging - no crond nor syslog step anymore
338 - plc init script now named plc.init instead of former guest.init
339
340 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
341 - add Monitor to docs build
342
343 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
344 - plc_config.py and plc-config-tty: generalized to work for more diverse
345 - MyPLC configurations.
346 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
347 - deployments and increase the memory limits in php.ini
348 - plc.d/crond: add --full option to vacuumdb
349
350 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
351 - avoid generating ssl certificates for disabled services among www api boot
352
353 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
354 - cleaned up old entries in db-config
355 - mtail more robust
356
357 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
358 - php include path tweaked for plekit includes
359 - reviewed myplc (fka native) packaging dependencies
360 - renumbered 4.3
361
362 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
363 - rename myplc into myplc-chroot and myplc-native into myplc
364 - new settings (shortname & hrn_root) for local peer
365
366 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
367 - First iteration of new data model
368 - Bunch of various fixes
369
370 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
371 - Removed proper ops from planetflow slice.
372
373 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
374 - myplc-native requires myplc-docs
375 - fixed doc build by locating locally installed DTDs at build-time
376
377 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
378 - turn myplc-docs off for now
379
380 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
381 - figures in doc package
382
383 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
384 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
385 - chroot packaging does not have docs anymore
386 - 'cvs' and 'dev' not required from myplc-native anymore
387 - cosmetic change in kml output
388
389
390 %define module_current_branch 4.3