Needed to change the semantics of SetSlice(), which previously would
[myplc.git] / myplc-docs.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-docs
7 %define version 4.3
8 %define taglevel 27
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) online documentation
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 BuildRequires: docbook-dtds, docbook-utils-pdf
28
29 %define debug_package %{nil}
30
31 %description
32 This package contains the online documentation for MyPLC, i.e. the
33 reference manuals for the two APIs provided: PLCAPI and NMAPI. A
34 more general introduction to the MyPLC system can be found at
35 http://svn.planet-lab.org/wiki/MyPLCUserGuide
36
37 %prep
38 %setup -q
39
40 %build
41 rm -rf $RPM_BUILD_ROOT
42
43 pushd PLCAPI
44 # beware that making the pdf file somehow overwrites the html
45 make -C doc PLCAPI.pdf 
46 rm -f doc/PLCAPI.html
47 make -C doc PLCAPI.html 
48 popd
49
50 pushd NodeManager
51 # beware that making the pdf file somehow overwrites the html
52 make -C doc NMAPI.pdf 
53 rm -f doc/NMAPI.html
54 make -C doc NMAPI.html 
55 popd
56
57 pushd Monitor
58 # beware that making the pdf file somehow overwrites the html
59 make -C docs Monitor.pdf 
60 rm -f docs/Monitor.html
61 make -C docs Monitor.html 
62 popd
63
64 %install
65
66 for ext in pdf html; do
67     install -D -m 444 PLCAPI/doc/PLCAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.$ext
68     install -D -m 444 NodeManager/doc/NMAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.$ext
69     install -D -m 444 Monitor/docs/Monitor.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.$ext
70 done
71
72 ./MyPLC/docbook2drupal.sh "PLC API Documentation (%{pldistro})" \
73     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.html \
74     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.php 
75 ./MyPLC/docbook2drupal.sh "Node Manager API Documentation (%{pldistro})" \
76     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.html \
77     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.php 
78 ./MyPLC/docbook2drupal.sh "Monitor API Documentation (%{pldistro})" \
79     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.html \
80     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.php 
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %files
86 %defattr(-,root,root,-)
87 /var/www/html/planetlab/doc/
88
89 %changelog
90 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
91 - fix for silverauth - missing tag types now created at plc startup time
92
93 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
94 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
95
96 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
97 - companion to NM's specialaccounts plugin
98 - do not generate /etc/planetlab/root_ssh_key* anymore
99 - remove related config. variables and conf_files
100
101 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
102 - clarified description text to refer only to plcrt and not other optional
103 - packages.
104
105 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
106 - fixed a bug setting slice multiple attributes with the same tag name
107
108 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
109 - SSL setup for monitor box, and related new config variables
110 - new conf_file for /etc/planetlab/extensions
111 - various tweaks in db-config internals, about initscripts among others
112 - also more messages defined in the db
113
114 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
115 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
116
117 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
118 - bugfix in db-config, tag 4.3-19 would not fly
119
120 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
121 - Refactored db-config into snippets in db-config.d/.
122
123 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
124 - oops, tag 4.3-17 was broken and would not work
125
126 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
127 - bugfix - escape sequences inserted in xml configs
128
129 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
130 - Handle db-config.d files properly.
131
132 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
133 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
134 - than the log file
135 - - Fix db-config to be a bit more cautious when
136 - /etc/planetlab/db-config.d doesn't exist
137 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
138 - .orig files.
139 - - Refactor generic plc-config-tty code into plc_config.py.
140 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
141 - and the list of validated variables and the corresponding
142 - validator() function. This refactoring lets one reuse plc_config.py
143 - as a generic cmdline configuration tool for highly customer MyPLC
144 - like software.
145
146 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
147 - update PCU Type descriptions.
148 - updates to init scripts
149
150 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
151 - requires monitor-pcucontrol so register-wizard can work
152
153 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
154 - cleaned up plc-config-tty, no more need to configure plc-devel
155
156 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
157 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
158
159 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
160 - tighter right permissions on site_admin's authorized keys for more robustness
161
162 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
163 - fix issue in db-config that prevented correct operation
164
165 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
166 - remove support for chroot-based packaging - no crond nor syslog step anymore
167 - plc init script now named plc.init instead of former guest.init
168
169 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
170 - add Monitor to docs build
171
172 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
173 - plc_config.py and plc-config-tty: generalized to work for more diverse
174 - MyPLC configurations.
175 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
176 - deployments and increase the memory limits in php.ini
177 - plc.d/crond: add --full option to vacuumdb
178
179 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
180 - avoid generating ssl certificates for disabled services among www api boot
181
182 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
183 - cleaned up old entries in db-config
184 - mtail more robust
185
186 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
187 - php include path tweaked for plekit includes
188 - reviewed myplc (fka native) packaging dependencies
189 - renumbered 4.3
190
191 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
192 - rename myplc into myplc-chroot and myplc-native into myplc
193 - new settings (shortname & hrn_root) for local peer
194
195 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
196 - First iteration of new data model
197 - Bunch of various fixes
198
199 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
200 - Removed proper ops from planetflow slice.
201
202 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
203 - myplc-native requires myplc-docs
204 - fixed doc build by locating locally installed DTDs at build-time
205
206 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
207 - turn myplc-docs off for now
208
209 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
210 - figures in doc package
211
212 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
213 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
214 - chroot packaging does not have docs anymore
215 - 'cvs' and 'dev' not required from myplc-native anymore
216 - cosmetic change in kml output
217
218
219 %define module_current_branch 4.2