Setting tag myplc-5.3-5
[myplc.git] / myplc-docs.spec
1 %define name myplc-docs
2 %define version 5.3
3 %define taglevel 5
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central (PLC) online documentation
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: Applications/Systems
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15 BuildArch: noarch
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21
22 BuildRequires: docbook-dtds, docbook-utils-pdf
23
24 %define debug_package %{nil}
25
26 %description
27 This package contains the online documentation for MyPLC, i.e. the
28 reference manuals for the two APIs provided: PLCAPI and NMAPI. A
29 more general introduction to the MyPLC system can be found at
30 http://svn.planet-lab.org/wiki/MyPLCUserGuide
31
32 %prep
33 %setup -q
34
35 %build
36 rm -rf $RPM_BUILD_ROOT
37
38 # using the new lowercase names, and handling legacy
39 [ -d myplc ] || ln -s MyPLC myplc
40 [ -d plcapi ] || ln -s PLCAPI plcapi
41 [ -d nodemanager ] || ln -s NodeManager nodemanager
42 [ -d monitor ] || ln -s Monitor monitor 
43
44 pushd plcapi
45 # june2011 & f12, latex issues weird warnings, might need to try twice
46 make -C doc PLCAPI.pdf || make -C doc PLCAPI.pdf 
47 # beware that making the pdf file somehow overwrites the html
48 rm -f doc/PLCAPI.html
49 make -C doc PLCAPI.html || make -C doc PLCAPI.html 
50 popd
51
52 pushd nodemanager
53 # beware that making the pdf file somehow overwrites the html
54 make -C doc NMAPI.pdf || make -C doc NMAPI.pdf
55 rm -f doc/NMAPI.html
56 make -C doc NMAPI.html || make -C doc NMAPI.html 
57 popd
58
59 # not everyone rebuilds monitor, so make it optional
60 if [ -d monitor ] ; then
61 pushd monitor
62 # beware that making the pdf file somehow overwrites the html
63 make -C docs Monitor.pdf || make -C docs Monitor.pdf 
64 rm -f docs/Monitor.html
65 make -C docs Monitor.html || make -C docs Monitor.html 
66 popd
67 fi
68
69 %install
70
71 for ext in pdf html; do
72     install -D -m 444 plcapi/doc/PLCAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.$ext
73     install -D -m 444 nodemanager/doc/NMAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.$ext
74     if [ -d monitor ] ; then
75     install -D -m 444 monitor/docs/Monitor.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.$ext
76     fi
77 done
78
79 ./myplc/docbook2drupal.sh "PLC API Documentation (%{pldistro})" \
80     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.html \
81     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.php 
82 ./myplc/docbook2drupal.sh "Node Manager API Documentation (%{pldistro})" \
83     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.html \
84     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.php 
85 if [ -d monitor ] ; then
86 ./myplc/docbook2drupal.sh "Monitor API Documentation (%{pldistro})" \
87     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.html \
88     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.php 
89 fi
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %files
95 %defattr(-,root,root,-)
96 /var/www/html/planetlab/doc/
97
98 %changelog
99 * Mon Jan 07 2019 Thierry Parmentelat <thierry.parmentelat@inria.fr> - myplc-5.3-5
100 - last version suitable for f27/f29 with python2
101 - packaging is split up, one more rpm named 'myplc-core' is produced,
102 - that covers the infrastructure side only (without bootcds and nodeimages and all node-oriented material)
103 - no more init file, one systemd service only, that leverages new /usr/bin/plc-ctl
104 - more robust config for httpd and php-fpm and php
105
106 * Sun Jul 16 2017 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-4
107 - takes care of creating plcapi log file
108
109 * Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-3
110 - tweaked renew_reminder for federation
111
112 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-2
113 - tweaks in check-hrns.py
114 - do not require PyXML any more
115
116 * Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-1
117 - review check-hrns for plcapi-5.3
118 - add PLC_HRN_ROOT in usual plc-config-tty's settings
119
120 * Thu Oct 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-5
121 - reduce the scope of check-hrns.py script, now that the SFA layer handles this natively
122 - add an rpm-sign dependency on feedora>=16
123
124 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-4
125 - drop PLC_OMF_XMPP_{USER,PASSWORD} from config
126
127 * Tue Apr 23 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-3
128 - plc.d/gpg now does not rm /dev/random but preserves it
129 - this is because libvirt won't let us run mknod
130
131 * Wed Apr 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-2
132 - fix typo in check-hrns - used to print 'host' while dealing with persons
133
134 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-1
135 - supports httpd config for either mod_python (preferred) or mod_wsgi
136 - requires mod_wsgi on f18 only, otherwise mod_python
137 - supports httpd config for apache 2.4 (f18)
138 - new config variable PLC_FLAVOUR_VIRT_MAP to set 'virt' from fcdistro
139
140 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-6
141 - bugfix in check-vsys-defaults.py
142
143 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-5
144 - define open_basedir in php.ini to stop confidentiality leak
145 - new utility slice_ssh_keys.py for showing sliver keys (OMF interop)
146 - new config setting PLC_VSYS_DEFAULTS for vsys tags granted to all
147 - new utilities check-hrns.py and check-vsys-defaults.py
148
149 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-4
150 - set TimeoutSec to 300 in plc.service
151 - remove ref to deprecated svn $URL$ in db-config usage
152
153 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-3
154 - expose mtail.py as simply mtail
155
156 * Mon May 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-2
157 - plc-kml.py now has support for nodegroups
158
159 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-1
160 - use nodeimage package instead of deprecated bootstrapfs
161 - has systemd-friendly startup script
162 - plc_reload moved to functions/ - no more service plc reload
163 - no svn keywords anymore
164
165 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-19
166 - new maintenance/monitoring script spot-aliens to look for glitches in refreshpeer+sfa
167
168 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-18
169 - new settings for myslice (comon&tophat) and monitor (db)
170 - removed mentions of chroot in description
171 - can redo myplc-docs on broken f12-latex
172 - set short_open_tag in php.ini
173 - fixes in gen-sites-xml (is that still used ?)
174 - partial-repo.sh has moved to 'build' where it more belongs
175 - tweaks in convenience tool 'mtail'
176
177 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-17
178 - fixed changelog, no change from 5.0-16
179
180 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-16
181 - requires ed for the plc.d/packages step
182 - sirius initscript to handle stop and restart
183
184 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-15
185 - ignore steps in db-config.d if they have a '.' or '~' in their name
186
187 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-14
188 - can redo myplc-docs without the doc for monitor
189
190 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-13
191 - no semantic change - just fixed specfile for git URL
192
193 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
194 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
195
196 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
197 - add missing files to rpm package
198
199 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
200 - mtail.py -s for SFA
201 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
202
203 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
204 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
205
206 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
207 - plc-config-tty now has a validator on booleans
208 - e.g. entering 'True' now is rejected rather than silently recording 'false'
209
210 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
211 - disable mod_wsgi
212
213 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
214 - module name changes
215 - start wsgi support
216
217 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
218 - new setting PLC_RESERVATION_GRANULARITY
219
220 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
221 - * partial-repo.sh script
222 - * preserve key along with certificates
223
224 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
225 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
226
227 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
228 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
229 - new OMF category in the config
230 - create the drl system slice
231
232 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
233 - first working version of 5.0:
234 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
235 - nodefamily is 3-fold with pldistro-fcdistro-arch
236 - new PLC_FLAVOUR config category
237 - reviewed module layout
238 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
239
240 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
241 - support for fedora 12
242 - new package myplc-config for use by sfa
243 - drupal user registration turned off
244
245 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
246 - - fix to make sure when API, BOOT, MONITOR are on the same
247 - machine as WWW that the SSL key,cert for WWW takes precedence.
248 - - Do proper setup for SSL CA certficate to be used as the server
249 - chain.
250
251 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
252 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
253
254 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
255 - depend on pcucontrol
256
257 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
258 - * validate input according to type in plc_config
259 - * added the _genicw system slice
260 - * add tag types for sites and persons
261 - * add new tags for nodes and slices for exemption from myops
262
263 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
264 - turn off drupal on a box that acts as BOOT server but not as WWW server
265 - cleanup some obsolete code for old chroot-jail packaging in the process
266 - new bootcd-kernel script for keeping bootcd variants up2date
267
268 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
269 - Make the /etc/hosts manipulation optional.
270
271 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
272 - Fix SetRole.
273
274 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
275 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
276 - into the DB.
277 - - Added the root ssh key handling support back into plc.d/ssh and the
278 - default xml file.  This should be identical to the way it was in
279 - rc12.
280 - - Added support in the db-config.d/01-init script to register the root
281 - ssh public key with the default administrator.  In this way the root
282 - ssh key will make it into the root account on the nodes by means of
283 - NodeManager's specialaccounts plugin.
284
285 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
286 - db-config ignores sliver tags
287 - sirius's db-config script renamed (was sirious)
288
289 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
290 - fix for silverauth - missing tag types now created at plc startup time
291
292 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
293 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
294
295 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
296 - companion to NM's specialaccounts plugin
297 - do not generate /etc/planetlab/root_ssh_key* anymore
298 - remove related config. variables and conf_files
299
300 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
301 - clarified description text to refer only to plcrt and not other optional
302 - packages.
303
304 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
305 - fixed a bug setting slice multiple attributes with the same tag name
306
307 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
308 - SSL setup for monitor box, and related new config variables
309 - new conf_file for /etc/planetlab/extensions
310 - various tweaks in db-config internals, about initscripts among others
311 - also more messages defined in the db
312
313 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
314 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
315
316 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
317 - bugfix in db-config, tag 4.3-19 would not fly
318
319 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
320 - Refactored db-config into snippets in db-config.d/.
321
322 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
323 - oops, tag 4.3-17 was broken and would not work
324
325 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
326 - bugfix - escape sequences inserted in xml configs
327
328 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
329 - Handle db-config.d files properly.
330
331 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
332 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
333 - than the log file
334 - - Fix db-config to be a bit more cautious when
335 - /etc/planetlab/db-config.d doesn't exist
336 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
337 - .orig files.
338 - - Refactor generic plc-config-tty code into plc_config.py.
339 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
340 - and the list of validated variables and the corresponding
341 - validator() function. This refactoring lets one reuse plc_config.py
342 - as a generic cmdline configuration tool for highly customer MyPLC
343 - like software.
344
345 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
346 - update PCU Type descriptions.
347 - updates to init scripts
348
349 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
350 - requires monitor-pcucontrol so register-wizard can work
351
352 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
353 - cleaned up plc-config-tty, no more need to configure plc-devel
354
355 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
356 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
357
358 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
359 - tighter right permissions on site_admin's authorized keys for more robustness
360
361 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
362 - fix issue in db-config that prevented correct operation
363
364 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
365 - remove support for chroot-based packaging - no crond nor syslog step anymore
366 - plc init script now named plc.init instead of former guest.init
367
368 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
369 - add Monitor to docs build
370
371 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
372 - plc_config.py and plc-config-tty: generalized to work for more diverse
373 - MyPLC configurations.
374 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
375 - deployments and increase the memory limits in php.ini
376 - plc.d/crond: add --full option to vacuumdb
377
378 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
379 - avoid generating ssl certificates for disabled services among www api boot
380
381 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
382 - cleaned up old entries in db-config
383 - mtail more robust
384
385 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
386 - php include path tweaked for plekit includes
387 - reviewed myplc (fka native) packaging dependencies
388 - renumbered 4.3
389
390 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
391 - rename myplc into myplc-chroot and myplc-native into myplc
392 - new settings (shortname & hrn_root) for local peer
393
394 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
395 - First iteration of new data model
396 - Bunch of various fixes
397
398 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
399 - Removed proper ops from planetflow slice.
400
401 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
402 - myplc-native requires myplc-docs
403 - fixed doc build by locating locally installed DTDs at build-time
404
405 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
406 - turn myplc-docs off for now
407
408 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
409 - figures in doc package
410
411 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
412 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
413 - chroot packaging does not have docs anymore
414 - 'cvs' and 'dev' not required from myplc-native anymore
415 - cosmetic change in kml output
416
417
418 %define module_current_branch 4.3