Setting tag myplc-5.3-1
[myplc.git] / myplc-docs.spec
1 %define name myplc-docs
2 %define version 5.3
3 %define taglevel 1
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central (PLC) online documentation
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: Applications/Systems
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15 BuildArch: noarch
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21
22 BuildRequires: docbook-dtds, docbook-utils-pdf
23
24 %define debug_package %{nil}
25
26 %description
27 This package contains the online documentation for MyPLC, i.e. the
28 reference manuals for the two APIs provided: PLCAPI and NMAPI. A
29 more general introduction to the MyPLC system can be found at
30 http://svn.planet-lab.org/wiki/MyPLCUserGuide
31
32 %prep
33 %setup -q
34
35 %build
36 rm -rf $RPM_BUILD_ROOT
37
38 # using the new lowercase names, and handling legacy
39 [ -d myplc ] || ln -s MyPLC myplc
40 [ -d plcapi ] || ln -s PLCAPI plcapi
41 [ -d nodemanager ] || ln -s NodeManager nodemanager
42 [ -d monitor ] || ln -s Monitor monitor 
43
44 pushd plcapi
45 # june2011 & f12, latex issues weird warnings, might need to try twice
46 make -C doc PLCAPI.pdf || make -C doc PLCAPI.pdf 
47 # beware that making the pdf file somehow overwrites the html
48 rm -f doc/PLCAPI.html
49 make -C doc PLCAPI.html || make -C doc PLCAPI.html 
50 popd
51
52 pushd nodemanager
53 # beware that making the pdf file somehow overwrites the html
54 make -C doc NMAPI.pdf || make -C doc NMAPI.pdf
55 rm -f doc/NMAPI.html
56 make -C doc NMAPI.html || make -C doc NMAPI.html 
57 popd
58
59 # not everyone rebuilds monitor, so make it optional
60 if [ -d monitor ] ; then
61 pushd monitor
62 # beware that making the pdf file somehow overwrites the html
63 make -C docs Monitor.pdf || make -C docs Monitor.pdf 
64 rm -f docs/Monitor.html
65 make -C docs Monitor.html || make -C docs Monitor.html 
66 popd
67 fi
68
69 %install
70
71 for ext in pdf html; do
72     install -D -m 444 plcapi/doc/PLCAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.$ext
73     install -D -m 444 nodemanager/doc/NMAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.$ext
74     if [ -d monitor ] ; then
75     install -D -m 444 monitor/docs/Monitor.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.$ext
76     fi
77 done
78
79 ./myplc/docbook2drupal.sh "PLC API Documentation (%{pldistro})" \
80     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.html \
81     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.php 
82 ./myplc/docbook2drupal.sh "Node Manager API Documentation (%{pldistro})" \
83     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.html \
84     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.php 
85 if [ -d monitor ] ; then
86 ./myplc/docbook2drupal.sh "Monitor API Documentation (%{pldistro})" \
87     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.html \
88     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.php 
89 fi
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %files
95 %defattr(-,root,root,-)
96 /var/www/html/planetlab/doc/
97
98 %changelog
99 * Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-1
100 - review check-hrns for plcapi-5.3
101 - add PLC_HRN_ROOT in usual plc-config-tty's settings
102
103 * Thu Oct 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-5
104 - reduce the scope of check-hrns.py script, now that the SFA layer handles this natively
105 - add an rpm-sign dependency on feedora>=16
106
107 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-4
108 - drop PLC_OMF_XMPP_{USER,PASSWORD} from config
109
110 * Tue Apr 23 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-3
111 - plc.d/gpg now does not rm /dev/random but preserves it
112 - this is because libvirt won't let us run mknod
113
114 * Wed Apr 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-2
115 - fix typo in check-hrns - used to print 'host' while dealing with persons
116
117 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-1
118 - supports httpd config for either mod_python (preferred) or mod_wsgi
119 - requires mod_wsgi on f18 only, otherwise mod_python
120 - supports httpd config for apache 2.4 (f18)
121 - new config variable PLC_FLAVOUR_VIRT_MAP to set 'virt' from fcdistro
122
123 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-6
124 - bugfix in check-vsys-defaults.py
125
126 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-5
127 - define open_basedir in php.ini to stop confidentiality leak
128 - new utility slice_ssh_keys.py for showing sliver keys (OMF interop)
129 - new config setting PLC_VSYS_DEFAULTS for vsys tags granted to all
130 - new utilities check-hrns.py and check-vsys-defaults.py
131
132 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-4
133 - set TimeoutSec to 300 in plc.service
134 - remove ref to deprecated svn $URL$ in db-config usage
135
136 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-3
137 - expose mtail.py as simply mtail
138
139 * Mon May 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-2
140 - plc-kml.py now has support for nodegroups
141
142 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-1
143 - use nodeimage package instead of deprecated bootstrapfs
144 - has systemd-friendly startup script
145 - plc_reload moved to functions/ - no more service plc reload
146 - no svn keywords anymore
147
148 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-19
149 - new maintenance/monitoring script spot-aliens to look for glitches in refreshpeer+sfa
150
151 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-18
152 - new settings for myslice (comon&tophat) and monitor (db)
153 - removed mentions of chroot in description
154 - can redo myplc-docs on broken f12-latex
155 - set short_open_tag in php.ini
156 - fixes in gen-sites-xml (is that still used ?)
157 - partial-repo.sh has moved to 'build' where it more belongs
158 - tweaks in convenience tool 'mtail'
159
160 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-17
161 - fixed changelog, no change from 5.0-16
162
163 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-16
164 - requires ed for the plc.d/packages step
165 - sirius initscript to handle stop and restart
166
167 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-15
168 - ignore steps in db-config.d if they have a '.' or '~' in their name
169
170 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-14
171 - can redo myplc-docs without the doc for monitor
172
173 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-13
174 - no semantic change - just fixed specfile for git URL
175
176 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
177 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
178
179 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
180 - add missing files to rpm package
181
182 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
183 - mtail.py -s for SFA
184 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
185
186 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
187 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
188
189 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
190 - plc-config-tty now has a validator on booleans
191 - e.g. entering 'True' now is rejected rather than silently recording 'false'
192
193 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
194 - disable mod_wsgi
195
196 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
197 - module name changes
198 - start wsgi support
199
200 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
201 - new setting PLC_RESERVATION_GRANULARITY
202
203 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
204 - * partial-repo.sh script
205 - * preserve key along with certificates
206
207 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
208 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
209
210 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
211 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
212 - new OMF category in the config
213 - create the drl system slice
214
215 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
216 - first working version of 5.0:
217 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
218 - nodefamily is 3-fold with pldistro-fcdistro-arch
219 - new PLC_FLAVOUR config category
220 - reviewed module layout
221 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
222
223 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
224 - support for fedora 12
225 - new package myplc-config for use by sfa
226 - drupal user registration turned off
227
228 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
229 - - fix to make sure when API, BOOT, MONITOR are on the same
230 - machine as WWW that the SSL key,cert for WWW takes precedence.
231 - - Do proper setup for SSL CA certficate to be used as the server
232 - chain.
233
234 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
235 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
236
237 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
238 - depend on pcucontrol
239
240 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
241 - * validate input according to type in plc_config
242 - * added the _genicw system slice
243 - * add tag types for sites and persons
244 - * add new tags for nodes and slices for exemption from myops
245
246 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
247 - turn off drupal on a box that acts as BOOT server but not as WWW server
248 - cleanup some obsolete code for old chroot-jail packaging in the process
249 - new bootcd-kernel script for keeping bootcd variants up2date
250
251 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
252 - Make the /etc/hosts manipulation optional.
253
254 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
255 - Fix SetRole.
256
257 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
258 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
259 - into the DB.
260 - - Added the root ssh key handling support back into plc.d/ssh and the
261 - default xml file.  This should be identical to the way it was in
262 - rc12.
263 - - Added support in the db-config.d/01-init script to register the root
264 - ssh public key with the default administrator.  In this way the root
265 - ssh key will make it into the root account on the nodes by means of
266 - NodeManager's specialaccounts plugin.
267
268 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
269 - db-config ignores sliver tags
270 - sirius's db-config script renamed (was sirious)
271
272 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
273 - fix for silverauth - missing tag types now created at plc startup time
274
275 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
276 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
277
278 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
279 - companion to NM's specialaccounts plugin
280 - do not generate /etc/planetlab/root_ssh_key* anymore
281 - remove related config. variables and conf_files
282
283 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
284 - clarified description text to refer only to plcrt and not other optional
285 - packages.
286
287 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
288 - fixed a bug setting slice multiple attributes with the same tag name
289
290 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
291 - SSL setup for monitor box, and related new config variables
292 - new conf_file for /etc/planetlab/extensions
293 - various tweaks in db-config internals, about initscripts among others
294 - also more messages defined in the db
295
296 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
297 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
298
299 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
300 - bugfix in db-config, tag 4.3-19 would not fly
301
302 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
303 - Refactored db-config into snippets in db-config.d/.
304
305 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
306 - oops, tag 4.3-17 was broken and would not work
307
308 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
309 - bugfix - escape sequences inserted in xml configs
310
311 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
312 - Handle db-config.d files properly.
313
314 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
315 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
316 - than the log file
317 - - Fix db-config to be a bit more cautious when
318 - /etc/planetlab/db-config.d doesn't exist
319 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
320 - .orig files.
321 - - Refactor generic plc-config-tty code into plc_config.py.
322 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
323 - and the list of validated variables and the corresponding
324 - validator() function. This refactoring lets one reuse plc_config.py
325 - as a generic cmdline configuration tool for highly customer MyPLC
326 - like software.
327
328 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
329 - update PCU Type descriptions.
330 - updates to init scripts
331
332 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
333 - requires monitor-pcucontrol so register-wizard can work
334
335 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
336 - cleaned up plc-config-tty, no more need to configure plc-devel
337
338 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
339 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
340
341 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
342 - tighter right permissions on site_admin's authorized keys for more robustness
343
344 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
345 - fix issue in db-config that prevented correct operation
346
347 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
348 - remove support for chroot-based packaging - no crond nor syslog step anymore
349 - plc init script now named plc.init instead of former guest.init
350
351 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
352 - add Monitor to docs build
353
354 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
355 - plc_config.py and plc-config-tty: generalized to work for more diverse
356 - MyPLC configurations.
357 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
358 - deployments and increase the memory limits in php.ini
359 - plc.d/crond: add --full option to vacuumdb
360
361 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
362 - avoid generating ssl certificates for disabled services among www api boot
363
364 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
365 - cleaned up old entries in db-config
366 - mtail more robust
367
368 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
369 - php include path tweaked for plekit includes
370 - reviewed myplc (fka native) packaging dependencies
371 - renumbered 4.3
372
373 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
374 - rename myplc into myplc-chroot and myplc-native into myplc
375 - new settings (shortname & hrn_root) for local peer
376
377 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
378 - First iteration of new data model
379 - Bunch of various fixes
380
381 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
382 - Removed proper ops from planetflow slice.
383
384 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
385 - myplc-native requires myplc-docs
386 - fixed doc build by locating locally installed DTDs at build-time
387
388 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
389 - turn myplc-docs off for now
390
391 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
392 - figures in doc package
393
394 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
395 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
396 - chroot packaging does not have docs anymore
397 - 'cvs' and 'dev' not required from myplc-native anymore
398 - cosmetic change in kml output
399
400
401 %define module_current_branch 4.3