add dep. to rpm-sign - cleanup cron-related business only relevant for old distros
[myplc.git] / myplc-docs.spec
1 %define name myplc-docs
2 %define version 5.2
3 %define taglevel 4
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central (PLC) online documentation
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: Applications/Systems
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15 BuildArch: noarch
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21
22 BuildRequires: docbook-dtds, docbook-utils-pdf
23
24 %define debug_package %{nil}
25
26 %description
27 This package contains the online documentation for MyPLC, i.e. the
28 reference manuals for the two APIs provided: PLCAPI and NMAPI. A
29 more general introduction to the MyPLC system can be found at
30 http://svn.planet-lab.org/wiki/MyPLCUserGuide
31
32 %prep
33 %setup -q
34
35 %build
36 rm -rf $RPM_BUILD_ROOT
37
38 # using the new lowercase names, and handling legacy
39 [ -d myplc ] || ln -s MyPLC myplc
40 [ -d plcapi ] || ln -s PLCAPI plcapi
41 [ -d nodemanager ] || ln -s NodeManager nodemanager
42 [ -d monitor ] || ln -s Monitor monitor 
43
44 pushd plcapi
45 # june2011 & f12, latex issues weird warnings, might need to try twice
46 make -C doc PLCAPI.pdf || make -C doc PLCAPI.pdf 
47 # beware that making the pdf file somehow overwrites the html
48 rm -f doc/PLCAPI.html
49 make -C doc PLCAPI.html || make -C doc PLCAPI.html 
50 popd
51
52 pushd nodemanager
53 # beware that making the pdf file somehow overwrites the html
54 make -C doc NMAPI.pdf || make -C doc NMAPI.pdf
55 rm -f doc/NMAPI.html
56 make -C doc NMAPI.html || make -C doc NMAPI.html 
57 popd
58
59 # not everyone rebuilds monitor, so make it optional
60 if [ -d monitor ] ; then
61 pushd monitor
62 # beware that making the pdf file somehow overwrites the html
63 make -C docs Monitor.pdf || make -C docs Monitor.pdf 
64 rm -f docs/Monitor.html
65 make -C docs Monitor.html || make -C docs Monitor.html 
66 popd
67 fi
68
69 %install
70
71 for ext in pdf html; do
72     install -D -m 444 plcapi/doc/PLCAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.$ext
73     install -D -m 444 nodemanager/doc/NMAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.$ext
74     if [ -d monitor ] ; then
75     install -D -m 444 monitor/docs/Monitor.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.$ext
76     fi
77 done
78
79 ./myplc/docbook2drupal.sh "PLC API Documentation (%{pldistro})" \
80     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.html \
81     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.php 
82 ./myplc/docbook2drupal.sh "Node Manager API Documentation (%{pldistro})" \
83     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.html \
84     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.php 
85 if [ -d monitor ] ; then
86 ./myplc/docbook2drupal.sh "Monitor API Documentation (%{pldistro})" \
87     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.html \
88     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.php 
89 fi
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %files
95 %defattr(-,root,root,-)
96 /var/www/html/planetlab/doc/
97
98 %changelog
99 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-4
100 - drop PLC_OMF_XMPP_{USER,PASSWORD} from config
101
102 * Tue Apr 23 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-3
103 - plc.d/gpg now does not rm /dev/random but preserves it
104 - this is because libvirt won't let us run mknod
105
106 * Wed Apr 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-2
107 - fix typo in check-hrns - used to print 'host' while dealing with persons
108
109 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-1
110 - supports httpd config for either mod_python (preferred) or mod_wsgi
111 - requires mod_wsgi on f18 only, otherwise mod_python
112 - supports httpd config for apache 2.4 (f18)
113 - new config variable PLC_FLAVOUR_VIRT_MAP to set 'virt' from fcdistro
114
115 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-6
116 - bugfix in check-vsys-defaults.py
117
118 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-5
119 - define open_basedir in php.ini to stop confidentiality leak
120 - new utility slice_ssh_keys.py for showing sliver keys (OMF interop)
121 - new config setting PLC_VSYS_DEFAULTS for vsys tags granted to all
122 - new utilities check-hrns.py and check-vsys-defaults.py
123
124 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-4
125 - set TimeoutSec to 300 in plc.service
126 - remove ref to deprecated svn $URL$ in db-config usage
127
128 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-3
129 - expose mtail.py as simply mtail
130
131 * Mon May 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-2
132 - plc-kml.py now has support for nodegroups
133
134 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-1
135 - use nodeimage package instead of deprecated bootstrapfs
136 - has systemd-friendly startup script
137 - plc_reload moved to functions/ - no more service plc reload
138 - no svn keywords anymore
139
140 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-19
141 - new maintenance/monitoring script spot-aliens to look for glitches in refreshpeer+sfa
142
143 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-18
144 - new settings for myslice (comon&tophat) and monitor (db)
145 - removed mentions of chroot in description
146 - can redo myplc-docs on broken f12-latex
147 - set short_open_tag in php.ini
148 - fixes in gen-sites-xml (is that still used ?)
149 - partial-repo.sh has moved to 'build' where it more belongs
150 - tweaks in convenience tool 'mtail'
151
152 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-17
153 - fixed changelog, no change from 5.0-16
154
155 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-16
156 - requires ed for the plc.d/packages step
157 - sirius initscript to handle stop and restart
158
159 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-15
160 - ignore steps in db-config.d if they have a '.' or '~' in their name
161
162 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-14
163 - can redo myplc-docs without the doc for monitor
164
165 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-13
166 - no semantic change - just fixed specfile for git URL
167
168 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
169 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
170
171 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
172 - add missing files to rpm package
173
174 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
175 - mtail.py -s for SFA
176 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
177
178 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
179 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
180
181 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
182 - plc-config-tty now has a validator on booleans
183 - e.g. entering 'True' now is rejected rather than silently recording 'false'
184
185 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
186 - disable mod_wsgi
187
188 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
189 - module name changes
190 - start wsgi support
191
192 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
193 - new setting PLC_RESERVATION_GRANULARITY
194
195 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
196 - * partial-repo.sh script
197 - * preserve key along with certificates
198
199 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
200 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
201
202 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
203 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
204 - new OMF category in the config
205 - create the drl system slice
206
207 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
208 - first working version of 5.0:
209 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
210 - nodefamily is 3-fold with pldistro-fcdistro-arch
211 - new PLC_FLAVOUR config category
212 - reviewed module layout
213 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
214
215 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
216 - support for fedora 12
217 - new package myplc-config for use by sfa
218 - drupal user registration turned off
219
220 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
221 - - fix to make sure when API, BOOT, MONITOR are on the same
222 - machine as WWW that the SSL key,cert for WWW takes precedence.
223 - - Do proper setup for SSL CA certficate to be used as the server
224 - chain.
225
226 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
227 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
228
229 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
230 - depend on pcucontrol
231
232 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
233 - * validate input according to type in plc_config
234 - * added the _genicw system slice
235 - * add tag types for sites and persons
236 - * add new tags for nodes and slices for exemption from myops
237
238 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
239 - turn off drupal on a box that acts as BOOT server but not as WWW server
240 - cleanup some obsolete code for old chroot-jail packaging in the process
241 - new bootcd-kernel script for keeping bootcd variants up2date
242
243 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
244 - Make the /etc/hosts manipulation optional.
245
246 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
247 - Fix SetRole.
248
249 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
250 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
251 - into the DB.
252 - - Added the root ssh key handling support back into plc.d/ssh and the
253 - default xml file.  This should be identical to the way it was in
254 - rc12.
255 - - Added support in the db-config.d/01-init script to register the root
256 - ssh public key with the default administrator.  In this way the root
257 - ssh key will make it into the root account on the nodes by means of
258 - NodeManager's specialaccounts plugin.
259
260 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
261 - db-config ignores sliver tags
262 - sirius's db-config script renamed (was sirious)
263
264 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
265 - fix for silverauth - missing tag types now created at plc startup time
266
267 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
268 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
269
270 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
271 - companion to NM's specialaccounts plugin
272 - do not generate /etc/planetlab/root_ssh_key* anymore
273 - remove related config. variables and conf_files
274
275 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
276 - clarified description text to refer only to plcrt and not other optional
277 - packages.
278
279 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
280 - fixed a bug setting slice multiple attributes with the same tag name
281
282 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
283 - SSL setup for monitor box, and related new config variables
284 - new conf_file for /etc/planetlab/extensions
285 - various tweaks in db-config internals, about initscripts among others
286 - also more messages defined in the db
287
288 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
289 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
290
291 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
292 - bugfix in db-config, tag 4.3-19 would not fly
293
294 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
295 - Refactored db-config into snippets in db-config.d/.
296
297 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
298 - oops, tag 4.3-17 was broken and would not work
299
300 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
301 - bugfix - escape sequences inserted in xml configs
302
303 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
304 - Handle db-config.d files properly.
305
306 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
307 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
308 - than the log file
309 - - Fix db-config to be a bit more cautious when
310 - /etc/planetlab/db-config.d doesn't exist
311 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
312 - .orig files.
313 - - Refactor generic plc-config-tty code into plc_config.py.
314 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
315 - and the list of validated variables and the corresponding
316 - validator() function. This refactoring lets one reuse plc_config.py
317 - as a generic cmdline configuration tool for highly customer MyPLC
318 - like software.
319
320 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
321 - update PCU Type descriptions.
322 - updates to init scripts
323
324 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
325 - requires monitor-pcucontrol so register-wizard can work
326
327 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
328 - cleaned up plc-config-tty, no more need to configure plc-devel
329
330 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
331 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
332
333 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
334 - tighter right permissions on site_admin's authorized keys for more robustness
335
336 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
337 - fix issue in db-config that prevented correct operation
338
339 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
340 - remove support for chroot-based packaging - no crond nor syslog step anymore
341 - plc init script now named plc.init instead of former guest.init
342
343 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
344 - add Monitor to docs build
345
346 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
347 - plc_config.py and plc-config-tty: generalized to work for more diverse
348 - MyPLC configurations.
349 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
350 - deployments and increase the memory limits in php.ini
351 - plc.d/crond: add --full option to vacuumdb
352
353 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
354 - avoid generating ssl certificates for disabled services among www api boot
355
356 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
357 - cleaned up old entries in db-config
358 - mtail more robust
359
360 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
361 - php include path tweaked for plekit includes
362 - reviewed myplc (fka native) packaging dependencies
363 - renumbered 4.3
364
365 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
366 - rename myplc into myplc-chroot and myplc-native into myplc
367 - new settings (shortname & hrn_root) for local peer
368
369 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
370 - First iteration of new data model
371 - Bunch of various fixes
372
373 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
374 - Removed proper ops from planetflow slice.
375
376 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
377 - myplc-native requires myplc-docs
378 - fixed doc build by locating locally installed DTDs at build-time
379
380 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
381 - turn myplc-docs off for now
382
383 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
384 - figures in doc package
385
386 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
387 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
388 - chroot packaging does not have docs anymore
389 - 'cvs' and 'dev' not required from myplc-native anymore
390 - cosmetic change in kml output
391
392
393 %define module_current_branch 4.3