The other spec files too.
[myplc.git] / myplc-docs.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-docs
7 %define version 4.3
8 %define taglevel 38
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) online documentation
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 BuildRequires: docbook-dtds, docbook-utils-pdf
28
29 %define debug_package %{nil}
30
31 %description
32 This package contains the online documentation for MyPLC, i.e. the
33 reference manuals for the two APIs provided: PLCAPI and NMAPI. A
34 more general introduction to the MyPLC system can be found at
35 http://svn.planet-lab.org/wiki/MyPLCUserGuide
36
37 %prep
38 %setup -q
39
40 %build
41 rm -rf $RPM_BUILD_ROOT
42
43 pushd PLCAPI
44 # beware that making the pdf file somehow overwrites the html
45 make -C doc PLCAPI.pdf 
46 rm -f doc/PLCAPI.html
47 make -C doc PLCAPI.html 
48 popd
49
50 pushd NodeManager
51 # beware that making the pdf file somehow overwrites the html
52 make -C doc NMAPI.pdf 
53 rm -f doc/NMAPI.html
54 make -C doc NMAPI.html 
55 popd
56
57 pushd Monitor
58 # beware that making the pdf file somehow overwrites the html
59 make -C docs Monitor.pdf 
60 rm -f docs/Monitor.html
61 make -C docs Monitor.html 
62 popd
63
64 %install
65
66 for ext in pdf html; do
67     install -D -m 444 PLCAPI/doc/PLCAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.$ext
68     install -D -m 444 NodeManager/doc/NMAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.$ext
69     install -D -m 444 Monitor/docs/Monitor.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.$ext
70 done
71
72 ./MyPLC/docbook2drupal.sh "PLC API Documentation (%{pldistro})" \
73     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.html \
74     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.php 
75 ./MyPLC/docbook2drupal.sh "Node Manager API Documentation (%{pldistro})" \
76     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.html \
77     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.php 
78 ./MyPLC/docbook2drupal.sh "Monitor API Documentation (%{pldistro})" \
79     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.html \
80     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.php 
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %files
86 %defattr(-,root,root,-)
87 /var/www/html/planetlab/doc/
88
89 %changelog
90 * Thu Jul 22 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-38
91 - Add DRL slice.
92 - Generalize bootcd-kernel.
93
94 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
95 - support for fedora 12
96 - new package myplc-config for use by sfa
97 - drupal user registration turned off
98
99 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
100 - - fix to make sure when API, BOOT, MONITOR are on the same
101 - machine as WWW that the SSL key,cert for WWW takes precedence.
102 - - Do proper setup for SSL CA certficate to be used as the server
103 - chain.
104
105 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
106 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
107
108 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
109 - depend on pcucontrol
110
111 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
112 - * validate input according to type in plc_config
113 - * added the _genicw system slice
114 - * add tag types for sites and persons
115 - * add new tags for nodes and slices for exemption from myops
116
117 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
118 - turn off drupal on a box that acts as BOOT server but not as WWW server
119 - cleanup some obsolete code for old chroot-jail packaging in the process
120 - new bootcd-kernel script for keeping bootcd variants up2date
121
122 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
123 - Make the /etc/hosts manipulation optional.
124
125 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
126 - Fix SetRole.
127
128 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
129 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
130 - into the DB.
131 - - Added the root ssh key handling support back into plc.d/ssh and the
132 - default xml file.  This should be identical to the way it was in
133 - rc12.
134 - - Added support in the db-config.d/01-init script to register the root
135 - ssh public key with the default administrator.  In this way the root
136 - ssh key will make it into the root account on the nodes by means of
137 - NodeManager's specialaccounts plugin.
138
139 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
140 - db-config ignores sliver tags
141 - sirius's db-config script renamed (was sirious)
142
143 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
144 - fix for silverauth - missing tag types now created at plc startup time
145
146 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
147 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
148
149 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
150 - companion to NM's specialaccounts plugin
151 - do not generate /etc/planetlab/root_ssh_key* anymore
152 - remove related config. variables and conf_files
153
154 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
155 - clarified description text to refer only to plcrt and not other optional
156 - packages.
157
158 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
159 - fixed a bug setting slice multiple attributes with the same tag name
160
161 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
162 - SSL setup for monitor box, and related new config variables
163 - new conf_file for /etc/planetlab/extensions
164 - various tweaks in db-config internals, about initscripts among others
165 - also more messages defined in the db
166
167 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
168 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
169
170 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
171 - bugfix in db-config, tag 4.3-19 would not fly
172
173 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
174 - Refactored db-config into snippets in db-config.d/.
175
176 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
177 - oops, tag 4.3-17 was broken and would not work
178
179 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
180 - bugfix - escape sequences inserted in xml configs
181
182 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
183 - Handle db-config.d files properly.
184
185 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
186 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
187 - than the log file
188 - - Fix db-config to be a bit more cautious when
189 - /etc/planetlab/db-config.d doesn't exist
190 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
191 - .orig files.
192 - - Refactor generic plc-config-tty code into plc_config.py.
193 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
194 - and the list of validated variables and the corresponding
195 - validator() function. This refactoring lets one reuse plc_config.py
196 - as a generic cmdline configuration tool for highly customer MyPLC
197 - like software.
198
199 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
200 - update PCU Type descriptions.
201 - updates to init scripts
202
203 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
204 - requires monitor-pcucontrol so register-wizard can work
205
206 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
207 - cleaned up plc-config-tty, no more need to configure plc-devel
208
209 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
210 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
211
212 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
213 - tighter right permissions on site_admin's authorized keys for more robustness
214
215 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
216 - fix issue in db-config that prevented correct operation
217
218 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
219 - remove support for chroot-based packaging - no crond nor syslog step anymore
220 - plc init script now named plc.init instead of former guest.init
221
222 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
223 - add Monitor to docs build
224
225 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
226 - plc_config.py and plc-config-tty: generalized to work for more diverse
227 - MyPLC configurations.
228 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
229 - deployments and increase the memory limits in php.ini
230 - plc.d/crond: add --full option to vacuumdb
231
232 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
233 - avoid generating ssl certificates for disabled services among www api boot
234
235 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
236 - cleaned up old entries in db-config
237 - mtail more robust
238
239 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
240 - php include path tweaked for plekit includes
241 - reviewed myplc (fka native) packaging dependencies
242 - renumbered 4.3
243
244 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
245 - rename myplc into myplc-chroot and myplc-native into myplc
246 - new settings (shortname & hrn_root) for local peer
247
248 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
249 - First iteration of new data model
250 - Bunch of various fixes
251
252 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
253 - Removed proper ops from planetflow slice.
254
255 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
256 - myplc-native requires myplc-docs
257 - fixed doc build by locating locally installed DTDs at build-time
258
259 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
260 - turn myplc-docs off for now
261
262 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
263 - figures in doc package
264
265 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
266 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
267 - chroot packaging does not have docs anymore
268 - 'cvs' and 'dev' not required from myplc-native anymore
269 - cosmetic change in kml output
270
271
272 %define module_current_branch 4.2