workaround for dealing with /dev/random /dev/urandom in a libvirt environment that...
[myplc.git] / myplc-docs.spec
1 %define name myplc-docs
2 %define version 5.2
3 %define taglevel 1
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central (PLC) online documentation
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: Applications/Systems
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15 BuildArch: noarch
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21
22 BuildRequires: docbook-dtds, docbook-utils-pdf
23
24 %define debug_package %{nil}
25
26 %description
27 This package contains the online documentation for MyPLC, i.e. the
28 reference manuals for the two APIs provided: PLCAPI and NMAPI. A
29 more general introduction to the MyPLC system can be found at
30 http://svn.planet-lab.org/wiki/MyPLCUserGuide
31
32 %prep
33 %setup -q
34
35 %build
36 rm -rf $RPM_BUILD_ROOT
37
38 # using the new lowercase names, and handling legacy
39 [ -d myplc ] || ln -s MyPLC myplc
40 [ -d plcapi ] || ln -s PLCAPI plcapi
41 [ -d nodemanager ] || ln -s NodeManager nodemanager
42 [ -d monitor ] || ln -s Monitor monitor 
43
44 pushd plcapi
45 # june2011 & f12, latex issues weird warnings, might need to try twice
46 make -C doc PLCAPI.pdf || make -C doc PLCAPI.pdf 
47 # beware that making the pdf file somehow overwrites the html
48 rm -f doc/PLCAPI.html
49 make -C doc PLCAPI.html || make -C doc PLCAPI.html 
50 popd
51
52 pushd nodemanager
53 # beware that making the pdf file somehow overwrites the html
54 make -C doc NMAPI.pdf || make -C doc NMAPI.pdf
55 rm -f doc/NMAPI.html
56 make -C doc NMAPI.html || make -C doc NMAPI.html 
57 popd
58
59 # not everyone rebuilds monitor, so make it optional
60 if [ -d monitor ] ; then
61 pushd monitor
62 # beware that making the pdf file somehow overwrites the html
63 make -C docs Monitor.pdf || make -C docs Monitor.pdf 
64 rm -f docs/Monitor.html
65 make -C docs Monitor.html || make -C docs Monitor.html 
66 popd
67 fi
68
69 %install
70
71 for ext in pdf html; do
72     install -D -m 444 plcapi/doc/PLCAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.$ext
73     install -D -m 444 nodemanager/doc/NMAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.$ext
74     if [ -d monitor ] ; then
75     install -D -m 444 monitor/docs/Monitor.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.$ext
76     fi
77 done
78
79 ./myplc/docbook2drupal.sh "PLC API Documentation (%{pldistro})" \
80     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.html \
81     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.php 
82 ./myplc/docbook2drupal.sh "Node Manager API Documentation (%{pldistro})" \
83     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.html \
84     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.php 
85 if [ -d monitor ] ; then
86 ./myplc/docbook2drupal.sh "Monitor API Documentation (%{pldistro})" \
87     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.html \
88     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.php 
89 fi
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %files
95 %defattr(-,root,root,-)
96 /var/www/html/planetlab/doc/
97
98 %changelog
99 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-1
100 - supports httpd config for either mod_python (preferred) or mod_wsgi
101 - requires mod_wsgi on f18 only, otherwise mod_python
102 - supports httpd config for apache 2.4 (f18)
103 - new config variable PLC_FLAVOUR_VIRT_MAP to set 'virt' from fcdistro
104
105 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-6
106 - bugfix in check-vsys-defaults.py
107
108 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-5
109 - define open_basedir in php.ini to stop confidentiality leak
110 - new utility slice_ssh_keys.py for showing sliver keys (OMF interop)
111 - new config setting PLC_VSYS_DEFAULTS for vsys tags granted to all
112 - new utilities check-hrns.py and check-vsys-defaults.py
113
114 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-4
115 - set TimeoutSec to 300 in plc.service
116 - remove ref to deprecated svn $URL$ in db-config usage
117
118 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-3
119 - expose mtail.py as simply mtail
120
121 * Mon May 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-2
122 - plc-kml.py now has support for nodegroups
123
124 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-1
125 - use nodeimage package instead of deprecated bootstrapfs
126 - has systemd-friendly startup script
127 - plc_reload moved to functions/ - no more service plc reload
128 - no svn keywords anymore
129
130 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-19
131 - new maintenance/monitoring script spot-aliens to look for glitches in refreshpeer+sfa
132
133 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-18
134 - new settings for myslice (comon&tophat) and monitor (db)
135 - removed mentions of chroot in description
136 - can redo myplc-docs on broken f12-latex
137 - set short_open_tag in php.ini
138 - fixes in gen-sites-xml (is that still used ?)
139 - partial-repo.sh has moved to 'build' where it more belongs
140 - tweaks in convenience tool 'mtail'
141
142 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-17
143 - fixed changelog, no change from 5.0-16
144
145 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-16
146 - requires ed for the plc.d/packages step
147 - sirius initscript to handle stop and restart
148
149 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-15
150 - ignore steps in db-config.d if they have a '.' or '~' in their name
151
152 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-14
153 - can redo myplc-docs without the doc for monitor
154
155 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-13
156 - no semantic change - just fixed specfile for git URL
157
158 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
159 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
160
161 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
162 - add missing files to rpm package
163
164 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
165 - mtail.py -s for SFA
166 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
167
168 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
169 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
170
171 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
172 - plc-config-tty now has a validator on booleans
173 - e.g. entering 'True' now is rejected rather than silently recording 'false'
174
175 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
176 - disable mod_wsgi
177
178 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
179 - module name changes
180 - start wsgi support
181
182 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
183 - new setting PLC_RESERVATION_GRANULARITY
184
185 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
186 - * partial-repo.sh script
187 - * preserve key along with certificates
188
189 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
190 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
191
192 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
193 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
194 - new OMF category in the config
195 - create the drl system slice
196
197 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
198 - first working version of 5.0:
199 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
200 - nodefamily is 3-fold with pldistro-fcdistro-arch
201 - new PLC_FLAVOUR config category
202 - reviewed module layout
203 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
204
205 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
206 - support for fedora 12
207 - new package myplc-config for use by sfa
208 - drupal user registration turned off
209
210 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
211 - - fix to make sure when API, BOOT, MONITOR are on the same
212 - machine as WWW that the SSL key,cert for WWW takes precedence.
213 - - Do proper setup for SSL CA certficate to be used as the server
214 - chain.
215
216 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
217 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
218
219 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
220 - depend on pcucontrol
221
222 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
223 - * validate input according to type in plc_config
224 - * added the _genicw system slice
225 - * add tag types for sites and persons
226 - * add new tags for nodes and slices for exemption from myops
227
228 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
229 - turn off drupal on a box that acts as BOOT server but not as WWW server
230 - cleanup some obsolete code for old chroot-jail packaging in the process
231 - new bootcd-kernel script for keeping bootcd variants up2date
232
233 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
234 - Make the /etc/hosts manipulation optional.
235
236 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
237 - Fix SetRole.
238
239 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
240 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
241 - into the DB.
242 - - Added the root ssh key handling support back into plc.d/ssh and the
243 - default xml file.  This should be identical to the way it was in
244 - rc12.
245 - - Added support in the db-config.d/01-init script to register the root
246 - ssh public key with the default administrator.  In this way the root
247 - ssh key will make it into the root account on the nodes by means of
248 - NodeManager's specialaccounts plugin.
249
250 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
251 - db-config ignores sliver tags
252 - sirius's db-config script renamed (was sirious)
253
254 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
255 - fix for silverauth - missing tag types now created at plc startup time
256
257 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
258 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
259
260 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
261 - companion to NM's specialaccounts plugin
262 - do not generate /etc/planetlab/root_ssh_key* anymore
263 - remove related config. variables and conf_files
264
265 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
266 - clarified description text to refer only to plcrt and not other optional
267 - packages.
268
269 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
270 - fixed a bug setting slice multiple attributes with the same tag name
271
272 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
273 - SSL setup for monitor box, and related new config variables
274 - new conf_file for /etc/planetlab/extensions
275 - various tweaks in db-config internals, about initscripts among others
276 - also more messages defined in the db
277
278 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
279 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
280
281 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
282 - bugfix in db-config, tag 4.3-19 would not fly
283
284 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
285 - Refactored db-config into snippets in db-config.d/.
286
287 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
288 - oops, tag 4.3-17 was broken and would not work
289
290 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
291 - bugfix - escape sequences inserted in xml configs
292
293 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
294 - Handle db-config.d files properly.
295
296 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
297 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
298 - than the log file
299 - - Fix db-config to be a bit more cautious when
300 - /etc/planetlab/db-config.d doesn't exist
301 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
302 - .orig files.
303 - - Refactor generic plc-config-tty code into plc_config.py.
304 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
305 - and the list of validated variables and the corresponding
306 - validator() function. This refactoring lets one reuse plc_config.py
307 - as a generic cmdline configuration tool for highly customer MyPLC
308 - like software.
309
310 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
311 - update PCU Type descriptions.
312 - updates to init scripts
313
314 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
315 - requires monitor-pcucontrol so register-wizard can work
316
317 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
318 - cleaned up plc-config-tty, no more need to configure plc-devel
319
320 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
321 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
322
323 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
324 - tighter right permissions on site_admin's authorized keys for more robustness
325
326 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
327 - fix issue in db-config that prevented correct operation
328
329 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
330 - remove support for chroot-based packaging - no crond nor syslog step anymore
331 - plc init script now named plc.init instead of former guest.init
332
333 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
334 - add Monitor to docs build
335
336 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
337 - plc_config.py and plc-config-tty: generalized to work for more diverse
338 - MyPLC configurations.
339 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
340 - deployments and increase the memory limits in php.ini
341 - plc.d/crond: add --full option to vacuumdb
342
343 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
344 - avoid generating ssl certificates for disabled services among www api boot
345
346 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
347 - cleaned up old entries in db-config
348 - mtail more robust
349
350 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
351 - php include path tweaked for plekit includes
352 - reviewed myplc (fka native) packaging dependencies
353 - renumbered 4.3
354
355 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
356 - rename myplc into myplc-chroot and myplc-native into myplc
357 - new settings (shortname & hrn_root) for local peer
358
359 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
360 - First iteration of new data model
361 - Bunch of various fixes
362
363 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
364 - Removed proper ops from planetflow slice.
365
366 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
367 - myplc-native requires myplc-docs
368 - fixed doc build by locating locally installed DTDs at build-time
369
370 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
371 - turn myplc-docs off for now
372
373 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
374 - figures in doc package
375
376 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
377 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
378 - chroot packaging does not have docs anymore
379 - 'cvs' and 'dev' not required from myplc-native anymore
380 - cosmetic change in kml output
381
382
383 %define module_current_branch 4.3