trying again
[myplc.git] / myplc-docs.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-docs
7 %define version 5.0
8 %define taglevel 5
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) online documentation
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 BuildRequires: docbook-dtds, docbook-utils-pdf
28
29 %define debug_package %{nil}
30
31 %description
32 This package contains the online documentation for MyPLC, i.e. the
33 reference manuals for the two APIs provided: PLCAPI and NMAPI. A
34 more general introduction to the MyPLC system can be found at
35 http://svn.planet-lab.org/wiki/MyPLCUserGuide
36
37 %prep
38 %setup -q
39
40 %build
41 rm -rf $RPM_BUILD_ROOT
42
43 # using the new lowercase names, and handling legacy
44 [ -d plcapi ] || ln -s PLCAPI plcapi
45 pushd plcapi
46 # beware that making the pdf file somehow overwrites the html
47 make -C doc PLCAPI.pdf 
48 rm -f doc/PLCAPI.html
49 make -C doc PLCAPI.html 
50 popd
51
52 [ -d nodemanager ] || ln -s NodeManager nodemnager
53 pushd nodemanager
54 # beware that making the pdf file somehow overwrites the html
55 make -C doc NMAPI.pdf 
56 rm -f doc/NMAPI.html
57 make -C doc NMAPI.html 
58 popd
59
60 [ -d monitor ] || ln -s Monitor monitor 
61 pushd monitor
62 # beware that making the pdf file somehow overwrites the html
63 make -C docs Monitor.pdf 
64 rm -f docs/Monitor.html
65 make -C docs Monitor.html 
66 popd
67
68 %install
69
70 for ext in pdf html; do
71     install -D -m 444 plcapi/doc/PLCAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.$ext
72     install -D -m 444 nodemanager/doc/NMAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.$ext
73     install -D -m 444 monitor/docs/Monitor.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.$ext
74 done
75
76 ./MyPLC/docbook2drupal.sh "PLC API Documentation (%{pldistro})" \
77     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.html \
78     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.php 
79 ./MyPLC/docbook2drupal.sh "Node Manager API Documentation (%{pldistro})" \
80     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.html \
81     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.php 
82 ./MyPLC/docbook2drupal.sh "Monitor API Documentation (%{pldistro})" \
83     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.html \
84     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.php 
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %files
90 %defattr(-,root,root,-)
91 /var/www/html/planetlab/doc/
92
93 %changelog
94 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
95 - new setting PLC_RESERVATION_GRANULARITY
96
97 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
98 - * partial-repo.sh script
99 - * preserve key along with certificates
100
101 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
102 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
103
104 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
105 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
106 - new OMF category in the config
107 - create the drl system slice
108
109 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
110 - first working version of 5.0:
111 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
112 - nodefamily is 3-fold with pldistro-fcdistro-arch
113 - new PLC_FLAVOUR config category
114 - reviewed module layout
115 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
116
117 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
118 - support for fedora 12
119 - new package myplc-config for use by sfa
120 - drupal user registration turned off
121
122 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
123 - - fix to make sure when API, BOOT, MONITOR are on the same
124 - machine as WWW that the SSL key,cert for WWW takes precedence.
125 - - Do proper setup for SSL CA certficate to be used as the server
126 - chain.
127
128 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
129 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
130
131 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
132 - depend on pcucontrol
133
134 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
135 - * validate input according to type in plc_config
136 - * added the _genicw system slice
137 - * add tag types for sites and persons
138 - * add new tags for nodes and slices for exemption from myops
139
140 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
141 - turn off drupal on a box that acts as BOOT server but not as WWW server
142 - cleanup some obsolete code for old chroot-jail packaging in the process
143 - new bootcd-kernel script for keeping bootcd variants up2date
144
145 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
146 - Make the /etc/hosts manipulation optional.
147
148 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
149 - Fix SetRole.
150
151 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
152 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
153 - into the DB.
154 - - Added the root ssh key handling support back into plc.d/ssh and the
155 - default xml file.  This should be identical to the way it was in
156 - rc12.
157 - - Added support in the db-config.d/01-init script to register the root
158 - ssh public key with the default administrator.  In this way the root
159 - ssh key will make it into the root account on the nodes by means of
160 - NodeManager's specialaccounts plugin.
161
162 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
163 - db-config ignores sliver tags
164 - sirius's db-config script renamed (was sirious)
165
166 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
167 - fix for silverauth - missing tag types now created at plc startup time
168
169 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
170 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
171
172 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
173 - companion to NM's specialaccounts plugin
174 - do not generate /etc/planetlab/root_ssh_key* anymore
175 - remove related config. variables and conf_files
176
177 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
178 - clarified description text to refer only to plcrt and not other optional
179 - packages.
180
181 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
182 - fixed a bug setting slice multiple attributes with the same tag name
183
184 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
185 - SSL setup for monitor box, and related new config variables
186 - new conf_file for /etc/planetlab/extensions
187 - various tweaks in db-config internals, about initscripts among others
188 - also more messages defined in the db
189
190 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
191 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
192
193 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
194 - bugfix in db-config, tag 4.3-19 would not fly
195
196 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
197 - Refactored db-config into snippets in db-config.d/.
198
199 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
200 - oops, tag 4.3-17 was broken and would not work
201
202 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
203 - bugfix - escape sequences inserted in xml configs
204
205 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
206 - Handle db-config.d files properly.
207
208 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
209 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
210 - than the log file
211 - - Fix db-config to be a bit more cautious when
212 - /etc/planetlab/db-config.d doesn't exist
213 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
214 - .orig files.
215 - - Refactor generic plc-config-tty code into plc_config.py.
216 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
217 - and the list of validated variables and the corresponding
218 - validator() function. This refactoring lets one reuse plc_config.py
219 - as a generic cmdline configuration tool for highly customer MyPLC
220 - like software.
221
222 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
223 - update PCU Type descriptions.
224 - updates to init scripts
225
226 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
227 - requires monitor-pcucontrol so register-wizard can work
228
229 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
230 - cleaned up plc-config-tty, no more need to configure plc-devel
231
232 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
233 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
234
235 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
236 - tighter right permissions on site_admin's authorized keys for more robustness
237
238 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
239 - fix issue in db-config that prevented correct operation
240
241 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
242 - remove support for chroot-based packaging - no crond nor syslog step anymore
243 - plc init script now named plc.init instead of former guest.init
244
245 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
246 - add Monitor to docs build
247
248 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
249 - plc_config.py and plc-config-tty: generalized to work for more diverse
250 - MyPLC configurations.
251 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
252 - deployments and increase the memory limits in php.ini
253 - plc.d/crond: add --full option to vacuumdb
254
255 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
256 - avoid generating ssl certificates for disabled services among www api boot
257
258 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
259 - cleaned up old entries in db-config
260 - mtail more robust
261
262 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
263 - php include path tweaked for plekit includes
264 - reviewed myplc (fka native) packaging dependencies
265 - renumbered 4.3
266
267 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
268 - rename myplc into myplc-chroot and myplc-native into myplc
269 - new settings (shortname & hrn_root) for local peer
270
271 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
272 - First iteration of new data model
273 - Bunch of various fixes
274
275 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
276 - Removed proper ops from planetflow slice.
277
278 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
279 - myplc-native requires myplc-docs
280 - fixed doc build by locating locally installed DTDs at build-time
281
282 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
283 - turn myplc-docs off for now
284
285 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
286 - figures in doc package
287
288 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
289 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
290 - chroot packaging does not have docs anymore
291 - 'cvs' and 'dev' not required from myplc-native anymore
292 - cosmetic change in kml output
293
294
295 %define module_current_branch 4.3