documentation for myplc has moved to https://svn.planet-lab.org/wiki/MyPLCUserGuide
[myplc.git] / myplc-docs.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-docs
7 %define version 5.0
8 %define taglevel 0
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) online documentation
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 BuildRequires: docbook-dtds, docbook-utils-pdf
28
29 %define debug_package %{nil}
30
31 %description This package contains the online documentation for MyPLC,
32 in the form of the reference manuals for the two APIs provided: PLCAPI
33 and NMAPI. A general introduction to the MyPLC system can be found at
34 http://svn.planet-lab.org/wiki/MyPLCUserGuide
35
36 %prep
37 %setup -q
38
39 %build
40 rm -rf $RPM_BUILD_ROOT
41
42 pushd PLCAPI
43 # beware that making the pdf file somehow overwrites the html
44 make -C doc PLCAPI.pdf 
45 rm -f doc/PLCAPI.html
46 make -C doc PLCAPI.html 
47 popd
48
49 pushd NodeManager
50 # beware that making the pdf file somehow overwrites the html
51 make -C doc NMAPI.pdf 
52 rm -f doc/NMAPI.html
53 make -C doc NMAPI.html 
54 popd
55
56 %install
57
58 for ext in pdf html; do
59     install -D -m 444 PLCAPI/doc/PLCAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.$ext
60     install -D -m 444 NodeManager/doc/NMAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.$ext
61 done
62
63 ./MyPLC/docbook2drupal.sh "PLC API Documentation (%{pldistro})" \
64     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.html \
65     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.php 
66 ./MyPLC/docbook2drupal.sh "Node Manager API Documentation (%{pldistro})" \
67     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.html \
68     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.php 
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %files
74 %defattr(-,root,root,-)
75 /var/www/html/planetlab/doc/
76
77 %changelog
78 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
79 - Removed proper ops from planetflow slice.
80
81 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
82 - myplc-native requires myplc-docs
83 - fixed doc build by locating locally installed DTDs at build-time
84
85 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
86 - turn myplc-docs off for now
87
88 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
89 - figures in doc package
90
91 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
92 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
93 - chroot packaging does not have docs anymore
94 - 'cvs' and 'dev' not required from myplc-native anymore
95 - cosmetic change in kml output
96
97
98 %define module_current_branch 4.2