Setting tag MyPLC-4.3-25
[myplc.git] / myplc-docs.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-docs
7 %define version 4.3
8 %define taglevel 25
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) online documentation
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 BuildRequires: docbook-dtds, docbook-utils-pdf
28
29 %define debug_package %{nil}
30
31 %description
32 This package contains the online documentation for MyPLC, i.e. the
33 reference manuals for the two APIs provided: PLCAPI and NMAPI. A
34 more general introduction to the MyPLC system can be found at
35 http://svn.planet-lab.org/wiki/MyPLCUserGuide
36
37 %prep
38 %setup -q
39
40 %build
41 rm -rf $RPM_BUILD_ROOT
42
43 pushd PLCAPI
44 # beware that making the pdf file somehow overwrites the html
45 make -C doc PLCAPI.pdf 
46 rm -f doc/PLCAPI.html
47 make -C doc PLCAPI.html 
48 popd
49
50 pushd NodeManager
51 # beware that making the pdf file somehow overwrites the html
52 make -C doc NMAPI.pdf 
53 rm -f doc/NMAPI.html
54 make -C doc NMAPI.html 
55 popd
56
57 pushd Monitor
58 # beware that making the pdf file somehow overwrites the html
59 make -C docs Monitor.pdf 
60 rm -f docs/Monitor.html
61 make -C docs Monitor.html 
62 popd
63
64 %install
65
66 for ext in pdf html; do
67     install -D -m 444 PLCAPI/doc/PLCAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.$ext
68     install -D -m 444 NodeManager/doc/NMAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.$ext
69     install -D -m 444 Monitor/docs/Monitor.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.$ext
70 done
71
72 ./MyPLC/docbook2drupal.sh "PLC API Documentation (%{pldistro})" \
73     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.html \
74     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.php 
75 ./MyPLC/docbook2drupal.sh "Node Manager API Documentation (%{pldistro})" \
76     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.html \
77     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.php 
78 ./MyPLC/docbook2drupal.sh "Monitor API Documentation (%{pldistro})" \
79     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.html \
80     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.php 
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %files
86 %defattr(-,root,root,-)
87 /var/www/html/planetlab/doc/
88
89 %changelog
90 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
91 - companion to NM's specialaccounts plugin
92 - do not generate /etc/planetlab/root_ssh_key* anymore
93 - remove related config. variables and conf_files
94
95 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
96 - clarified description text to refer only to plcrt and not other optional
97 - packages.
98
99 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
100 - fixed a bug setting slice multiple attributes with the same tag name
101
102 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
103 - SSL setup for monitor box, and related new config variables
104 - new conf_file for /etc/planetlab/extensions
105 - various tweaks in db-config internals, about initscripts among others
106 - also more messages defined in the db
107
108 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
109 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
110
111 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
112 - bugfix in db-config, tag 4.3-19 would not fly
113
114 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
115 - Refactored db-config into snippets in db-config.d/.
116
117 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
118 - oops, tag 4.3-17 was broken and would not work
119
120 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
121 - bugfix - escape sequences inserted in xml configs
122
123 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
124 - Handle db-config.d files properly.
125
126 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
127 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
128 - than the log file
129 - - Fix db-config to be a bit more cautious when
130 - /etc/planetlab/db-config.d doesn't exist
131 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
132 - .orig files.
133 - - Refactor generic plc-config-tty code into plc_config.py.
134 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
135 - and the list of validated variables and the corresponding
136 - validator() function. This refactoring lets one reuse plc_config.py
137 - as a generic cmdline configuration tool for highly customer MyPLC
138 - like software.
139
140 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
141 - update PCU Type descriptions.
142 - updates to init scripts
143
144 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
145 - requires monitor-pcucontrol so register-wizard can work
146
147 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
148 - cleaned up plc-config-tty, no more need to configure plc-devel
149
150 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
151 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
152
153 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
154 - tighter right permissions on site_admin's authorized keys for more robustness
155
156 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
157 - fix issue in db-config that prevented correct operation
158
159 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
160 - remove support for chroot-based packaging - no crond nor syslog step anymore
161 - plc init script now named plc.init instead of former guest.init
162
163 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
164 - add Monitor to docs build
165
166 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
167 - plc_config.py and plc-config-tty: generalized to work for more diverse
168 - MyPLC configurations.
169 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
170 - deployments and increase the memory limits in php.ini
171 - plc.d/crond: add --full option to vacuumdb
172
173 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
174 - avoid generating ssl certificates for disabled services among www api boot
175
176 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
177 - cleaned up old entries in db-config
178 - mtail more robust
179
180 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
181 - php include path tweaked for plekit includes
182 - reviewed myplc (fka native) packaging dependencies
183 - renumbered 4.3
184
185 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
186 - rename myplc into myplc-chroot and myplc-native into myplc
187 - new settings (shortname & hrn_root) for local peer
188
189 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
190 - First iteration of new data model
191 - Bunch of various fixes
192
193 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
194 - Removed proper ops from planetflow slice.
195
196 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
197 - myplc-native requires myplc-docs
198 - fixed doc build by locating locally installed DTDs at build-time
199
200 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
201 - turn myplc-docs off for now
202
203 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
204 - figures in doc package
205
206 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
207 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
208 - chroot packaging does not have docs anymore
209 - 'cvs' and 'dev' not required from myplc-native anymore
210 - cosmetic change in kml output
211
212
213 %define module_current_branch 4.2