Setting tag MyPLC-4.3-35
[myplc.git] / myplc-docs.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-docs
7 %define version 4.3
8 %define taglevel 35
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) online documentation
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 BuildRequires: docbook-dtds, docbook-utils-pdf
28
29 %define debug_package %{nil}
30
31 %description
32 This package contains the online documentation for MyPLC, i.e. the
33 reference manuals for the two APIs provided: PLCAPI and NMAPI. A
34 more general introduction to the MyPLC system can be found at
35 http://svn.planet-lab.org/wiki/MyPLCUserGuide
36
37 %prep
38 %setup -q
39
40 %build
41 rm -rf $RPM_BUILD_ROOT
42
43 pushd PLCAPI
44 # beware that making the pdf file somehow overwrites the html
45 make -C doc PLCAPI.pdf 
46 rm -f doc/PLCAPI.html
47 make -C doc PLCAPI.html 
48 popd
49
50 pushd NodeManager
51 # beware that making the pdf file somehow overwrites the html
52 make -C doc NMAPI.pdf 
53 rm -f doc/NMAPI.html
54 make -C doc NMAPI.html 
55 popd
56
57 pushd Monitor
58 # beware that making the pdf file somehow overwrites the html
59 make -C docs Monitor.pdf 
60 rm -f docs/Monitor.html
61 make -C docs Monitor.html 
62 popd
63
64 %install
65
66 for ext in pdf html; do
67     install -D -m 444 PLCAPI/doc/PLCAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.$ext
68     install -D -m 444 NodeManager/doc/NMAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.$ext
69     install -D -m 444 Monitor/docs/Monitor.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.$ext
70 done
71
72 ./MyPLC/docbook2drupal.sh "PLC API Documentation (%{pldistro})" \
73     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.html \
74     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.php 
75 ./MyPLC/docbook2drupal.sh "Node Manager API Documentation (%{pldistro})" \
76     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.html \
77     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.php 
78 ./MyPLC/docbook2drupal.sh "Monitor API Documentation (%{pldistro})" \
79     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.html \
80     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.php 
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %files
86 %defattr(-,root,root,-)
87 /var/www/html/planetlab/doc/
88
89 %changelog
90 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
91 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
92
93 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
94 - depend on pcucontrol
95
96 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
97 - * validate input according to type in plc_config
98 - * added the _genicw system slice
99 - * add tag types for sites and persons
100 - * add new tags for nodes and slices for exemption from myops
101
102 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
103 - turn off drupal on a box that acts as BOOT server but not as WWW server
104 - cleanup some obsolete code for old chroot-jail packaging in the process
105 - new bootcd-kernel script for keeping bootcd variants up2date
106
107 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
108 - Make the /etc/hosts manipulation optional.
109
110 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
111 - Fix SetRole.
112
113 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
114 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
115 - into the DB.
116 - - Added the root ssh key handling support back into plc.d/ssh and the
117 - default xml file.  This should be identical to the way it was in
118 - rc12.
119 - - Added support in the db-config.d/01-init script to register the root
120 - ssh public key with the default administrator.  In this way the root
121 - ssh key will make it into the root account on the nodes by means of
122 - NodeManager's specialaccounts plugin.
123
124 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
125 - db-config ignores sliver tags
126 - sirius's db-config script renamed (was sirious)
127
128 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
129 - fix for silverauth - missing tag types now created at plc startup time
130
131 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
132 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
133
134 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
135 - companion to NM's specialaccounts plugin
136 - do not generate /etc/planetlab/root_ssh_key* anymore
137 - remove related config. variables and conf_files
138
139 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
140 - clarified description text to refer only to plcrt and not other optional
141 - packages.
142
143 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
144 - fixed a bug setting slice multiple attributes with the same tag name
145
146 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
147 - SSL setup for monitor box, and related new config variables
148 - new conf_file for /etc/planetlab/extensions
149 - various tweaks in db-config internals, about initscripts among others
150 - also more messages defined in the db
151
152 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
153 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
154
155 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
156 - bugfix in db-config, tag 4.3-19 would not fly
157
158 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
159 - Refactored db-config into snippets in db-config.d/.
160
161 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
162 - oops, tag 4.3-17 was broken and would not work
163
164 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
165 - bugfix - escape sequences inserted in xml configs
166
167 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
168 - Handle db-config.d files properly.
169
170 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
171 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
172 - than the log file
173 - - Fix db-config to be a bit more cautious when
174 - /etc/planetlab/db-config.d doesn't exist
175 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
176 - .orig files.
177 - - Refactor generic plc-config-tty code into plc_config.py.
178 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
179 - and the list of validated variables and the corresponding
180 - validator() function. This refactoring lets one reuse plc_config.py
181 - as a generic cmdline configuration tool for highly customer MyPLC
182 - like software.
183
184 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
185 - update PCU Type descriptions.
186 - updates to init scripts
187
188 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
189 - requires monitor-pcucontrol so register-wizard can work
190
191 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
192 - cleaned up plc-config-tty, no more need to configure plc-devel
193
194 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
195 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
196
197 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
198 - tighter right permissions on site_admin's authorized keys for more robustness
199
200 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
201 - fix issue in db-config that prevented correct operation
202
203 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
204 - remove support for chroot-based packaging - no crond nor syslog step anymore
205 - plc init script now named plc.init instead of former guest.init
206
207 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
208 - add Monitor to docs build
209
210 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
211 - plc_config.py and plc-config-tty: generalized to work for more diverse
212 - MyPLC configurations.
213 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
214 - deployments and increase the memory limits in php.ini
215 - plc.d/crond: add --full option to vacuumdb
216
217 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
218 - avoid generating ssl certificates for disabled services among www api boot
219
220 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
221 - cleaned up old entries in db-config
222 - mtail more robust
223
224 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
225 - php include path tweaked for plekit includes
226 - reviewed myplc (fka native) packaging dependencies
227 - renumbered 4.3
228
229 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
230 - rename myplc into myplc-chroot and myplc-native into myplc
231 - new settings (shortname & hrn_root) for local peer
232
233 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
234 - First iteration of new data model
235 - Bunch of various fixes
236
237 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
238 - Removed proper ops from planetflow slice.
239
240 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
241 - myplc-native requires myplc-docs
242 - fixed doc build by locating locally installed DTDs at build-time
243
244 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
245 - turn myplc-docs off for now
246
247 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
248 - figures in doc package
249
250 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
251 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
252 - chroot packaging does not have docs anymore
253 - 'cvs' and 'dev' not required from myplc-native anymore
254 - cosmetic change in kml output
255
256
257 %define module_current_branch 4.2