Setting tag MyPLC-4.3-30
[myplc.git] / myplc-docs.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-docs
7 %define version 4.3
8 %define taglevel 30
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) online documentation
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 BuildRequires: docbook-dtds, docbook-utils-pdf
28
29 %define debug_package %{nil}
30
31 %description
32 This package contains the online documentation for MyPLC, i.e. the
33 reference manuals for the two APIs provided: PLCAPI and NMAPI. A
34 more general introduction to the MyPLC system can be found at
35 http://svn.planet-lab.org/wiki/MyPLCUserGuide
36
37 %prep
38 %setup -q
39
40 %build
41 rm -rf $RPM_BUILD_ROOT
42
43 pushd PLCAPI
44 # beware that making the pdf file somehow overwrites the html
45 make -C doc PLCAPI.pdf 
46 rm -f doc/PLCAPI.html
47 make -C doc PLCAPI.html 
48 popd
49
50 pushd NodeManager
51 # beware that making the pdf file somehow overwrites the html
52 make -C doc NMAPI.pdf 
53 rm -f doc/NMAPI.html
54 make -C doc NMAPI.html 
55 popd
56
57 pushd Monitor
58 # beware that making the pdf file somehow overwrites the html
59 make -C docs Monitor.pdf 
60 rm -f docs/Monitor.html
61 make -C docs Monitor.html 
62 popd
63
64 %install
65
66 for ext in pdf html; do
67     install -D -m 444 PLCAPI/doc/PLCAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.$ext
68     install -D -m 444 NodeManager/doc/NMAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.$ext
69     install -D -m 444 Monitor/docs/Monitor.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.$ext
70 done
71
72 ./MyPLC/docbook2drupal.sh "PLC API Documentation (%{pldistro})" \
73     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.html \
74     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.php 
75 ./MyPLC/docbook2drupal.sh "Node Manager API Documentation (%{pldistro})" \
76     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.html \
77     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.php 
78 ./MyPLC/docbook2drupal.sh "Monitor API Documentation (%{pldistro})" \
79     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.html \
80     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.php 
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %files
86 %defattr(-,root,root,-)
87 /var/www/html/planetlab/doc/
88
89 %changelog
90 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
91 - Fix SetRole.
92
93 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
94 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
95 - into the DB.
96 - - Added the root ssh key handling support back into plc.d/ssh and the
97 - default xml file.  This should be identical to the way it was in
98 - rc12.
99 - - Added support in the db-config.d/01-init script to register the root
100 - ssh public key with the default administrator.  In this way the root
101 - ssh key will make it into the root account on the nodes by means of
102 - NodeManager's specialaccounts plugin.
103
104 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
105 - db-config ignores sliver tags
106 - sirius's db-config script renamed (was sirious)
107
108 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
109 - fix for silverauth - missing tag types now created at plc startup time
110
111 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
112 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
113
114 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
115 - companion to NM's specialaccounts plugin
116 - do not generate /etc/planetlab/root_ssh_key* anymore
117 - remove related config. variables and conf_files
118
119 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
120 - clarified description text to refer only to plcrt and not other optional
121 - packages.
122
123 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
124 - fixed a bug setting slice multiple attributes with the same tag name
125
126 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
127 - SSL setup for monitor box, and related new config variables
128 - new conf_file for /etc/planetlab/extensions
129 - various tweaks in db-config internals, about initscripts among others
130 - also more messages defined in the db
131
132 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
133 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
134
135 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
136 - bugfix in db-config, tag 4.3-19 would not fly
137
138 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
139 - Refactored db-config into snippets in db-config.d/.
140
141 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
142 - oops, tag 4.3-17 was broken and would not work
143
144 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
145 - bugfix - escape sequences inserted in xml configs
146
147 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
148 - Handle db-config.d files properly.
149
150 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
151 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
152 - than the log file
153 - - Fix db-config to be a bit more cautious when
154 - /etc/planetlab/db-config.d doesn't exist
155 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
156 - .orig files.
157 - - Refactor generic plc-config-tty code into plc_config.py.
158 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
159 - and the list of validated variables and the corresponding
160 - validator() function. This refactoring lets one reuse plc_config.py
161 - as a generic cmdline configuration tool for highly customer MyPLC
162 - like software.
163
164 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
165 - update PCU Type descriptions.
166 - updates to init scripts
167
168 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
169 - requires monitor-pcucontrol so register-wizard can work
170
171 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
172 - cleaned up plc-config-tty, no more need to configure plc-devel
173
174 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
175 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
176
177 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
178 - tighter right permissions on site_admin's authorized keys for more robustness
179
180 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
181 - fix issue in db-config that prevented correct operation
182
183 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
184 - remove support for chroot-based packaging - no crond nor syslog step anymore
185 - plc init script now named plc.init instead of former guest.init
186
187 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
188 - add Monitor to docs build
189
190 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
191 - plc_config.py and plc-config-tty: generalized to work for more diverse
192 - MyPLC configurations.
193 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
194 - deployments and increase the memory limits in php.ini
195 - plc.d/crond: add --full option to vacuumdb
196
197 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
198 - avoid generating ssl certificates for disabled services among www api boot
199
200 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
201 - cleaned up old entries in db-config
202 - mtail more robust
203
204 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
205 - php include path tweaked for plekit includes
206 - reviewed myplc (fka native) packaging dependencies
207 - renumbered 4.3
208
209 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
210 - rename myplc into myplc-chroot and myplc-native into myplc
211 - new settings (shortname & hrn_root) for local peer
212
213 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
214 - First iteration of new data model
215 - Bunch of various fixes
216
217 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
218 - Removed proper ops from planetflow slice.
219
220 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
221 - myplc-native requires myplc-docs
222 - fixed doc build by locating locally installed DTDs at build-time
223
224 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
225 - turn myplc-docs off for now
226
227 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
228 - figures in doc package
229
230 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
231 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
232 - chroot packaging does not have docs anymore
233 - 'cvs' and 'dev' not required from myplc-native anymore
234 - cosmetic change in kml output
235
236
237 %define module_current_branch 4.2