Tagging module MyPLC - MyPLC-4.3-18
[myplc.git] / myplc-docs.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-docs
7 %define version 4.3
8 %define taglevel 18
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) online documentation
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 BuildRequires: docbook-dtds, docbook-utils-pdf
28
29 %define debug_package %{nil}
30
31 %description
32 This package contains the online documentation for MyPLC, i.e. the
33 reference manuals for the two APIs provided: PLCAPI and NMAPI. A
34 more general introduction to the MyPLC system can be found at
35 http://svn.planet-lab.org/wiki/MyPLCUserGuide
36
37 %prep
38 %setup -q
39
40 %build
41 rm -rf $RPM_BUILD_ROOT
42
43 pushd PLCAPI
44 # beware that making the pdf file somehow overwrites the html
45 make -C doc PLCAPI.pdf 
46 rm -f doc/PLCAPI.html
47 make -C doc PLCAPI.html 
48 popd
49
50 pushd NodeManager
51 # beware that making the pdf file somehow overwrites the html
52 make -C doc NMAPI.pdf 
53 rm -f doc/NMAPI.html
54 make -C doc NMAPI.html 
55 popd
56
57 pushd Monitor
58 # beware that making the pdf file somehow overwrites the html
59 make -C docs Monitor.pdf 
60 rm -f docs/Monitor.html
61 make -C docs Monitor.html 
62 popd
63
64 %install
65
66 for ext in pdf html; do
67     install -D -m 444 PLCAPI/doc/PLCAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.$ext
68     install -D -m 444 NodeManager/doc/NMAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.$ext
69     install -D -m 444 Monitor/docs/Monitor.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.$ext
70 done
71
72 ./MyPLC/docbook2drupal.sh "PLC API Documentation (%{pldistro})" \
73     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.html \
74     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.php 
75 ./MyPLC/docbook2drupal.sh "Node Manager API Documentation (%{pldistro})" \
76     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.html \
77     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.php 
78 ./MyPLC/docbook2drupal.sh "Monitor API Documentation (%{pldistro})" \
79     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.html \
80     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.php 
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %files
86 %defattr(-,root,root,-)
87 /var/www/html/planetlab/doc/
88
89 %changelog
90 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
91 - oops, tag 4.3-17 was broken and would not work
92
93 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
94 - bugfix - escape sequences inserted in xml configs
95
96 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
97 - Handle db-config.d files properly.
98
99 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
100 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
101 - than the log file
102 - - Fix db-config to be a bit more cautious when
103 - /etc/planetlab/db-config.d doesn't exist
104 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
105 - .orig files.
106 - - Refactor generic plc-config-tty code into plc_config.py.
107 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
108 - and the list of validated variables and the corresponding
109 - validator() function. This refactoring lets one reuse plc_config.py
110 - as a generic cmdline configuration tool for highly customer MyPLC
111 - like software.
112
113 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
114 - update PCU Type descriptions.
115 - updates to init scripts
116
117 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
118 - requires monitor-pcucontrol so register-wizard can work
119
120 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
121 - cleaned up plc-config-tty, no more need to configure plc-devel
122
123 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
124 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
125
126 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
127 - tighter right permissions on site_admin's authorized keys for more robustness
128
129 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
130 - fix issue in db-config that prevented correct operation
131
132 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
133 - remove support for chroot-based packaging - no crond nor syslog step anymore
134 - plc init script now named plc.init instead of former guest.init
135
136 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
137 - add Monitor to docs build
138
139 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
140 - plc_config.py and plc-config-tty: generalized to work for more diverse
141 - MyPLC configurations.
142 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
143 - deployments and increase the memory limits in php.ini
144 - plc.d/crond: add --full option to vacuumdb
145
146 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
147 - avoid generating ssl certificates for disabled services among www api boot
148
149 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
150 - cleaned up old entries in db-config
151 - mtail more robust
152
153 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
154 - php include path tweaked for plekit includes
155 - reviewed myplc (fka native) packaging dependencies
156 - renumbered 4.3
157
158 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
159 - rename myplc into myplc-chroot and myplc-native into myplc
160 - new settings (shortname & hrn_root) for local peer
161
162 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
163 - First iteration of new data model
164 - Bunch of various fixes
165
166 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
167 - Removed proper ops from planetflow slice.
168
169 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
170 - myplc-native requires myplc-docs
171 - fixed doc build by locating locally installed DTDs at build-time
172
173 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
174 - turn myplc-docs off for now
175
176 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
177 - figures in doc package
178
179 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
180 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
181 - chroot packaging does not have docs anymore
182 - 'cvs' and 'dev' not required from myplc-native anymore
183 - cosmetic change in kml output
184
185
186 %define module_current_branch 4.2