Setting tag MyPLC-4.3-24
[myplc.git] / myplc-docs.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-docs
7 %define version 4.3
8 %define taglevel 24
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) online documentation
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 BuildRequires: docbook-dtds, docbook-utils-pdf
28
29 %define debug_package %{nil}
30
31 %description
32 This package contains the online documentation for MyPLC, i.e. the
33 reference manuals for the two APIs provided: PLCAPI and NMAPI. A
34 more general introduction to the MyPLC system can be found at
35 http://svn.planet-lab.org/wiki/MyPLCUserGuide
36
37 %prep
38 %setup -q
39
40 %build
41 rm -rf $RPM_BUILD_ROOT
42
43 pushd PLCAPI
44 # beware that making the pdf file somehow overwrites the html
45 make -C doc PLCAPI.pdf 
46 rm -f doc/PLCAPI.html
47 make -C doc PLCAPI.html 
48 popd
49
50 pushd NodeManager
51 # beware that making the pdf file somehow overwrites the html
52 make -C doc NMAPI.pdf 
53 rm -f doc/NMAPI.html
54 make -C doc NMAPI.html 
55 popd
56
57 pushd Monitor
58 # beware that making the pdf file somehow overwrites the html
59 make -C docs Monitor.pdf 
60 rm -f docs/Monitor.html
61 make -C docs Monitor.html 
62 popd
63
64 %install
65
66 for ext in pdf html; do
67     install -D -m 444 PLCAPI/doc/PLCAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.$ext
68     install -D -m 444 NodeManager/doc/NMAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.$ext
69     install -D -m 444 Monitor/docs/Monitor.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.$ext
70 done
71
72 ./MyPLC/docbook2drupal.sh "PLC API Documentation (%{pldistro})" \
73     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.html \
74     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.php 
75 ./MyPLC/docbook2drupal.sh "Node Manager API Documentation (%{pldistro})" \
76     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.html \
77     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.php 
78 ./MyPLC/docbook2drupal.sh "Monitor API Documentation (%{pldistro})" \
79     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.html \
80     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.php 
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %files
86 %defattr(-,root,root,-)
87 /var/www/html/planetlab/doc/
88
89 %changelog
90 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
91 - clarified description text to refer only to plcrt and not other optional
92 - packages.
93
94 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
95 - fixed a bug setting slice multiple attributes with the same tag name
96
97 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
98 - SSL setup for monitor box, and related new config variables
99 - new conf_file for /etc/planetlab/extensions
100 - various tweaks in db-config internals, about initscripts among others
101 - also more messages defined in the db
102
103 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
104 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
105
106 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
107 - bugfix in db-config, tag 4.3-19 would not fly
108
109 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
110 - Refactored db-config into snippets in db-config.d/.
111
112 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
113 - oops, tag 4.3-17 was broken and would not work
114
115 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
116 - bugfix - escape sequences inserted in xml configs
117
118 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
119 - Handle db-config.d files properly.
120
121 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
122 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
123 - than the log file
124 - - Fix db-config to be a bit more cautious when
125 - /etc/planetlab/db-config.d doesn't exist
126 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
127 - .orig files.
128 - - Refactor generic plc-config-tty code into plc_config.py.
129 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
130 - and the list of validated variables and the corresponding
131 - validator() function. This refactoring lets one reuse plc_config.py
132 - as a generic cmdline configuration tool for highly customer MyPLC
133 - like software.
134
135 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
136 - update PCU Type descriptions.
137 - updates to init scripts
138
139 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
140 - requires monitor-pcucontrol so register-wizard can work
141
142 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
143 - cleaned up plc-config-tty, no more need to configure plc-devel
144
145 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
146 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
147
148 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
149 - tighter right permissions on site_admin's authorized keys for more robustness
150
151 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
152 - fix issue in db-config that prevented correct operation
153
154 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
155 - remove support for chroot-based packaging - no crond nor syslog step anymore
156 - plc init script now named plc.init instead of former guest.init
157
158 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
159 - add Monitor to docs build
160
161 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
162 - plc_config.py and plc-config-tty: generalized to work for more diverse
163 - MyPLC configurations.
164 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
165 - deployments and increase the memory limits in php.ini
166 - plc.d/crond: add --full option to vacuumdb
167
168 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
169 - avoid generating ssl certificates for disabled services among www api boot
170
171 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
172 - cleaned up old entries in db-config
173 - mtail more robust
174
175 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
176 - php include path tweaked for plekit includes
177 - reviewed myplc (fka native) packaging dependencies
178 - renumbered 4.3
179
180 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
181 - rename myplc into myplc-chroot and myplc-native into myplc
182 - new settings (shortname & hrn_root) for local peer
183
184 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
185 - First iteration of new data model
186 - Bunch of various fixes
187
188 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
189 - Removed proper ops from planetflow slice.
190
191 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
192 - myplc-native requires myplc-docs
193 - fixed doc build by locating locally installed DTDs at build-time
194
195 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
196 - turn myplc-docs off for now
197
198 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
199 - figures in doc package
200
201 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
202 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
203 - chroot packaging does not have docs anymore
204 - 'cvs' and 'dev' not required from myplc-native anymore
205 - cosmetic change in kml output
206
207
208 %define module_current_branch 4.2