not everyone builds monitor, make it optional
[myplc.git] / myplc-docs.spec
1 %define name myplc-docs
2 %define version 5.0
3 %define taglevel 13
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central (PLC) online documentation
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: Applications/Systems
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15 BuildArch: noarch
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21
22 BuildRequires: docbook-dtds, docbook-utils-pdf
23
24 %define debug_package %{nil}
25
26 %description
27 This package contains the online documentation for MyPLC, i.e. the
28 reference manuals for the two APIs provided: PLCAPI and NMAPI. A
29 more general introduction to the MyPLC system can be found at
30 http://svn.planet-lab.org/wiki/MyPLCUserGuide
31
32 %prep
33 %setup -q
34
35 %build
36 rm -rf $RPM_BUILD_ROOT
37
38 # using the new lowercase names, and handling legacy
39 [ -d myplc ] || ln -s MyPLC myplc
40 [ -d plcapi ] || ln -s PLCAPI plcapi
41 [ -d nodemanager ] || ln -s NodeManager nodemanager
42 [ -d monitor ] || ln -s Monitor monitor 
43
44 pushd plcapi
45 # beware that making the pdf file somehow overwrites the html
46 make -C doc PLCAPI.pdf 
47 rm -f doc/PLCAPI.html
48 make -C doc PLCAPI.html 
49 popd
50
51 pushd nodemanager
52 # beware that making the pdf file somehow overwrites the html
53 make -C doc NMAPI.pdf 
54 rm -f doc/NMAPI.html
55 make -C doc NMAPI.html 
56 popd
57
58 # not everyone rebuilds monitor, so make it optional
59 if [ -d monitor ] ; then
60 pushd monitor
61 # beware that making the pdf file somehow overwrites the html
62 make -C docs Monitor.pdf 
63 rm -f docs/Monitor.html
64 make -C docs Monitor.html 
65 popd
66 fi
67
68 %install
69
70 for ext in pdf html; do
71     install -D -m 444 plcapi/doc/PLCAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.$ext
72     install -D -m 444 nodemanager/doc/NMAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.$ext
73     if [ -d monitor ] ; then
74     install -D -m 444 monitor/docs/Monitor.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.$ext
75     fi
76 done
77
78 ./myplc/docbook2drupal.sh "PLC API Documentation (%{pldistro})" \
79     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.html \
80     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.php 
81 ./myplc/docbook2drupal.sh "Node Manager API Documentation (%{pldistro})" \
82     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.html \
83     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.php 
84 if [ -d monitor ] ; then
85 ./myplc/docbook2drupal.sh "Monitor API Documentation (%{pldistro})" \
86     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.html \
87     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.php 
88 fi
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %files
94 %defattr(-,root,root,-)
95 /var/www/html/planetlab/doc/
96
97 %changelog
98 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-13
99 - no semantic change - just fixed specfile for git URL
100
101 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
102 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
103
104 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
105 - add missing files to rpm package
106
107 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
108 - mtail.py -s for SFA
109 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
110
111 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
112 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
113
114 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
115 - plc-config-tty now has a validator on booleans
116 - e.g. entering 'True' now is rejected rather than silently recording 'false'
117
118 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
119 - disable mod_wsgi
120
121 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
122 - module name changes
123 - start wsgi support
124
125 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
126 - new setting PLC_RESERVATION_GRANULARITY
127
128 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
129 - * partial-repo.sh script
130 - * preserve key along with certificates
131
132 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
133 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
134
135 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
136 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
137 - new OMF category in the config
138 - create the drl system slice
139
140 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
141 - first working version of 5.0:
142 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
143 - nodefamily is 3-fold with pldistro-fcdistro-arch
144 - new PLC_FLAVOUR config category
145 - reviewed module layout
146 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
147
148 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
149 - support for fedora 12
150 - new package myplc-config for use by sfa
151 - drupal user registration turned off
152
153 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
154 - - fix to make sure when API, BOOT, MONITOR are on the same
155 - machine as WWW that the SSL key,cert for WWW takes precedence.
156 - - Do proper setup for SSL CA certficate to be used as the server
157 - chain.
158
159 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
160 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
161
162 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
163 - depend on pcucontrol
164
165 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
166 - * validate input according to type in plc_config
167 - * added the _genicw system slice
168 - * add tag types for sites and persons
169 - * add new tags for nodes and slices for exemption from myops
170
171 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
172 - turn off drupal on a box that acts as BOOT server but not as WWW server
173 - cleanup some obsolete code for old chroot-jail packaging in the process
174 - new bootcd-kernel script for keeping bootcd variants up2date
175
176 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
177 - Make the /etc/hosts manipulation optional.
178
179 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
180 - Fix SetRole.
181
182 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
183 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
184 - into the DB.
185 - - Added the root ssh key handling support back into plc.d/ssh and the
186 - default xml file.  This should be identical to the way it was in
187 - rc12.
188 - - Added support in the db-config.d/01-init script to register the root
189 - ssh public key with the default administrator.  In this way the root
190 - ssh key will make it into the root account on the nodes by means of
191 - NodeManager's specialaccounts plugin.
192
193 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
194 - db-config ignores sliver tags
195 - sirius's db-config script renamed (was sirious)
196
197 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
198 - fix for silverauth - missing tag types now created at plc startup time
199
200 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
201 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
202
203 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
204 - companion to NM's specialaccounts plugin
205 - do not generate /etc/planetlab/root_ssh_key* anymore
206 - remove related config. variables and conf_files
207
208 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
209 - clarified description text to refer only to plcrt and not other optional
210 - packages.
211
212 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
213 - fixed a bug setting slice multiple attributes with the same tag name
214
215 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
216 - SSL setup for monitor box, and related new config variables
217 - new conf_file for /etc/planetlab/extensions
218 - various tweaks in db-config internals, about initscripts among others
219 - also more messages defined in the db
220
221 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
222 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
223
224 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
225 - bugfix in db-config, tag 4.3-19 would not fly
226
227 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
228 - Refactored db-config into snippets in db-config.d/.
229
230 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
231 - oops, tag 4.3-17 was broken and would not work
232
233 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
234 - bugfix - escape sequences inserted in xml configs
235
236 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
237 - Handle db-config.d files properly.
238
239 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
240 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
241 - than the log file
242 - - Fix db-config to be a bit more cautious when
243 - /etc/planetlab/db-config.d doesn't exist
244 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
245 - .orig files.
246 - - Refactor generic plc-config-tty code into plc_config.py.
247 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
248 - and the list of validated variables and the corresponding
249 - validator() function. This refactoring lets one reuse plc_config.py
250 - as a generic cmdline configuration tool for highly customer MyPLC
251 - like software.
252
253 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
254 - update PCU Type descriptions.
255 - updates to init scripts
256
257 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
258 - requires monitor-pcucontrol so register-wizard can work
259
260 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
261 - cleaned up plc-config-tty, no more need to configure plc-devel
262
263 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
264 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
265
266 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
267 - tighter right permissions on site_admin's authorized keys for more robustness
268
269 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
270 - fix issue in db-config that prevented correct operation
271
272 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
273 - remove support for chroot-based packaging - no crond nor syslog step anymore
274 - plc init script now named plc.init instead of former guest.init
275
276 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
277 - add Monitor to docs build
278
279 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
280 - plc_config.py and plc-config-tty: generalized to work for more diverse
281 - MyPLC configurations.
282 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
283 - deployments and increase the memory limits in php.ini
284 - plc.d/crond: add --full option to vacuumdb
285
286 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
287 - avoid generating ssl certificates for disabled services among www api boot
288
289 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
290 - cleaned up old entries in db-config
291 - mtail more robust
292
293 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
294 - php include path tweaked for plekit includes
295 - reviewed myplc (fka native) packaging dependencies
296 - renumbered 4.3
297
298 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
299 - rename myplc into myplc-chroot and myplc-native into myplc
300 - new settings (shortname & hrn_root) for local peer
301
302 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
303 - First iteration of new data model
304 - Bunch of various fixes
305
306 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
307 - Removed proper ops from planetflow slice.
308
309 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
310 - myplc-native requires myplc-docs
311 - fixed doc build by locating locally installed DTDs at build-time
312
313 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
314 - turn myplc-docs off for now
315
316 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
317 - figures in doc package
318
319 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
320 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
321 - chroot packaging does not have docs anymore
322 - 'cvs' and 'dev' not required from myplc-native anymore
323 - cosmetic change in kml output
324
325
326 %define module_current_branch 4.3