Setting tag MyPLC-4.3-23
[myplc.git] / myplc-docs.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-docs
7 %define version 4.3
8 %define taglevel 23
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) online documentation
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 BuildRequires: docbook-dtds, docbook-utils-pdf
28
29 %define debug_package %{nil}
30
31 %description
32 This package contains the online documentation for MyPLC, i.e. the
33 reference manuals for the two APIs provided: PLCAPI and NMAPI. A
34 more general introduction to the MyPLC system can be found at
35 http://svn.planet-lab.org/wiki/MyPLCUserGuide
36
37 %prep
38 %setup -q
39
40 %build
41 rm -rf $RPM_BUILD_ROOT
42
43 pushd PLCAPI
44 # beware that making the pdf file somehow overwrites the html
45 make -C doc PLCAPI.pdf 
46 rm -f doc/PLCAPI.html
47 make -C doc PLCAPI.html 
48 popd
49
50 pushd NodeManager
51 # beware that making the pdf file somehow overwrites the html
52 make -C doc NMAPI.pdf 
53 rm -f doc/NMAPI.html
54 make -C doc NMAPI.html 
55 popd
56
57 pushd Monitor
58 # beware that making the pdf file somehow overwrites the html
59 make -C docs Monitor.pdf 
60 rm -f docs/Monitor.html
61 make -C docs Monitor.html 
62 popd
63
64 %install
65
66 for ext in pdf html; do
67     install -D -m 444 PLCAPI/doc/PLCAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.$ext
68     install -D -m 444 NodeManager/doc/NMAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.$ext
69     install -D -m 444 Monitor/docs/Monitor.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.$ext
70 done
71
72 ./MyPLC/docbook2drupal.sh "PLC API Documentation (%{pldistro})" \
73     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.html \
74     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.php 
75 ./MyPLC/docbook2drupal.sh "Node Manager API Documentation (%{pldistro})" \
76     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.html \
77     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.php 
78 ./MyPLC/docbook2drupal.sh "Monitor API Documentation (%{pldistro})" \
79     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.html \
80     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.php 
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %files
86 %defattr(-,root,root,-)
87 /var/www/html/planetlab/doc/
88
89 %changelog
90 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
91 - fixed a bug setting slice multiple attributes with the same tag name
92
93 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
94 - SSL setup for monitor box, and related new config variables
95 - new conf_file for /etc/planetlab/extensions
96 - various tweaks in db-config internals, about initscripts among others
97 - also more messages defined in the db
98
99 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
100 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
101
102 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
103 - bugfix in db-config, tag 4.3-19 would not fly
104
105 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
106 - Refactored db-config into snippets in db-config.d/.
107
108 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
109 - oops, tag 4.3-17 was broken and would not work
110
111 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
112 - bugfix - escape sequences inserted in xml configs
113
114 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
115 - Handle db-config.d files properly.
116
117 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
118 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
119 - than the log file
120 - - Fix db-config to be a bit more cautious when
121 - /etc/planetlab/db-config.d doesn't exist
122 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
123 - .orig files.
124 - - Refactor generic plc-config-tty code into plc_config.py.
125 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
126 - and the list of validated variables and the corresponding
127 - validator() function. This refactoring lets one reuse plc_config.py
128 - as a generic cmdline configuration tool for highly customer MyPLC
129 - like software.
130
131 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
132 - update PCU Type descriptions.
133 - updates to init scripts
134
135 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
136 - requires monitor-pcucontrol so register-wizard can work
137
138 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
139 - cleaned up plc-config-tty, no more need to configure plc-devel
140
141 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
142 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
143
144 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
145 - tighter right permissions on site_admin's authorized keys for more robustness
146
147 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
148 - fix issue in db-config that prevented correct operation
149
150 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
151 - remove support for chroot-based packaging - no crond nor syslog step anymore
152 - plc init script now named plc.init instead of former guest.init
153
154 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
155 - add Monitor to docs build
156
157 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
158 - plc_config.py and plc-config-tty: generalized to work for more diverse
159 - MyPLC configurations.
160 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
161 - deployments and increase the memory limits in php.ini
162 - plc.d/crond: add --full option to vacuumdb
163
164 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
165 - avoid generating ssl certificates for disabled services among www api boot
166
167 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
168 - cleaned up old entries in db-config
169 - mtail more robust
170
171 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
172 - php include path tweaked for plekit includes
173 - reviewed myplc (fka native) packaging dependencies
174 - renumbered 4.3
175
176 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
177 - rename myplc into myplc-chroot and myplc-native into myplc
178 - new settings (shortname & hrn_root) for local peer
179
180 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
181 - First iteration of new data model
182 - Bunch of various fixes
183
184 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
185 - Removed proper ops from planetflow slice.
186
187 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
188 - myplc-native requires myplc-docs
189 - fixed doc build by locating locally installed DTDs at build-time
190
191 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
192 - turn myplc-docs off for now
193
194 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
195 - figures in doc package
196
197 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
198 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
199 - chroot packaging does not have docs anymore
200 - 'cvs' and 'dev' not required from myplc-native anymore
201 - cosmetic change in kml output
202
203
204 %define module_current_branch 4.2