Tagging module MyPLC - MyPLC-4.3-8
[myplc.git] / myplc-docs.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-docs
7 %define version 4.3
8 %define taglevel 8
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) online documentation
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 BuildRequires: docbook-dtds, docbook-utils-pdf
28
29 %define debug_package %{nil}
30
31 %description
32 This package contains the online documentation for MyPLC, i.e. the
33 reference manuals for the two APIs provided: PLCAPI and NMAPI. A
34 more general introduction to the MyPLC system can be found at
35 http://svn.planet-lab.org/wiki/MyPLCUserGuide
36
37 %prep
38 %setup -q
39
40 %build
41 rm -rf $RPM_BUILD_ROOT
42
43 pushd PLCAPI
44 # beware that making the pdf file somehow overwrites the html
45 make -C doc PLCAPI.pdf 
46 rm -f doc/PLCAPI.html
47 make -C doc PLCAPI.html 
48 popd
49
50 pushd NodeManager
51 # beware that making the pdf file somehow overwrites the html
52 make -C doc NMAPI.pdf 
53 rm -f doc/NMAPI.html
54 make -C doc NMAPI.html 
55 popd
56
57 pushd Monitor
58 # beware that making the pdf file somehow overwrites the html
59 make -C docs Monitor.pdf 
60 rm -f docs/Monitor.html
61 make -C docs Monitor.html 
62 popd
63
64 %install
65
66 for ext in pdf html; do
67     install -D -m 444 PLCAPI/doc/PLCAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.$ext
68     install -D -m 444 NodeManager/doc/NMAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.$ext
69     install -D -m 444 Monitor/docs/Monitor.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.$ext
70 done
71
72 ./MyPLC/docbook2drupal.sh "PLC API Documentation (%{pldistro})" \
73     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.html \
74     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.php 
75 ./MyPLC/docbook2drupal.sh "Node Manager API Documentation (%{pldistro})" \
76     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.html \
77     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.php 
78 ./MyPLC/docbook2drupal.sh "Monitor API Documentation (%{pldistro})" \
79     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.html \
80     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.php 
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %files
86 %defattr(-,root,root,-)
87 /var/www/html/planetlab/doc/
88
89 %changelog
90 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
91 - remove support for chroot-based packaging - no crond nor syslog step anymore
92 - plc init script now named plc.init instead of former guest.init
93
94 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
95 - add Monitor to docs build
96
97 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
98 - plc_config.py and plc-config-tty: generalized to work for more diverse
99 - MyPLC configurations.
100 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
101 - deployments and increase the memory limits in php.ini
102 - plc.d/crond: add --full option to vacuumdb
103
104 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
105 - avoid generating ssl certificates for disabled services among www api boot
106
107 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
108 - cleaned up old entries in db-config
109 - mtail more robust
110
111 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
112 - php include path tweaked for plekit includes
113 - reviewed myplc (fka native) packaging dependencies
114 - renumbered 4.3
115
116 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
117 - rename myplc into myplc-chroot and myplc-native into myplc
118 - new settings (shortname & hrn_root) for local peer
119
120 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
121 - First iteration of new data model
122 - Bunch of various fixes
123
124 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
125 - Removed proper ops from planetflow slice.
126
127 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
128 - myplc-native requires myplc-docs
129 - fixed doc build by locating locally installed DTDs at build-time
130
131 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
132 - turn myplc-docs off for now
133
134 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
135 - figures in doc package
136
137 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
138 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
139 - chroot packaging does not have docs anymore
140 - 'cvs' and 'dev' not required from myplc-native anymore
141 - cosmetic change in kml output
142
143
144 %define module_current_branch 4.2