Setting tag myplc-5.0-10
[myplc.git] / myplc-docs.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-docs
7 %define version 5.0
8 %define taglevel 10
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) online documentation
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 BuildRequires: docbook-dtds, docbook-utils-pdf
28
29 %define debug_package %{nil}
30
31 %description
32 This package contains the online documentation for MyPLC, i.e. the
33 reference manuals for the two APIs provided: PLCAPI and NMAPI. A
34 more general introduction to the MyPLC system can be found at
35 http://svn.planet-lab.org/wiki/MyPLCUserGuide
36
37 %prep
38 %setup -q
39
40 %build
41 rm -rf $RPM_BUILD_ROOT
42
43 # using the new lowercase names, and handling legacy
44 [ -d plcapi ] || ln -s PLCAPI plcapi
45 [ -d monitor ] || ln -s Monitor monitor 
46 [ -d nodemanager ] || ln -s NodeManager nodemanager
47 [ -d myplc ] || ln -s MyPLC myplc
48
49 pushd plcapi
50 # beware that making the pdf file somehow overwrites the html
51 make -C doc PLCAPI.pdf 
52 rm -f doc/PLCAPI.html
53 make -C doc PLCAPI.html 
54 popd
55
56 pushd nodemanager
57 # beware that making the pdf file somehow overwrites the html
58 make -C doc NMAPI.pdf 
59 rm -f doc/NMAPI.html
60 make -C doc NMAPI.html 
61 popd
62
63 pushd monitor
64 # beware that making the pdf file somehow overwrites the html
65 make -C docs Monitor.pdf 
66 rm -f docs/Monitor.html
67 make -C docs Monitor.html 
68 popd
69
70 %install
71
72 for ext in pdf html; do
73     install -D -m 444 plcapi/doc/PLCAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.$ext
74     install -D -m 444 nodemanager/doc/NMAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.$ext
75     install -D -m 444 monitor/docs/Monitor.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.$ext
76 done
77
78 ./myplc/docbook2drupal.sh "PLC API Documentation (%{pldistro})" \
79     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.html \
80     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.php 
81 ./myplc/docbook2drupal.sh "Node Manager API Documentation (%{pldistro})" \
82     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.html \
83     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.php 
84 ./myplc/docbook2drupal.sh "Monitor API Documentation (%{pldistro})" \
85     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.html \
86     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.php 
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %files
92 %defattr(-,root,root,-)
93 /var/www/html/planetlab/doc/
94
95 %changelog
96 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
97 - mtail.py -s for SFA
98 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
99
100 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
101 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
102
103 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
104 - plc-config-tty now has a validator on booleans
105 - e.g. entering 'True' now is rejected rather than silently recording 'false'
106
107 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
108 - disable mod_wsgi
109
110 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
111 - module name changes
112 - start wsgi support
113
114 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
115 - new setting PLC_RESERVATION_GRANULARITY
116
117 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
118 - * partial-repo.sh script
119 - * preserve key along with certificates
120
121 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
122 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
123
124 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
125 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
126 - new OMF category in the config
127 - create the drl system slice
128
129 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
130 - first working version of 5.0:
131 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
132 - nodefamily is 3-fold with pldistro-fcdistro-arch
133 - new PLC_FLAVOUR config category
134 - reviewed module layout
135 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
136
137 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
138 - support for fedora 12
139 - new package myplc-config for use by sfa
140 - drupal user registration turned off
141
142 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
143 - - fix to make sure when API, BOOT, MONITOR are on the same
144 - machine as WWW that the SSL key,cert for WWW takes precedence.
145 - - Do proper setup for SSL CA certficate to be used as the server
146 - chain.
147
148 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
149 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
150
151 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
152 - depend on pcucontrol
153
154 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
155 - * validate input according to type in plc_config
156 - * added the _genicw system slice
157 - * add tag types for sites and persons
158 - * add new tags for nodes and slices for exemption from myops
159
160 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
161 - turn off drupal on a box that acts as BOOT server but not as WWW server
162 - cleanup some obsolete code for old chroot-jail packaging in the process
163 - new bootcd-kernel script for keeping bootcd variants up2date
164
165 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
166 - Make the /etc/hosts manipulation optional.
167
168 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
169 - Fix SetRole.
170
171 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
172 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
173 - into the DB.
174 - - Added the root ssh key handling support back into plc.d/ssh and the
175 - default xml file.  This should be identical to the way it was in
176 - rc12.
177 - - Added support in the db-config.d/01-init script to register the root
178 - ssh public key with the default administrator.  In this way the root
179 - ssh key will make it into the root account on the nodes by means of
180 - NodeManager's specialaccounts plugin.
181
182 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
183 - db-config ignores sliver tags
184 - sirius's db-config script renamed (was sirious)
185
186 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
187 - fix for silverauth - missing tag types now created at plc startup time
188
189 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
190 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
191
192 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
193 - companion to NM's specialaccounts plugin
194 - do not generate /etc/planetlab/root_ssh_key* anymore
195 - remove related config. variables and conf_files
196
197 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
198 - clarified description text to refer only to plcrt and not other optional
199 - packages.
200
201 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
202 - fixed a bug setting slice multiple attributes with the same tag name
203
204 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
205 - SSL setup for monitor box, and related new config variables
206 - new conf_file for /etc/planetlab/extensions
207 - various tweaks in db-config internals, about initscripts among others
208 - also more messages defined in the db
209
210 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
211 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
212
213 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
214 - bugfix in db-config, tag 4.3-19 would not fly
215
216 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
217 - Refactored db-config into snippets in db-config.d/.
218
219 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
220 - oops, tag 4.3-17 was broken and would not work
221
222 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
223 - bugfix - escape sequences inserted in xml configs
224
225 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
226 - Handle db-config.d files properly.
227
228 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
229 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
230 - than the log file
231 - - Fix db-config to be a bit more cautious when
232 - /etc/planetlab/db-config.d doesn't exist
233 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
234 - .orig files.
235 - - Refactor generic plc-config-tty code into plc_config.py.
236 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
237 - and the list of validated variables and the corresponding
238 - validator() function. This refactoring lets one reuse plc_config.py
239 - as a generic cmdline configuration tool for highly customer MyPLC
240 - like software.
241
242 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
243 - update PCU Type descriptions.
244 - updates to init scripts
245
246 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
247 - requires monitor-pcucontrol so register-wizard can work
248
249 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
250 - cleaned up plc-config-tty, no more need to configure plc-devel
251
252 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
253 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
254
255 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
256 - tighter right permissions on site_admin's authorized keys for more robustness
257
258 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
259 - fix issue in db-config that prevented correct operation
260
261 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
262 - remove support for chroot-based packaging - no crond nor syslog step anymore
263 - plc init script now named plc.init instead of former guest.init
264
265 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
266 - add Monitor to docs build
267
268 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
269 - plc_config.py and plc-config-tty: generalized to work for more diverse
270 - MyPLC configurations.
271 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
272 - deployments and increase the memory limits in php.ini
273 - plc.d/crond: add --full option to vacuumdb
274
275 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
276 - avoid generating ssl certificates for disabled services among www api boot
277
278 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
279 - cleaned up old entries in db-config
280 - mtail more robust
281
282 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
283 - php include path tweaked for plekit includes
284 - reviewed myplc (fka native) packaging dependencies
285 - renumbered 4.3
286
287 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
288 - rename myplc into myplc-chroot and myplc-native into myplc
289 - new settings (shortname & hrn_root) for local peer
290
291 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
292 - First iteration of new data model
293 - Bunch of various fixes
294
295 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
296 - Removed proper ops from planetflow slice.
297
298 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
299 - myplc-native requires myplc-docs
300 - fixed doc build by locating locally installed DTDs at build-time
301
302 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
303 - turn myplc-docs off for now
304
305 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
306 - figures in doc package
307
308 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
309 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
310 - chroot packaging does not have docs anymore
311 - 'cvs' and 'dev' not required from myplc-native anymore
312 - cosmetic change in kml output
313
314
315 %define module_current_branch 4.3