Setting tag MyPLC-4.3-36
[myplc.git] / myplc-docs.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-docs
7 %define version 4.3
8 %define taglevel 36
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) online documentation
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 BuildRequires: docbook-dtds, docbook-utils-pdf
28
29 %define debug_package %{nil}
30
31 %description
32 This package contains the online documentation for MyPLC, i.e. the
33 reference manuals for the two APIs provided: PLCAPI and NMAPI. A
34 more general introduction to the MyPLC system can be found at
35 http://svn.planet-lab.org/wiki/MyPLCUserGuide
36
37 %prep
38 %setup -q
39
40 %build
41 rm -rf $RPM_BUILD_ROOT
42
43 pushd PLCAPI
44 # beware that making the pdf file somehow overwrites the html
45 make -C doc PLCAPI.pdf 
46 rm -f doc/PLCAPI.html
47 make -C doc PLCAPI.html 
48 popd
49
50 pushd NodeManager
51 # beware that making the pdf file somehow overwrites the html
52 make -C doc NMAPI.pdf 
53 rm -f doc/NMAPI.html
54 make -C doc NMAPI.html 
55 popd
56
57 pushd Monitor
58 # beware that making the pdf file somehow overwrites the html
59 make -C docs Monitor.pdf 
60 rm -f docs/Monitor.html
61 make -C docs Monitor.html 
62 popd
63
64 %install
65
66 for ext in pdf html; do
67     install -D -m 444 PLCAPI/doc/PLCAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.$ext
68     install -D -m 444 NodeManager/doc/NMAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.$ext
69     install -D -m 444 Monitor/docs/Monitor.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.$ext
70 done
71
72 ./MyPLC/docbook2drupal.sh "PLC API Documentation (%{pldistro})" \
73     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.html \
74     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.php 
75 ./MyPLC/docbook2drupal.sh "Node Manager API Documentation (%{pldistro})" \
76     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.html \
77     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.php 
78 ./MyPLC/docbook2drupal.sh "Monitor API Documentation (%{pldistro})" \
79     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.html \
80     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.php 
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %files
86 %defattr(-,root,root,-)
87 /var/www/html/planetlab/doc/
88
89 %changelog
90 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
91 - - fix to make sure when API, BOOT, MONITOR are on the same
92 - machine as WWW that the SSL key,cert for WWW takes precedence.
93 - - Do proper setup for SSL CA certficate to be used as the server
94 - chain.
95
96 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
97 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
98
99 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
100 - depend on pcucontrol
101
102 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
103 - * validate input according to type in plc_config
104 - * added the _genicw system slice
105 - * add tag types for sites and persons
106 - * add new tags for nodes and slices for exemption from myops
107
108 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
109 - turn off drupal on a box that acts as BOOT server but not as WWW server
110 - cleanup some obsolete code for old chroot-jail packaging in the process
111 - new bootcd-kernel script for keeping bootcd variants up2date
112
113 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
114 - Make the /etc/hosts manipulation optional.
115
116 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
117 - Fix SetRole.
118
119 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
120 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
121 - into the DB.
122 - - Added the root ssh key handling support back into plc.d/ssh and the
123 - default xml file.  This should be identical to the way it was in
124 - rc12.
125 - - Added support in the db-config.d/01-init script to register the root
126 - ssh public key with the default administrator.  In this way the root
127 - ssh key will make it into the root account on the nodes by means of
128 - NodeManager's specialaccounts plugin.
129
130 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
131 - db-config ignores sliver tags
132 - sirius's db-config script renamed (was sirious)
133
134 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
135 - fix for silverauth - missing tag types now created at plc startup time
136
137 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
138 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
139
140 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
141 - companion to NM's specialaccounts plugin
142 - do not generate /etc/planetlab/root_ssh_key* anymore
143 - remove related config. variables and conf_files
144
145 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
146 - clarified description text to refer only to plcrt and not other optional
147 - packages.
148
149 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
150 - fixed a bug setting slice multiple attributes with the same tag name
151
152 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
153 - SSL setup for monitor box, and related new config variables
154 - new conf_file for /etc/planetlab/extensions
155 - various tweaks in db-config internals, about initscripts among others
156 - also more messages defined in the db
157
158 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
159 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
160
161 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
162 - bugfix in db-config, tag 4.3-19 would not fly
163
164 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
165 - Refactored db-config into snippets in db-config.d/.
166
167 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
168 - oops, tag 4.3-17 was broken and would not work
169
170 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
171 - bugfix - escape sequences inserted in xml configs
172
173 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
174 - Handle db-config.d files properly.
175
176 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
177 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
178 - than the log file
179 - - Fix db-config to be a bit more cautious when
180 - /etc/planetlab/db-config.d doesn't exist
181 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
182 - .orig files.
183 - - Refactor generic plc-config-tty code into plc_config.py.
184 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
185 - and the list of validated variables and the corresponding
186 - validator() function. This refactoring lets one reuse plc_config.py
187 - as a generic cmdline configuration tool for highly customer MyPLC
188 - like software.
189
190 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
191 - update PCU Type descriptions.
192 - updates to init scripts
193
194 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
195 - requires monitor-pcucontrol so register-wizard can work
196
197 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
198 - cleaned up plc-config-tty, no more need to configure plc-devel
199
200 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
201 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
202
203 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
204 - tighter right permissions on site_admin's authorized keys for more robustness
205
206 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
207 - fix issue in db-config that prevented correct operation
208
209 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
210 - remove support for chroot-based packaging - no crond nor syslog step anymore
211 - plc init script now named plc.init instead of former guest.init
212
213 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
214 - add Monitor to docs build
215
216 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
217 - plc_config.py and plc-config-tty: generalized to work for more diverse
218 - MyPLC configurations.
219 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
220 - deployments and increase the memory limits in php.ini
221 - plc.d/crond: add --full option to vacuumdb
222
223 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
224 - avoid generating ssl certificates for disabled services among www api boot
225
226 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
227 - cleaned up old entries in db-config
228 - mtail more robust
229
230 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
231 - php include path tweaked for plekit includes
232 - reviewed myplc (fka native) packaging dependencies
233 - renumbered 4.3
234
235 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
236 - rename myplc into myplc-chroot and myplc-native into myplc
237 - new settings (shortname & hrn_root) for local peer
238
239 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
240 - First iteration of new data model
241 - Bunch of various fixes
242
243 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
244 - Removed proper ops from planetflow slice.
245
246 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
247 - myplc-native requires myplc-docs
248 - fixed doc build by locating locally installed DTDs at build-time
249
250 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
251 - turn myplc-docs off for now
252
253 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
254 - figures in doc package
255
256 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
257 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
258 - chroot packaging does not have docs anymore
259 - 'cvs' and 'dev' not required from myplc-native anymore
260 - cosmetic change in kml output
261
262
263 %define module_current_branch 4.2