fixing taglevel for new package
[myplc.git] / myplc-docs.spec
1 #
2 # $Id: myplc-native.spec 9260 2008-05-07 16:20:25Z thierry $
3 #
4 %define url $URL: svn+ssh://thierry@svn.planet-lab.org/svn/MyPLC/trunk/myplc-native.spec $
5
6 %define name myplc-docs
7 %define version 4.2
8 %define taglevel 10
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) online documentation
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 BuildRequires: docbook-dtds, docbook-utils-pdf
28
29 %define debug_package %{nil}
30
31 %description 
32 This package contains the online documentation for MyPLC. This covers
33 the overall system itself, together with the reference manuals for the
34 two APIs provided, namely PLCAPI and NMAPI.
35
36 %prep
37 %setup -q
38
39 %build
40 rm -rf $RPM_BUILD_ROOT
41
42 pushd MyPLC
43 # beware that making the pdf file somehow overwrites the html
44 make -C doc myplc.pdf 
45 rm -f doc/myplc.html
46 make -C doc myplc.html 
47 popd
48
49 pushd PLCAPI
50 # beware that making the pdf file somehow overwrites the html
51 make -C doc PLCAPI.pdf 
52 rm -f doc/PLCAPI.html
53 make -C doc PLCAPI.html 
54 popd
55
56 pushd NodeManager
57 # beware that making the pdf file somehow overwrites the html
58 make -C doc NMAPI.pdf 
59 rm -f doc/NMAPI.html
60 make -C doc NMAPI.html 
61 popd
62
63 %install
64
65 for ext in pdf html; do
66     install -D -m 444 MyPLC/doc/myplc.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/myplc.$ext
67     install -D -m 444 PLCAPI/doc/PLCAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.$ext
68     install -D -m 444 NodeManager/doc/NMAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.$ext
69 done
70
71 ./MyPLC/doc/docbook2drupal.sh "MyPLC Documentation (%{pldistro})" \
72     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/myplc.html \
73     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/myplc.php 
74 ./MyPLC/doc/docbook2drupal.sh "PLC API Documentation (%{pldistro})" \
75     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.html \
76     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.php 
77 ./MyPLC/doc/docbook2drupal.sh "Node Manager API Documentation (%{pldistro})" \
78     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.html \
79     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.php 
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %files
85 %defattr(-,root,root,-)
86 /var/www/html/planetlab/doc/
87
88 %changelog