Setting tag MyPLC-5.0-6
[myplc.git] / myplc-docs.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-docs
7 %define version 5.0
8 %define taglevel 6
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) online documentation
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 BuildRequires: docbook-dtds, docbook-utils-pdf
28
29 %define debug_package %{nil}
30
31 %description
32 This package contains the online documentation for MyPLC, i.e. the
33 reference manuals for the two APIs provided: PLCAPI and NMAPI. A
34 more general introduction to the MyPLC system can be found at
35 http://svn.planet-lab.org/wiki/MyPLCUserGuide
36
37 %prep
38 %setup -q
39
40 %build
41 rm -rf $RPM_BUILD_ROOT
42
43 # using the new lowercase names, and handling legacy
44 [ -d plcapi ] || ln -s PLCAPI plcapi
45 [ -d monitor ] || ln -s Monitor monitor 
46 [ -d nodemanager ] || ln -s NodeManager nodemanager
47 [ -d myplc ] || ln -s MyPLC myplc
48
49 pushd plcapi
50 # beware that making the pdf file somehow overwrites the html
51 make -C doc PLCAPI.pdf 
52 rm -f doc/PLCAPI.html
53 make -C doc PLCAPI.html 
54 popd
55
56 pushd nodemanager
57 # beware that making the pdf file somehow overwrites the html
58 make -C doc NMAPI.pdf 
59 rm -f doc/NMAPI.html
60 make -C doc NMAPI.html 
61 popd
62
63 pushd monitor
64 # beware that making the pdf file somehow overwrites the html
65 make -C docs Monitor.pdf 
66 rm -f docs/Monitor.html
67 make -C docs Monitor.html 
68 popd
69
70 %install
71
72 for ext in pdf html; do
73     install -D -m 444 plcapi/doc/PLCAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.$ext
74     install -D -m 444 nodemanager/doc/NMAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.$ext
75     install -D -m 444 monitor/docs/Monitor.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.$ext
76 done
77
78 ./myplc/docbook2drupal.sh "PLC API Documentation (%{pldistro})" \
79     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.html \
80     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.php 
81 ./myplc/docbook2drupal.sh "Node Manager API Documentation (%{pldistro})" \
82     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.html \
83     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.php 
84 ./myplc/docbook2drupal.sh "Monitor API Documentation (%{pldistro})" \
85     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.html \
86     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.php 
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %files
92 %defattr(-,root,root,-)
93 /var/www/html/planetlab/doc/
94
95 %changelog
96 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
97 - module name changes
98 - start wsgi support
99
100 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
101 - new setting PLC_RESERVATION_GRANULARITY
102
103 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
104 - * partial-repo.sh script
105 - * preserve key along with certificates
106
107 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
108 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
109
110 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
111 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
112 - new OMF category in the config
113 - create the drl system slice
114
115 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
116 - first working version of 5.0:
117 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
118 - nodefamily is 3-fold with pldistro-fcdistro-arch
119 - new PLC_FLAVOUR config category
120 - reviewed module layout
121 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
122
123 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
124 - support for fedora 12
125 - new package myplc-config for use by sfa
126 - drupal user registration turned off
127
128 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
129 - - fix to make sure when API, BOOT, MONITOR are on the same
130 - machine as WWW that the SSL key,cert for WWW takes precedence.
131 - - Do proper setup for SSL CA certficate to be used as the server
132 - chain.
133
134 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
135 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
136
137 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
138 - depend on pcucontrol
139
140 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
141 - * validate input according to type in plc_config
142 - * added the _genicw system slice
143 - * add tag types for sites and persons
144 - * add new tags for nodes and slices for exemption from myops
145
146 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
147 - turn off drupal on a box that acts as BOOT server but not as WWW server
148 - cleanup some obsolete code for old chroot-jail packaging in the process
149 - new bootcd-kernel script for keeping bootcd variants up2date
150
151 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
152 - Make the /etc/hosts manipulation optional.
153
154 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
155 - Fix SetRole.
156
157 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
158 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
159 - into the DB.
160 - - Added the root ssh key handling support back into plc.d/ssh and the
161 - default xml file.  This should be identical to the way it was in
162 - rc12.
163 - - Added support in the db-config.d/01-init script to register the root
164 - ssh public key with the default administrator.  In this way the root
165 - ssh key will make it into the root account on the nodes by means of
166 - NodeManager's specialaccounts plugin.
167
168 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
169 - db-config ignores sliver tags
170 - sirius's db-config script renamed (was sirious)
171
172 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
173 - fix for silverauth - missing tag types now created at plc startup time
174
175 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
176 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
177
178 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
179 - companion to NM's specialaccounts plugin
180 - do not generate /etc/planetlab/root_ssh_key* anymore
181 - remove related config. variables and conf_files
182
183 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
184 - clarified description text to refer only to plcrt and not other optional
185 - packages.
186
187 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
188 - fixed a bug setting slice multiple attributes with the same tag name
189
190 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
191 - SSL setup for monitor box, and related new config variables
192 - new conf_file for /etc/planetlab/extensions
193 - various tweaks in db-config internals, about initscripts among others
194 - also more messages defined in the db
195
196 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
197 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
198
199 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
200 - bugfix in db-config, tag 4.3-19 would not fly
201
202 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
203 - Refactored db-config into snippets in db-config.d/.
204
205 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
206 - oops, tag 4.3-17 was broken and would not work
207
208 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
209 - bugfix - escape sequences inserted in xml configs
210
211 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
212 - Handle db-config.d files properly.
213
214 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
215 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
216 - than the log file
217 - - Fix db-config to be a bit more cautious when
218 - /etc/planetlab/db-config.d doesn't exist
219 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
220 - .orig files.
221 - - Refactor generic plc-config-tty code into plc_config.py.
222 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
223 - and the list of validated variables and the corresponding
224 - validator() function. This refactoring lets one reuse plc_config.py
225 - as a generic cmdline configuration tool for highly customer MyPLC
226 - like software.
227
228 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
229 - update PCU Type descriptions.
230 - updates to init scripts
231
232 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
233 - requires monitor-pcucontrol so register-wizard can work
234
235 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
236 - cleaned up plc-config-tty, no more need to configure plc-devel
237
238 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
239 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
240
241 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
242 - tighter right permissions on site_admin's authorized keys for more robustness
243
244 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
245 - fix issue in db-config that prevented correct operation
246
247 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
248 - remove support for chroot-based packaging - no crond nor syslog step anymore
249 - plc init script now named plc.init instead of former guest.init
250
251 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
252 - add Monitor to docs build
253
254 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
255 - plc_config.py and plc-config-tty: generalized to work for more diverse
256 - MyPLC configurations.
257 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
258 - deployments and increase the memory limits in php.ini
259 - plc.d/crond: add --full option to vacuumdb
260
261 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
262 - avoid generating ssl certificates for disabled services among www api boot
263
264 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
265 - cleaned up old entries in db-config
266 - mtail more robust
267
268 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
269 - php include path tweaked for plekit includes
270 - reviewed myplc (fka native) packaging dependencies
271 - renumbered 4.3
272
273 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
274 - rename myplc into myplc-chroot and myplc-native into myplc
275 - new settings (shortname & hrn_root) for local peer
276
277 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
278 - First iteration of new data model
279 - Bunch of various fixes
280
281 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
282 - Removed proper ops from planetflow slice.
283
284 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
285 - myplc-native requires myplc-docs
286 - fixed doc build by locating locally installed DTDs at build-time
287
288 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
289 - turn myplc-docs off for now
290
291 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
292 - figures in doc package
293
294 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
295 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
296 - chroot packaging does not have docs anymore
297 - 'cvs' and 'dev' not required from myplc-native anymore
298 - cosmetic change in kml output
299
300
301 %define module_current_branch 4.3