resistant to module names being lowercased
[myplc.git] / myplc-docs.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-docs
7 %define version 5.0
8 %define taglevel 5
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) online documentation
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 BuildRequires: docbook-dtds, docbook-utils-pdf
28
29 %define debug_package %{nil}
30
31 %description
32 This package contains the online documentation for MyPLC, i.e. the
33 reference manuals for the two APIs provided: PLCAPI and NMAPI. A
34 more general introduction to the MyPLC system can be found at
35 http://svn.planet-lab.org/wiki/MyPLCUserGuide
36
37 %prep
38 %setup -q
39
40 %build
41 rm -rf $RPM_BUILD_ROOT
42
43 if [ -d PLCAPI ] ; then pushd PLCAPI ; else pushd plcapi; fi
44 # beware that making the pdf file somehow overwrites the html
45 make -C doc PLCAPI.pdf 
46 rm -f doc/PLCAPI.html
47 make -C doc PLCAPI.html 
48 popd
49
50 if [ -d NodeManager ] ; then pushd NodeManager; else pushd nodemanager ; fi
51 # beware that making the pdf file somehow overwrites the html
52 make -C doc NMAPI.pdf 
53 rm -f doc/NMAPI.html
54 make -C doc NMAPI.html 
55 popd
56
57 if [ -d Monitor ] ; then pushd Monitor; else pushd monitor; fi
58 # beware that making the pdf file somehow overwrites the html
59 make -C docs Monitor.pdf 
60 rm -f docs/Monitor.html
61 make -C docs Monitor.html 
62 popd
63
64 %install
65
66 for ext in pdf html; do
67     install -D -m 444 PLCAPI/doc/PLCAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.$ext
68     install -D -m 444 NodeManager/doc/NMAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.$ext
69     install -D -m 444 Monitor/docs/Monitor.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.$ext
70 done
71
72 ./MyPLC/docbook2drupal.sh "PLC API Documentation (%{pldistro})" \
73     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.html \
74     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.php 
75 ./MyPLC/docbook2drupal.sh "Node Manager API Documentation (%{pldistro})" \
76     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.html \
77     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.php 
78 ./MyPLC/docbook2drupal.sh "Monitor API Documentation (%{pldistro})" \
79     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.html \
80     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.php 
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %files
86 %defattr(-,root,root,-)
87 /var/www/html/planetlab/doc/
88
89 %changelog
90 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
91 - new setting PLC_RESERVATION_GRANULARITY
92
93 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
94 - * partial-repo.sh script
95 - * preserve key along with certificates
96
97 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
98 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
99
100 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
101 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
102 - new OMF category in the config
103 - create the drl system slice
104
105 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
106 - first working version of 5.0:
107 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
108 - nodefamily is 3-fold with pldistro-fcdistro-arch
109 - new PLC_FLAVOUR config category
110 - reviewed module layout
111 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
112
113 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
114 - support for fedora 12
115 - new package myplc-config for use by sfa
116 - drupal user registration turned off
117
118 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
119 - - fix to make sure when API, BOOT, MONITOR are on the same
120 - machine as WWW that the SSL key,cert for WWW takes precedence.
121 - - Do proper setup for SSL CA certficate to be used as the server
122 - chain.
123
124 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
125 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
126
127 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
128 - depend on pcucontrol
129
130 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
131 - * validate input according to type in plc_config
132 - * added the _genicw system slice
133 - * add tag types for sites and persons
134 - * add new tags for nodes and slices for exemption from myops
135
136 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
137 - turn off drupal on a box that acts as BOOT server but not as WWW server
138 - cleanup some obsolete code for old chroot-jail packaging in the process
139 - new bootcd-kernel script for keeping bootcd variants up2date
140
141 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
142 - Make the /etc/hosts manipulation optional.
143
144 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
145 - Fix SetRole.
146
147 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
148 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
149 - into the DB.
150 - - Added the root ssh key handling support back into plc.d/ssh and the
151 - default xml file.  This should be identical to the way it was in
152 - rc12.
153 - - Added support in the db-config.d/01-init script to register the root
154 - ssh public key with the default administrator.  In this way the root
155 - ssh key will make it into the root account on the nodes by means of
156 - NodeManager's specialaccounts plugin.
157
158 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
159 - db-config ignores sliver tags
160 - sirius's db-config script renamed (was sirious)
161
162 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
163 - fix for silverauth - missing tag types now created at plc startup time
164
165 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
166 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
167
168 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
169 - companion to NM's specialaccounts plugin
170 - do not generate /etc/planetlab/root_ssh_key* anymore
171 - remove related config. variables and conf_files
172
173 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
174 - clarified description text to refer only to plcrt and not other optional
175 - packages.
176
177 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
178 - fixed a bug setting slice multiple attributes with the same tag name
179
180 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
181 - SSL setup for monitor box, and related new config variables
182 - new conf_file for /etc/planetlab/extensions
183 - various tweaks in db-config internals, about initscripts among others
184 - also more messages defined in the db
185
186 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
187 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
188
189 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
190 - bugfix in db-config, tag 4.3-19 would not fly
191
192 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
193 - Refactored db-config into snippets in db-config.d/.
194
195 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
196 - oops, tag 4.3-17 was broken and would not work
197
198 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
199 - bugfix - escape sequences inserted in xml configs
200
201 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
202 - Handle db-config.d files properly.
203
204 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
205 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
206 - than the log file
207 - - Fix db-config to be a bit more cautious when
208 - /etc/planetlab/db-config.d doesn't exist
209 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
210 - .orig files.
211 - - Refactor generic plc-config-tty code into plc_config.py.
212 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
213 - and the list of validated variables and the corresponding
214 - validator() function. This refactoring lets one reuse plc_config.py
215 - as a generic cmdline configuration tool for highly customer MyPLC
216 - like software.
217
218 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
219 - update PCU Type descriptions.
220 - updates to init scripts
221
222 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
223 - requires monitor-pcucontrol so register-wizard can work
224
225 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
226 - cleaned up plc-config-tty, no more need to configure plc-devel
227
228 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
229 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
230
231 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
232 - tighter right permissions on site_admin's authorized keys for more robustness
233
234 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
235 - fix issue in db-config that prevented correct operation
236
237 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
238 - remove support for chroot-based packaging - no crond nor syslog step anymore
239 - plc init script now named plc.init instead of former guest.init
240
241 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
242 - add Monitor to docs build
243
244 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
245 - plc_config.py and plc-config-tty: generalized to work for more diverse
246 - MyPLC configurations.
247 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
248 - deployments and increase the memory limits in php.ini
249 - plc.d/crond: add --full option to vacuumdb
250
251 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
252 - avoid generating ssl certificates for disabled services among www api boot
253
254 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
255 - cleaned up old entries in db-config
256 - mtail more robust
257
258 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
259 - php include path tweaked for plekit includes
260 - reviewed myplc (fka native) packaging dependencies
261 - renumbered 4.3
262
263 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
264 - rename myplc into myplc-chroot and myplc-native into myplc
265 - new settings (shortname & hrn_root) for local peer
266
267 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
268 - First iteration of new data model
269 - Bunch of various fixes
270
271 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
272 - Removed proper ops from planetflow slice.
273
274 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
275 - myplc-native requires myplc-docs
276 - fixed doc build by locating locally installed DTDs at build-time
277
278 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
279 - turn myplc-docs off for now
280
281 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
282 - figures in doc package
283
284 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
285 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
286 - chroot packaging does not have docs anymore
287 - 'cvs' and 'dev' not required from myplc-native anymore
288 - cosmetic change in kml output
289
290
291 %define module_current_branch 4.3