Setting tag myplc-5.0-8
[myplc.git] / myplc-docs.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-docs
7 %define version 5.0
8 %define taglevel 8
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) online documentation
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 BuildRequires: docbook-dtds, docbook-utils-pdf
28
29 %define debug_package %{nil}
30
31 %description
32 This package contains the online documentation for MyPLC, i.e. the
33 reference manuals for the two APIs provided: PLCAPI and NMAPI. A
34 more general introduction to the MyPLC system can be found at
35 http://svn.planet-lab.org/wiki/MyPLCUserGuide
36
37 %prep
38 %setup -q
39
40 %build
41 rm -rf $RPM_BUILD_ROOT
42
43 # using the new lowercase names, and handling legacy
44 [ -d plcapi ] || ln -s PLCAPI plcapi
45 [ -d monitor ] || ln -s Monitor monitor 
46 [ -d nodemanager ] || ln -s NodeManager nodemanager
47 [ -d myplc ] || ln -s MyPLC myplc
48
49 pushd plcapi
50 # beware that making the pdf file somehow overwrites the html
51 make -C doc PLCAPI.pdf 
52 rm -f doc/PLCAPI.html
53 make -C doc PLCAPI.html 
54 popd
55
56 pushd nodemanager
57 # beware that making the pdf file somehow overwrites the html
58 make -C doc NMAPI.pdf 
59 rm -f doc/NMAPI.html
60 make -C doc NMAPI.html 
61 popd
62
63 pushd monitor
64 # beware that making the pdf file somehow overwrites the html
65 make -C docs Monitor.pdf 
66 rm -f docs/Monitor.html
67 make -C docs Monitor.html 
68 popd
69
70 %install
71
72 for ext in pdf html; do
73     install -D -m 444 plcapi/doc/PLCAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.$ext
74     install -D -m 444 nodemanager/doc/NMAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.$ext
75     install -D -m 444 monitor/docs/Monitor.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.$ext
76 done
77
78 ./myplc/docbook2drupal.sh "PLC API Documentation (%{pldistro})" \
79     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.html \
80     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.php 
81 ./myplc/docbook2drupal.sh "Node Manager API Documentation (%{pldistro})" \
82     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.html \
83     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.php 
84 ./myplc/docbook2drupal.sh "Monitor API Documentation (%{pldistro})" \
85     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.html \
86     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.php 
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %files
92 %defattr(-,root,root,-)
93 /var/www/html/planetlab/doc/
94
95 %changelog
96 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
97 - plc-config-tty now has a validator on booleans
98 - e.g. entering 'True' now is rejected rather than silently recording 'false'
99
100 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
101 - disable mod_wsgi
102
103 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
104 - module name changes
105 - start wsgi support
106
107 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
108 - new setting PLC_RESERVATION_GRANULARITY
109
110 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
111 - * partial-repo.sh script
112 - * preserve key along with certificates
113
114 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
115 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
116
117 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
118 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
119 - new OMF category in the config
120 - create the drl system slice
121
122 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
123 - first working version of 5.0:
124 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
125 - nodefamily is 3-fold with pldistro-fcdistro-arch
126 - new PLC_FLAVOUR config category
127 - reviewed module layout
128 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
129
130 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
131 - support for fedora 12
132 - new package myplc-config for use by sfa
133 - drupal user registration turned off
134
135 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
136 - - fix to make sure when API, BOOT, MONITOR are on the same
137 - machine as WWW that the SSL key,cert for WWW takes precedence.
138 - - Do proper setup for SSL CA certficate to be used as the server
139 - chain.
140
141 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
142 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
143
144 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
145 - depend on pcucontrol
146
147 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
148 - * validate input according to type in plc_config
149 - * added the _genicw system slice
150 - * add tag types for sites and persons
151 - * add new tags for nodes and slices for exemption from myops
152
153 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
154 - turn off drupal on a box that acts as BOOT server but not as WWW server
155 - cleanup some obsolete code for old chroot-jail packaging in the process
156 - new bootcd-kernel script for keeping bootcd variants up2date
157
158 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
159 - Make the /etc/hosts manipulation optional.
160
161 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
162 - Fix SetRole.
163
164 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
165 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
166 - into the DB.
167 - - Added the root ssh key handling support back into plc.d/ssh and the
168 - default xml file.  This should be identical to the way it was in
169 - rc12.
170 - - Added support in the db-config.d/01-init script to register the root
171 - ssh public key with the default administrator.  In this way the root
172 - ssh key will make it into the root account on the nodes by means of
173 - NodeManager's specialaccounts plugin.
174
175 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
176 - db-config ignores sliver tags
177 - sirius's db-config script renamed (was sirious)
178
179 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
180 - fix for silverauth - missing tag types now created at plc startup time
181
182 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
183 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
184
185 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
186 - companion to NM's specialaccounts plugin
187 - do not generate /etc/planetlab/root_ssh_key* anymore
188 - remove related config. variables and conf_files
189
190 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
191 - clarified description text to refer only to plcrt and not other optional
192 - packages.
193
194 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
195 - fixed a bug setting slice multiple attributes with the same tag name
196
197 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
198 - SSL setup for monitor box, and related new config variables
199 - new conf_file for /etc/planetlab/extensions
200 - various tweaks in db-config internals, about initscripts among others
201 - also more messages defined in the db
202
203 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
204 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
205
206 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
207 - bugfix in db-config, tag 4.3-19 would not fly
208
209 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
210 - Refactored db-config into snippets in db-config.d/.
211
212 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
213 - oops, tag 4.3-17 was broken and would not work
214
215 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
216 - bugfix - escape sequences inserted in xml configs
217
218 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
219 - Handle db-config.d files properly.
220
221 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
222 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
223 - than the log file
224 - - Fix db-config to be a bit more cautious when
225 - /etc/planetlab/db-config.d doesn't exist
226 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
227 - .orig files.
228 - - Refactor generic plc-config-tty code into plc_config.py.
229 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
230 - and the list of validated variables and the corresponding
231 - validator() function. This refactoring lets one reuse plc_config.py
232 - as a generic cmdline configuration tool for highly customer MyPLC
233 - like software.
234
235 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
236 - update PCU Type descriptions.
237 - updates to init scripts
238
239 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
240 - requires monitor-pcucontrol so register-wizard can work
241
242 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
243 - cleaned up plc-config-tty, no more need to configure plc-devel
244
245 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
246 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
247
248 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
249 - tighter right permissions on site_admin's authorized keys for more robustness
250
251 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
252 - fix issue in db-config that prevented correct operation
253
254 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
255 - remove support for chroot-based packaging - no crond nor syslog step anymore
256 - plc init script now named plc.init instead of former guest.init
257
258 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
259 - add Monitor to docs build
260
261 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
262 - plc_config.py and plc-config-tty: generalized to work for more diverse
263 - MyPLC configurations.
264 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
265 - deployments and increase the memory limits in php.ini
266 - plc.d/crond: add --full option to vacuumdb
267
268 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
269 - avoid generating ssl certificates for disabled services among www api boot
270
271 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
272 - cleaned up old entries in db-config
273 - mtail more robust
274
275 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
276 - php include path tweaked for plekit includes
277 - reviewed myplc (fka native) packaging dependencies
278 - renumbered 4.3
279
280 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
281 - rename myplc into myplc-chroot and myplc-native into myplc
282 - new settings (shortname & hrn_root) for local peer
283
284 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
285 - First iteration of new data model
286 - Bunch of various fixes
287
288 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
289 - Removed proper ops from planetflow slice.
290
291 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
292 - myplc-native requires myplc-docs
293 - fixed doc build by locating locally installed DTDs at build-time
294
295 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
296 - turn myplc-docs off for now
297
298 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
299 - figures in doc package
300
301 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
302 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
303 - chroot packaging does not have docs anymore
304 - 'cvs' and 'dev' not required from myplc-native anymore
305 - cosmetic change in kml output
306
307
308 %define module_current_branch 4.3