Merge commit 'origin/master'
[myplc.git] / myplc-docs.spec
1 %define name myplc-docs
2 %define version 5.0
3 %define taglevel 16
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central (PLC) online documentation
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: Applications/Systems
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15 BuildArch: noarch
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21
22 BuildRequires: docbook-dtds, docbook-utils-pdf
23
24 %define debug_package %{nil}
25
26 %description
27 This package contains the online documentation for MyPLC, i.e. the
28 reference manuals for the two APIs provided: PLCAPI and NMAPI. A
29 more general introduction to the MyPLC system can be found at
30 http://svn.planet-lab.org/wiki/MyPLCUserGuide
31
32 %prep
33 %setup -q
34
35 %build
36 rm -rf $RPM_BUILD_ROOT
37
38 # using the new lowercase names, and handling legacy
39 [ -d myplc ] || ln -s MyPLC myplc
40 [ -d plcapi ] || ln -s PLCAPI plcapi
41 [ -d nodemanager ] || ln -s NodeManager nodemanager
42 [ -d monitor ] || ln -s Monitor monitor 
43
44 pushd plcapi
45 # beware that making the pdf file somehow overwrites the html
46 make -C doc PLCAPI.pdf 
47 rm -f doc/PLCAPI.html
48 make -C doc PLCAPI.html 
49 popd
50
51 pushd nodemanager
52 # beware that making the pdf file somehow overwrites the html
53 make -C doc NMAPI.pdf 
54 rm -f doc/NMAPI.html
55 make -C doc NMAPI.html 
56 popd
57
58 # not everyone rebuilds monitor, so make it optional
59 if [ -d monitor ] ; then
60 pushd monitor
61 # beware that making the pdf file somehow overwrites the html
62 make -C docs Monitor.pdf 
63 rm -f docs/Monitor.html
64 make -C docs Monitor.html 
65 popd
66 fi
67
68 %install
69
70 for ext in pdf html; do
71     install -D -m 444 plcapi/doc/PLCAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.$ext
72     install -D -m 444 nodemanager/doc/NMAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.$ext
73     if [ -d monitor ] ; then
74     install -D -m 444 monitor/docs/Monitor.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.$ext
75     fi
76 done
77
78 ./myplc/docbook2drupal.sh "PLC API Documentation (%{pldistro})" \
79     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.html \
80     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.php 
81 ./myplc/docbook2drupal.sh "Node Manager API Documentation (%{pldistro})" \
82     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.html \
83     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.php 
84 if [ -d monitor ] ; then
85 ./myplc/docbook2drupal.sh "Monitor API Documentation (%{pldistro})" \
86     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.html \
87     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.php 
88 fi
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %files
94 %defattr(-,root,root,-)
95 /var/www/html/planetlab/doc/
96
97 %changelog
98 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-16
99 - requires ed for the plc.d/packages step
100 - new initscript_body slice tag
101 - sirius initscript to handle stop and restart
102
103 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-15
104 - ignore steps in db-config.d if they have a '.' or '~' in their name
105
106 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-14
107 - can redo myplc-docs without the doc for monitor
108
109 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-13
110 - no semantic change - just fixed specfile for git URL
111
112 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
113 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
114
115 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
116 - add missing files to rpm package
117
118 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
119 - mtail.py -s for SFA
120 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
121
122 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
123 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
124
125 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
126 - plc-config-tty now has a validator on booleans
127 - e.g. entering 'True' now is rejected rather than silently recording 'false'
128
129 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
130 - disable mod_wsgi
131
132 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
133 - module name changes
134 - start wsgi support
135
136 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
137 - new setting PLC_RESERVATION_GRANULARITY
138
139 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
140 - * partial-repo.sh script
141 - * preserve key along with certificates
142
143 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
144 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
145
146 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
147 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
148 - new OMF category in the config
149 - create the drl system slice
150
151 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
152 - first working version of 5.0:
153 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
154 - nodefamily is 3-fold with pldistro-fcdistro-arch
155 - new PLC_FLAVOUR config category
156 - reviewed module layout
157 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
158
159 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
160 - support for fedora 12
161 - new package myplc-config for use by sfa
162 - drupal user registration turned off
163
164 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
165 - - fix to make sure when API, BOOT, MONITOR are on the same
166 - machine as WWW that the SSL key,cert for WWW takes precedence.
167 - - Do proper setup for SSL CA certficate to be used as the server
168 - chain.
169
170 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
171 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
172
173 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
174 - depend on pcucontrol
175
176 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
177 - * validate input according to type in plc_config
178 - * added the _genicw system slice
179 - * add tag types for sites and persons
180 - * add new tags for nodes and slices for exemption from myops
181
182 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
183 - turn off drupal on a box that acts as BOOT server but not as WWW server
184 - cleanup some obsolete code for old chroot-jail packaging in the process
185 - new bootcd-kernel script for keeping bootcd variants up2date
186
187 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
188 - Make the /etc/hosts manipulation optional.
189
190 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
191 - Fix SetRole.
192
193 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
194 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
195 - into the DB.
196 - - Added the root ssh key handling support back into plc.d/ssh and the
197 - default xml file.  This should be identical to the way it was in
198 - rc12.
199 - - Added support in the db-config.d/01-init script to register the root
200 - ssh public key with the default administrator.  In this way the root
201 - ssh key will make it into the root account on the nodes by means of
202 - NodeManager's specialaccounts plugin.
203
204 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
205 - db-config ignores sliver tags
206 - sirius's db-config script renamed (was sirious)
207
208 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
209 - fix for silverauth - missing tag types now created at plc startup time
210
211 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
212 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
213
214 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
215 - companion to NM's specialaccounts plugin
216 - do not generate /etc/planetlab/root_ssh_key* anymore
217 - remove related config. variables and conf_files
218
219 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
220 - clarified description text to refer only to plcrt and not other optional
221 - packages.
222
223 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
224 - fixed a bug setting slice multiple attributes with the same tag name
225
226 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
227 - SSL setup for monitor box, and related new config variables
228 - new conf_file for /etc/planetlab/extensions
229 - various tweaks in db-config internals, about initscripts among others
230 - also more messages defined in the db
231
232 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
233 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
234
235 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
236 - bugfix in db-config, tag 4.3-19 would not fly
237
238 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
239 - Refactored db-config into snippets in db-config.d/.
240
241 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
242 - oops, tag 4.3-17 was broken and would not work
243
244 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
245 - bugfix - escape sequences inserted in xml configs
246
247 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
248 - Handle db-config.d files properly.
249
250 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
251 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
252 - than the log file
253 - - Fix db-config to be a bit more cautious when
254 - /etc/planetlab/db-config.d doesn't exist
255 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
256 - .orig files.
257 - - Refactor generic plc-config-tty code into plc_config.py.
258 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
259 - and the list of validated variables and the corresponding
260 - validator() function. This refactoring lets one reuse plc_config.py
261 - as a generic cmdline configuration tool for highly customer MyPLC
262 - like software.
263
264 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
265 - update PCU Type descriptions.
266 - updates to init scripts
267
268 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
269 - requires monitor-pcucontrol so register-wizard can work
270
271 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
272 - cleaned up plc-config-tty, no more need to configure plc-devel
273
274 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
275 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
276
277 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
278 - tighter right permissions on site_admin's authorized keys for more robustness
279
280 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
281 - fix issue in db-config that prevented correct operation
282
283 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
284 - remove support for chroot-based packaging - no crond nor syslog step anymore
285 - plc init script now named plc.init instead of former guest.init
286
287 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
288 - add Monitor to docs build
289
290 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
291 - plc_config.py and plc-config-tty: generalized to work for more diverse
292 - MyPLC configurations.
293 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
294 - deployments and increase the memory limits in php.ini
295 - plc.d/crond: add --full option to vacuumdb
296
297 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
298 - avoid generating ssl certificates for disabled services among www api boot
299
300 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
301 - cleaned up old entries in db-config
302 - mtail more robust
303
304 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
305 - php include path tweaked for plekit includes
306 - reviewed myplc (fka native) packaging dependencies
307 - renumbered 4.3
308
309 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
310 - rename myplc into myplc-chroot and myplc-native into myplc
311 - new settings (shortname & hrn_root) for local peer
312
313 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
314 - First iteration of new data model
315 - Bunch of various fixes
316
317 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
318 - Removed proper ops from planetflow slice.
319
320 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
321 - myplc-native requires myplc-docs
322 - fixed doc build by locating locally installed DTDs at build-time
323
324 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
325 - turn myplc-docs off for now
326
327 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
328 - figures in doc package
329
330 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
331 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
332 - chroot packaging does not have docs anymore
333 - 'cvs' and 'dev' not required from myplc-native anymore
334 - cosmetic change in kml output
335
336
337 %define module_current_branch 4.3