Setting tag myplc-5.0-11
[myplc.git] / myplc-docs.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-docs
7 %define version 5.0
8 %define taglevel 11
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) online documentation
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 BuildRequires: docbook-dtds, docbook-utils-pdf
28
29 %define debug_package %{nil}
30
31 %description
32 This package contains the online documentation for MyPLC, i.e. the
33 reference manuals for the two APIs provided: PLCAPI and NMAPI. A
34 more general introduction to the MyPLC system can be found at
35 http://svn.planet-lab.org/wiki/MyPLCUserGuide
36
37 %prep
38 %setup -q
39
40 %build
41 rm -rf $RPM_BUILD_ROOT
42
43 # using the new lowercase names, and handling legacy
44 [ -d plcapi ] || ln -s PLCAPI plcapi
45 [ -d monitor ] || ln -s Monitor monitor 
46 [ -d nodemanager ] || ln -s NodeManager nodemanager
47 [ -d myplc ] || ln -s MyPLC myplc
48
49 pushd plcapi
50 # beware that making the pdf file somehow overwrites the html
51 make -C doc PLCAPI.pdf 
52 rm -f doc/PLCAPI.html
53 make -C doc PLCAPI.html 
54 popd
55
56 pushd nodemanager
57 # beware that making the pdf file somehow overwrites the html
58 make -C doc NMAPI.pdf 
59 rm -f doc/NMAPI.html
60 make -C doc NMAPI.html 
61 popd
62
63 pushd monitor
64 # beware that making the pdf file somehow overwrites the html
65 make -C docs Monitor.pdf 
66 rm -f docs/Monitor.html
67 make -C docs Monitor.html 
68 popd
69
70 %install
71
72 for ext in pdf html; do
73     install -D -m 444 plcapi/doc/PLCAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.$ext
74     install -D -m 444 nodemanager/doc/NMAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.$ext
75     install -D -m 444 monitor/docs/Monitor.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.$ext
76 done
77
78 ./myplc/docbook2drupal.sh "PLC API Documentation (%{pldistro})" \
79     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.html \
80     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.php 
81 ./myplc/docbook2drupal.sh "Node Manager API Documentation (%{pldistro})" \
82     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.html \
83     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.php 
84 ./myplc/docbook2drupal.sh "Monitor API Documentation (%{pldistro})" \
85     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.html \
86     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.php 
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %files
92 %defattr(-,root,root,-)
93 /var/www/html/planetlab/doc/
94
95 %changelog
96 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
97 - add missing files to rpm package
98
99 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
100 - mtail.py -s for SFA
101 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
102
103 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
104 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
105
106 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
107 - plc-config-tty now has a validator on booleans
108 - e.g. entering 'True' now is rejected rather than silently recording 'false'
109
110 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
111 - disable mod_wsgi
112
113 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
114 - module name changes
115 - start wsgi support
116
117 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
118 - new setting PLC_RESERVATION_GRANULARITY
119
120 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
121 - * partial-repo.sh script
122 - * preserve key along with certificates
123
124 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
125 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
126
127 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
128 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
129 - new OMF category in the config
130 - create the drl system slice
131
132 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
133 - first working version of 5.0:
134 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
135 - nodefamily is 3-fold with pldistro-fcdistro-arch
136 - new PLC_FLAVOUR config category
137 - reviewed module layout
138 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
139
140 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
141 - support for fedora 12
142 - new package myplc-config for use by sfa
143 - drupal user registration turned off
144
145 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
146 - - fix to make sure when API, BOOT, MONITOR are on the same
147 - machine as WWW that the SSL key,cert for WWW takes precedence.
148 - - Do proper setup for SSL CA certficate to be used as the server
149 - chain.
150
151 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
152 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
153
154 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
155 - depend on pcucontrol
156
157 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
158 - * validate input according to type in plc_config
159 - * added the _genicw system slice
160 - * add tag types for sites and persons
161 - * add new tags for nodes and slices for exemption from myops
162
163 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
164 - turn off drupal on a box that acts as BOOT server but not as WWW server
165 - cleanup some obsolete code for old chroot-jail packaging in the process
166 - new bootcd-kernel script for keeping bootcd variants up2date
167
168 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
169 - Make the /etc/hosts manipulation optional.
170
171 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
172 - Fix SetRole.
173
174 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
175 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
176 - into the DB.
177 - - Added the root ssh key handling support back into plc.d/ssh and the
178 - default xml file.  This should be identical to the way it was in
179 - rc12.
180 - - Added support in the db-config.d/01-init script to register the root
181 - ssh public key with the default administrator.  In this way the root
182 - ssh key will make it into the root account on the nodes by means of
183 - NodeManager's specialaccounts plugin.
184
185 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
186 - db-config ignores sliver tags
187 - sirius's db-config script renamed (was sirious)
188
189 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
190 - fix for silverauth - missing tag types now created at plc startup time
191
192 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
193 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
194
195 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
196 - companion to NM's specialaccounts plugin
197 - do not generate /etc/planetlab/root_ssh_key* anymore
198 - remove related config. variables and conf_files
199
200 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
201 - clarified description text to refer only to plcrt and not other optional
202 - packages.
203
204 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
205 - fixed a bug setting slice multiple attributes with the same tag name
206
207 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
208 - SSL setup for monitor box, and related new config variables
209 - new conf_file for /etc/planetlab/extensions
210 - various tweaks in db-config internals, about initscripts among others
211 - also more messages defined in the db
212
213 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
214 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
215
216 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
217 - bugfix in db-config, tag 4.3-19 would not fly
218
219 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
220 - Refactored db-config into snippets in db-config.d/.
221
222 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
223 - oops, tag 4.3-17 was broken and would not work
224
225 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
226 - bugfix - escape sequences inserted in xml configs
227
228 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
229 - Handle db-config.d files properly.
230
231 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
232 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
233 - than the log file
234 - - Fix db-config to be a bit more cautious when
235 - /etc/planetlab/db-config.d doesn't exist
236 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
237 - .orig files.
238 - - Refactor generic plc-config-tty code into plc_config.py.
239 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
240 - and the list of validated variables and the corresponding
241 - validator() function. This refactoring lets one reuse plc_config.py
242 - as a generic cmdline configuration tool for highly customer MyPLC
243 - like software.
244
245 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
246 - update PCU Type descriptions.
247 - updates to init scripts
248
249 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
250 - requires monitor-pcucontrol so register-wizard can work
251
252 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
253 - cleaned up plc-config-tty, no more need to configure plc-devel
254
255 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
256 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
257
258 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
259 - tighter right permissions on site_admin's authorized keys for more robustness
260
261 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
262 - fix issue in db-config that prevented correct operation
263
264 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
265 - remove support for chroot-based packaging - no crond nor syslog step anymore
266 - plc init script now named plc.init instead of former guest.init
267
268 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
269 - add Monitor to docs build
270
271 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
272 - plc_config.py and plc-config-tty: generalized to work for more diverse
273 - MyPLC configurations.
274 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
275 - deployments and increase the memory limits in php.ini
276 - plc.d/crond: add --full option to vacuumdb
277
278 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
279 - avoid generating ssl certificates for disabled services among www api boot
280
281 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
282 - cleaned up old entries in db-config
283 - mtail more robust
284
285 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
286 - php include path tweaked for plekit includes
287 - reviewed myplc (fka native) packaging dependencies
288 - renumbered 4.3
289
290 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
291 - rename myplc into myplc-chroot and myplc-native into myplc
292 - new settings (shortname & hrn_root) for local peer
293
294 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
295 - First iteration of new data model
296 - Bunch of various fixes
297
298 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
299 - Removed proper ops from planetflow slice.
300
301 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
302 - myplc-native requires myplc-docs
303 - fixed doc build by locating locally installed DTDs at build-time
304
305 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
306 - turn myplc-docs off for now
307
308 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
309 - figures in doc package
310
311 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
312 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
313 - chroot packaging does not have docs anymore
314 - 'cvs' and 'dev' not required from myplc-native anymore
315 - cosmetic change in kml output
316
317
318 %define module_current_branch 4.3