Setting tag MyPLC-5.0-3
[myplc.git] / myplc-docs.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-docs
7 %define version 5.0
8 %define taglevel 3
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) online documentation
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 BuildRequires: docbook-dtds, docbook-utils-pdf
28
29 %define debug_package %{nil}
30
31 %description
32 This package contains the online documentation for MyPLC, i.e. the
33 reference manuals for the two APIs provided: PLCAPI and NMAPI. A
34 more general introduction to the MyPLC system can be found at
35 http://svn.planet-lab.org/wiki/MyPLCUserGuide
36
37 %prep
38 %setup -q
39
40 %build
41 rm -rf $RPM_BUILD_ROOT
42
43 pushd PLCAPI
44 # beware that making the pdf file somehow overwrites the html
45 make -C doc PLCAPI.pdf 
46 rm -f doc/PLCAPI.html
47 make -C doc PLCAPI.html 
48 popd
49
50 pushd NodeManager
51 # beware that making the pdf file somehow overwrites the html
52 make -C doc NMAPI.pdf 
53 rm -f doc/NMAPI.html
54 make -C doc NMAPI.html 
55 popd
56
57 pushd Monitor
58 # beware that making the pdf file somehow overwrites the html
59 make -C docs Monitor.pdf 
60 rm -f docs/Monitor.html
61 make -C docs Monitor.html 
62 popd
63
64 %install
65
66 for ext in pdf html; do
67     install -D -m 444 PLCAPI/doc/PLCAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.$ext
68     install -D -m 444 NodeManager/doc/NMAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.$ext
69     install -D -m 444 Monitor/docs/Monitor.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.$ext
70 done
71
72 ./MyPLC/docbook2drupal.sh "PLC API Documentation (%{pldistro})" \
73     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.html \
74     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.php 
75 ./MyPLC/docbook2drupal.sh "Node Manager API Documentation (%{pldistro})" \
76     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.html \
77     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.php 
78 ./MyPLC/docbook2drupal.sh "Monitor API Documentation (%{pldistro})" \
79     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.html \
80     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.php 
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %files
86 %defattr(-,root,root,-)
87 /var/www/html/planetlab/doc/
88
89 %changelog
90 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
91 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
92
93 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
94 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
95 - new OMF category in the config
96 - create the drl system slice
97
98 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
99 - first working version of 5.0:
100 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
101 - nodefamily is 3-fold with pldistro-fcdistro-arch
102 - new PLC_FLAVOUR config category
103 - reviewed module layout
104 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
105
106 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
107 - support for fedora 12
108 - new package myplc-config for use by sfa
109 - drupal user registration turned off
110
111 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
112 - - fix to make sure when API, BOOT, MONITOR are on the same
113 - machine as WWW that the SSL key,cert for WWW takes precedence.
114 - - Do proper setup for SSL CA certficate to be used as the server
115 - chain.
116
117 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
118 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
119
120 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
121 - depend on pcucontrol
122
123 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
124 - * validate input according to type in plc_config
125 - * added the _genicw system slice
126 - * add tag types for sites and persons
127 - * add new tags for nodes and slices for exemption from myops
128
129 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
130 - turn off drupal on a box that acts as BOOT server but not as WWW server
131 - cleanup some obsolete code for old chroot-jail packaging in the process
132 - new bootcd-kernel script for keeping bootcd variants up2date
133
134 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
135 - Make the /etc/hosts manipulation optional.
136
137 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
138 - Fix SetRole.
139
140 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
141 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
142 - into the DB.
143 - - Added the root ssh key handling support back into plc.d/ssh and the
144 - default xml file.  This should be identical to the way it was in
145 - rc12.
146 - - Added support in the db-config.d/01-init script to register the root
147 - ssh public key with the default administrator.  In this way the root
148 - ssh key will make it into the root account on the nodes by means of
149 - NodeManager's specialaccounts plugin.
150
151 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
152 - db-config ignores sliver tags
153 - sirius's db-config script renamed (was sirious)
154
155 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
156 - fix for silverauth - missing tag types now created at plc startup time
157
158 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
159 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
160
161 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
162 - companion to NM's specialaccounts plugin
163 - do not generate /etc/planetlab/root_ssh_key* anymore
164 - remove related config. variables and conf_files
165
166 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
167 - clarified description text to refer only to plcrt and not other optional
168 - packages.
169
170 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
171 - fixed a bug setting slice multiple attributes with the same tag name
172
173 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
174 - SSL setup for monitor box, and related new config variables
175 - new conf_file for /etc/planetlab/extensions
176 - various tweaks in db-config internals, about initscripts among others
177 - also more messages defined in the db
178
179 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
180 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
181
182 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
183 - bugfix in db-config, tag 4.3-19 would not fly
184
185 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
186 - Refactored db-config into snippets in db-config.d/.
187
188 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
189 - oops, tag 4.3-17 was broken and would not work
190
191 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
192 - bugfix - escape sequences inserted in xml configs
193
194 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
195 - Handle db-config.d files properly.
196
197 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
198 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
199 - than the log file
200 - - Fix db-config to be a bit more cautious when
201 - /etc/planetlab/db-config.d doesn't exist
202 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
203 - .orig files.
204 - - Refactor generic plc-config-tty code into plc_config.py.
205 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
206 - and the list of validated variables and the corresponding
207 - validator() function. This refactoring lets one reuse plc_config.py
208 - as a generic cmdline configuration tool for highly customer MyPLC
209 - like software.
210
211 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
212 - update PCU Type descriptions.
213 - updates to init scripts
214
215 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
216 - requires monitor-pcucontrol so register-wizard can work
217
218 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
219 - cleaned up plc-config-tty, no more need to configure plc-devel
220
221 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
222 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
223
224 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
225 - tighter right permissions on site_admin's authorized keys for more robustness
226
227 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
228 - fix issue in db-config that prevented correct operation
229
230 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
231 - remove support for chroot-based packaging - no crond nor syslog step anymore
232 - plc init script now named plc.init instead of former guest.init
233
234 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
235 - add Monitor to docs build
236
237 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
238 - plc_config.py and plc-config-tty: generalized to work for more diverse
239 - MyPLC configurations.
240 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
241 - deployments and increase the memory limits in php.ini
242 - plc.d/crond: add --full option to vacuumdb
243
244 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
245 - avoid generating ssl certificates for disabled services among www api boot
246
247 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
248 - cleaned up old entries in db-config
249 - mtail more robust
250
251 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
252 - php include path tweaked for plekit includes
253 - reviewed myplc (fka native) packaging dependencies
254 - renumbered 4.3
255
256 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
257 - rename myplc into myplc-chroot and myplc-native into myplc
258 - new settings (shortname & hrn_root) for local peer
259
260 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
261 - First iteration of new data model
262 - Bunch of various fixes
263
264 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
265 - Removed proper ops from planetflow slice.
266
267 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
268 - myplc-native requires myplc-docs
269 - fixed doc build by locating locally installed DTDs at build-time
270
271 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
272 - turn myplc-docs off for now
273
274 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
275 - figures in doc package
276
277 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
278 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
279 - chroot packaging does not have docs anymore
280 - 'cvs' and 'dev' not required from myplc-native anymore
281 - cosmetic change in kml output
282
283
284 %define module_current_branch 4.3