be stubborn on running latex as on f12 it behaves somewjat weird
[myplc.git] / myplc-docs.spec
1 %define name myplc-docs
2 %define version 5.0
3 %define taglevel 17
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central (PLC) online documentation
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: Applications/Systems
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15 BuildArch: noarch
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21
22 BuildRequires: docbook-dtds, docbook-utils-pdf
23
24 %define debug_package %{nil}
25
26 %description
27 This package contains the online documentation for MyPLC, i.e. the
28 reference manuals for the two APIs provided: PLCAPI and NMAPI. A
29 more general introduction to the MyPLC system can be found at
30 http://svn.planet-lab.org/wiki/MyPLCUserGuide
31
32 %prep
33 %setup -q
34
35 %build
36 rm -rf $RPM_BUILD_ROOT
37
38 # using the new lowercase names, and handling legacy
39 [ -d myplc ] || ln -s MyPLC myplc
40 [ -d plcapi ] || ln -s PLCAPI plcapi
41 [ -d nodemanager ] || ln -s NodeManager nodemanager
42 [ -d monitor ] || ln -s Monitor monitor 
43
44 pushd plcapi
45 # june2011 & f12, latex issues weird warnings, might need to try twice
46 make -C doc PLCAPI.pdf || make -C doc PLCAPI.pdf 
47 # beware that making the pdf file somehow overwrites the html
48 rm -f doc/PLCAPI.html
49 make -C doc PLCAPI.html || make -C doc PLCAPI.html 
50 popd
51
52 pushd nodemanager
53 # beware that making the pdf file somehow overwrites the html
54 make -C doc NMAPI.pdf || make -C doc NMAPI.pdf
55 rm -f doc/NMAPI.html
56 make -C doc NMAPI.html || make -C doc NMAPI.html 
57 popd
58
59 # not everyone rebuilds monitor, so make it optional
60 if [ -d monitor ] ; then
61 pushd monitor
62 # beware that making the pdf file somehow overwrites the html
63 make -C docs Monitor.pdf || make -C docs Monitor.pdf 
64 rm -f docs/Monitor.html
65 make -C docs Monitor.html || make -C docs Monitor.html 
66 popd
67 fi
68
69 %install
70
71 for ext in pdf html; do
72     install -D -m 444 plcapi/doc/PLCAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.$ext
73     install -D -m 444 nodemanager/doc/NMAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.$ext
74     if [ -d monitor ] ; then
75     install -D -m 444 monitor/docs/Monitor.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.$ext
76     fi
77 done
78
79 ./myplc/docbook2drupal.sh "PLC API Documentation (%{pldistro})" \
80     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.html \
81     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.php 
82 ./myplc/docbook2drupal.sh "Node Manager API Documentation (%{pldistro})" \
83     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.html \
84     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.php 
85 if [ -d monitor ] ; then
86 ./myplc/docbook2drupal.sh "Monitor API Documentation (%{pldistro})" \
87     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.html \
88     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.php 
89 fi
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %files
95 %defattr(-,root,root,-)
96 /var/www/html/planetlab/doc/
97
98 %changelog
99 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-17
100 - fixed changelog, no change from 5.0-16
101
102 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-16
103 - requires ed for the plc.d/packages step
104 - sirius initscript to handle stop and restart
105
106 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-15
107 - ignore steps in db-config.d if they have a '.' or '~' in their name
108
109 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-14
110 - can redo myplc-docs without the doc for monitor
111
112 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-13
113 - no semantic change - just fixed specfile for git URL
114
115 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
116 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
117
118 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
119 - add missing files to rpm package
120
121 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
122 - mtail.py -s for SFA
123 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
124
125 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
126 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
127
128 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
129 - plc-config-tty now has a validator on booleans
130 - e.g. entering 'True' now is rejected rather than silently recording 'false'
131
132 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
133 - disable mod_wsgi
134
135 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
136 - module name changes
137 - start wsgi support
138
139 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
140 - new setting PLC_RESERVATION_GRANULARITY
141
142 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
143 - * partial-repo.sh script
144 - * preserve key along with certificates
145
146 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
147 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
148
149 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
150 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
151 - new OMF category in the config
152 - create the drl system slice
153
154 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
155 - first working version of 5.0:
156 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
157 - nodefamily is 3-fold with pldistro-fcdistro-arch
158 - new PLC_FLAVOUR config category
159 - reviewed module layout
160 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
161
162 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
163 - support for fedora 12
164 - new package myplc-config for use by sfa
165 - drupal user registration turned off
166
167 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
168 - - fix to make sure when API, BOOT, MONITOR are on the same
169 - machine as WWW that the SSL key,cert for WWW takes precedence.
170 - - Do proper setup for SSL CA certficate to be used as the server
171 - chain.
172
173 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
174 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
175
176 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
177 - depend on pcucontrol
178
179 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
180 - * validate input according to type in plc_config
181 - * added the _genicw system slice
182 - * add tag types for sites and persons
183 - * add new tags for nodes and slices for exemption from myops
184
185 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
186 - turn off drupal on a box that acts as BOOT server but not as WWW server
187 - cleanup some obsolete code for old chroot-jail packaging in the process
188 - new bootcd-kernel script for keeping bootcd variants up2date
189
190 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
191 - Make the /etc/hosts manipulation optional.
192
193 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
194 - Fix SetRole.
195
196 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
197 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
198 - into the DB.
199 - - Added the root ssh key handling support back into plc.d/ssh and the
200 - default xml file.  This should be identical to the way it was in
201 - rc12.
202 - - Added support in the db-config.d/01-init script to register the root
203 - ssh public key with the default administrator.  In this way the root
204 - ssh key will make it into the root account on the nodes by means of
205 - NodeManager's specialaccounts plugin.
206
207 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
208 - db-config ignores sliver tags
209 - sirius's db-config script renamed (was sirious)
210
211 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
212 - fix for silverauth - missing tag types now created at plc startup time
213
214 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
215 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
216
217 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
218 - companion to NM's specialaccounts plugin
219 - do not generate /etc/planetlab/root_ssh_key* anymore
220 - remove related config. variables and conf_files
221
222 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
223 - clarified description text to refer only to plcrt and not other optional
224 - packages.
225
226 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
227 - fixed a bug setting slice multiple attributes with the same tag name
228
229 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
230 - SSL setup for monitor box, and related new config variables
231 - new conf_file for /etc/planetlab/extensions
232 - various tweaks in db-config internals, about initscripts among others
233 - also more messages defined in the db
234
235 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
236 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
237
238 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
239 - bugfix in db-config, tag 4.3-19 would not fly
240
241 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
242 - Refactored db-config into snippets in db-config.d/.
243
244 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
245 - oops, tag 4.3-17 was broken and would not work
246
247 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
248 - bugfix - escape sequences inserted in xml configs
249
250 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
251 - Handle db-config.d files properly.
252
253 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
254 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
255 - than the log file
256 - - Fix db-config to be a bit more cautious when
257 - /etc/planetlab/db-config.d doesn't exist
258 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
259 - .orig files.
260 - - Refactor generic plc-config-tty code into plc_config.py.
261 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
262 - and the list of validated variables and the corresponding
263 - validator() function. This refactoring lets one reuse plc_config.py
264 - as a generic cmdline configuration tool for highly customer MyPLC
265 - like software.
266
267 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
268 - update PCU Type descriptions.
269 - updates to init scripts
270
271 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
272 - requires monitor-pcucontrol so register-wizard can work
273
274 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
275 - cleaned up plc-config-tty, no more need to configure plc-devel
276
277 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
278 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
279
280 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
281 - tighter right permissions on site_admin's authorized keys for more robustness
282
283 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
284 - fix issue in db-config that prevented correct operation
285
286 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
287 - remove support for chroot-based packaging - no crond nor syslog step anymore
288 - plc init script now named plc.init instead of former guest.init
289
290 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
291 - add Monitor to docs build
292
293 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
294 - plc_config.py and plc-config-tty: generalized to work for more diverse
295 - MyPLC configurations.
296 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
297 - deployments and increase the memory limits in php.ini
298 - plc.d/crond: add --full option to vacuumdb
299
300 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
301 - avoid generating ssl certificates for disabled services among www api boot
302
303 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
304 - cleaned up old entries in db-config
305 - mtail more robust
306
307 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
308 - php include path tweaked for plekit includes
309 - reviewed myplc (fka native) packaging dependencies
310 - renumbered 4.3
311
312 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
313 - rename myplc into myplc-chroot and myplc-native into myplc
314 - new settings (shortname & hrn_root) for local peer
315
316 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
317 - First iteration of new data model
318 - Bunch of various fixes
319
320 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
321 - Removed proper ops from planetflow slice.
322
323 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
324 - myplc-native requires myplc-docs
325 - fixed doc build by locating locally installed DTDs at build-time
326
327 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
328 - turn myplc-docs off for now
329
330 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
331 - figures in doc package
332
333 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
334 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
335 - chroot packaging does not have docs anymore
336 - 'cvs' and 'dev' not required from myplc-native anymore
337 - cosmetic change in kml output
338
339
340 %define module_current_branch 4.3