Tagging module MyPLC - MyPLC-4.2-15
[myplc.git] / myplc-docs.spec
1 #
2 # $Id: myplc-native.spec 9260 2008-05-07 16:20:25Z thierry $
3 #
4 %define url $URL: svn+ssh://thierry@svn.planet-lab.org/svn/MyPLC/trunk/myplc-native.spec $
5
6 %define name myplc-docs
7 %define version 4.2
8 %define taglevel 15
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) online documentation
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 BuildRequires: docbook-dtds, docbook-utils-pdf
28
29 %define debug_package %{nil}
30
31 %description 
32 This package contains the online documentation for MyPLC. This covers
33 the overall system itself, together with the reference manuals for the
34 two APIs provided, namely PLCAPI and NMAPI.
35
36 %prep
37 %setup -q
38
39 %build
40 rm -rf $RPM_BUILD_ROOT
41
42 pushd MyPLC
43 # beware that making the pdf file somehow overwrites the html
44 make -C doc myplc.pdf 
45 rm -f doc/myplc.html
46 make -C doc myplc.html 
47 popd
48
49 pushd PLCAPI
50 # beware that making the pdf file somehow overwrites the html
51 make -C doc PLCAPI.pdf 
52 rm -f doc/PLCAPI.html
53 make -C doc PLCAPI.html 
54 popd
55
56 pushd NodeManager
57 # beware that making the pdf file somehow overwrites the html
58 make -C doc NMAPI.pdf 
59 rm -f doc/NMAPI.html
60 make -C doc NMAPI.html 
61 popd
62
63 %install
64
65 for ext in pdf html; do
66     install -D -m 444 MyPLC/doc/myplc.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/myplc.$ext
67     install -D -m 444 PLCAPI/doc/PLCAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.$ext
68     install -D -m 444 NodeManager/doc/NMAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.$ext
69 done
70
71 # myplc figures
72 for ext in eps png; do 
73     install -m 444 MyPLC/doc/architecture.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/architecture.$ext
74 done
75
76 ./MyPLC/doc/docbook2drupal.sh "MyPLC Documentation (%{pldistro})" \
77     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/myplc.html \
78     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/myplc.php 
79 ./MyPLC/doc/docbook2drupal.sh "PLC API Documentation (%{pldistro})" \
80     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.html \
81     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.php 
82 ./MyPLC/doc/docbook2drupal.sh "Node Manager API Documentation (%{pldistro})" \
83     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.html \
84     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.php 
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %files
90 %defattr(-,root,root,-)
91 /var/www/html/planetlab/doc/
92
93 %changelog
94 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
95 - Removed proper ops from planetflow slice.
96
97 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
98 - myplc-native requires myplc-docs
99 - fixed doc build by locating locally installed DTDs at build-time
100
101 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
102 - turn myplc-docs off for now
103
104 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
105 - figures in doc package
106
107 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
108 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
109 - chroot packaging does not have docs anymore
110 - 'cvs' and 'dev' not required from myplc-native anymore
111 - cosmetic change in kml output
112