Setting tag MyPLC-4.3-32
[myplc.git] / myplc-docs.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-docs
7 %define version 4.3
8 %define taglevel 32
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) online documentation
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 BuildRequires: docbook-dtds, docbook-utils-pdf
28
29 %define debug_package %{nil}
30
31 %description
32 This package contains the online documentation for MyPLC, i.e. the
33 reference manuals for the two APIs provided: PLCAPI and NMAPI. A
34 more general introduction to the MyPLC system can be found at
35 http://svn.planet-lab.org/wiki/MyPLCUserGuide
36
37 %prep
38 %setup -q
39
40 %build
41 rm -rf $RPM_BUILD_ROOT
42
43 pushd PLCAPI
44 # beware that making the pdf file somehow overwrites the html
45 make -C doc PLCAPI.pdf 
46 rm -f doc/PLCAPI.html
47 make -C doc PLCAPI.html 
48 popd
49
50 pushd NodeManager
51 # beware that making the pdf file somehow overwrites the html
52 make -C doc NMAPI.pdf 
53 rm -f doc/NMAPI.html
54 make -C doc NMAPI.html 
55 popd
56
57 pushd Monitor
58 # beware that making the pdf file somehow overwrites the html
59 make -C docs Monitor.pdf 
60 rm -f docs/Monitor.html
61 make -C docs Monitor.html 
62 popd
63
64 %install
65
66 for ext in pdf html; do
67     install -D -m 444 PLCAPI/doc/PLCAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.$ext
68     install -D -m 444 NodeManager/doc/NMAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.$ext
69     install -D -m 444 Monitor/docs/Monitor.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.$ext
70 done
71
72 ./MyPLC/docbook2drupal.sh "PLC API Documentation (%{pldistro})" \
73     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.html \
74     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.php 
75 ./MyPLC/docbook2drupal.sh "Node Manager API Documentation (%{pldistro})" \
76     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.html \
77     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.php 
78 ./MyPLC/docbook2drupal.sh "Monitor API Documentation (%{pldistro})" \
79     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.html \
80     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.php 
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %files
86 %defattr(-,root,root,-)
87 /var/www/html/planetlab/doc/
88
89 %changelog
90 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
91 - turn off drupal on a box that acts as BOOT server but not as WWW server
92 - cleanup some obsolete code for old chroot-jail packaging in the process
93 - new bootcd-kernel script for keeping bootcd variants up2date
94
95 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
96 - Make the /etc/hosts manipulation optional.
97
98 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
99 - Fix SetRole.
100
101 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
102 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
103 - into the DB.
104 - - Added the root ssh key handling support back into plc.d/ssh and the
105 - default xml file.  This should be identical to the way it was in
106 - rc12.
107 - - Added support in the db-config.d/01-init script to register the root
108 - ssh public key with the default administrator.  In this way the root
109 - ssh key will make it into the root account on the nodes by means of
110 - NodeManager's specialaccounts plugin.
111
112 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
113 - db-config ignores sliver tags
114 - sirius's db-config script renamed (was sirious)
115
116 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
117 - fix for silverauth - missing tag types now created at plc startup time
118
119 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
120 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
121
122 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
123 - companion to NM's specialaccounts plugin
124 - do not generate /etc/planetlab/root_ssh_key* anymore
125 - remove related config. variables and conf_files
126
127 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
128 - clarified description text to refer only to plcrt and not other optional
129 - packages.
130
131 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
132 - fixed a bug setting slice multiple attributes with the same tag name
133
134 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
135 - SSL setup for monitor box, and related new config variables
136 - new conf_file for /etc/planetlab/extensions
137 - various tweaks in db-config internals, about initscripts among others
138 - also more messages defined in the db
139
140 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
141 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
142
143 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
144 - bugfix in db-config, tag 4.3-19 would not fly
145
146 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
147 - Refactored db-config into snippets in db-config.d/.
148
149 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
150 - oops, tag 4.3-17 was broken and would not work
151
152 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
153 - bugfix - escape sequences inserted in xml configs
154
155 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
156 - Handle db-config.d files properly.
157
158 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
159 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
160 - than the log file
161 - - Fix db-config to be a bit more cautious when
162 - /etc/planetlab/db-config.d doesn't exist
163 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
164 - .orig files.
165 - - Refactor generic plc-config-tty code into plc_config.py.
166 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
167 - and the list of validated variables and the corresponding
168 - validator() function. This refactoring lets one reuse plc_config.py
169 - as a generic cmdline configuration tool for highly customer MyPLC
170 - like software.
171
172 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
173 - update PCU Type descriptions.
174 - updates to init scripts
175
176 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
177 - requires monitor-pcucontrol so register-wizard can work
178
179 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
180 - cleaned up plc-config-tty, no more need to configure plc-devel
181
182 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
183 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
184
185 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
186 - tighter right permissions on site_admin's authorized keys for more robustness
187
188 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
189 - fix issue in db-config that prevented correct operation
190
191 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
192 - remove support for chroot-based packaging - no crond nor syslog step anymore
193 - plc init script now named plc.init instead of former guest.init
194
195 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
196 - add Monitor to docs build
197
198 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
199 - plc_config.py and plc-config-tty: generalized to work for more diverse
200 - MyPLC configurations.
201 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
202 - deployments and increase the memory limits in php.ini
203 - plc.d/crond: add --full option to vacuumdb
204
205 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
206 - avoid generating ssl certificates for disabled services among www api boot
207
208 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
209 - cleaned up old entries in db-config
210 - mtail more robust
211
212 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
213 - php include path tweaked for plekit includes
214 - reviewed myplc (fka native) packaging dependencies
215 - renumbered 4.3
216
217 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
218 - rename myplc into myplc-chroot and myplc-native into myplc
219 - new settings (shortname & hrn_root) for local peer
220
221 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
222 - First iteration of new data model
223 - Bunch of various fixes
224
225 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
226 - Removed proper ops from planetflow slice.
227
228 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
229 - myplc-native requires myplc-docs
230 - fixed doc build by locating locally installed DTDs at build-time
231
232 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
233 - turn myplc-docs off for now
234
235 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
236 - figures in doc package
237
238 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
239 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
240 - chroot packaging does not have docs anymore
241 - 'cvs' and 'dev' not required from myplc-native anymore
242 - cosmetic change in kml output
243
244
245 %define module_current_branch 4.2