Merge commit 'origin/master'
[myplc.git] / myplc-docs.spec
1 %define name myplc-docs
2 %define version 5.0
3 %define taglevel 17
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central (PLC) online documentation
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: Applications/Systems
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15 BuildArch: noarch
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21
22 BuildRequires: docbook-dtds, docbook-utils-pdf
23
24 %define debug_package %{nil}
25
26 %description
27 This package contains the online documentation for MyPLC, i.e. the
28 reference manuals for the two APIs provided: PLCAPI and NMAPI. A
29 more general introduction to the MyPLC system can be found at
30 http://svn.planet-lab.org/wiki/MyPLCUserGuide
31
32 %prep
33 %setup -q
34
35 %build
36 rm -rf $RPM_BUILD_ROOT
37
38 # using the new lowercase names, and handling legacy
39 [ -d myplc ] || ln -s MyPLC myplc
40 [ -d plcapi ] || ln -s PLCAPI plcapi
41 [ -d nodemanager ] || ln -s NodeManager nodemanager
42 [ -d monitor ] || ln -s Monitor monitor 
43
44 pushd plcapi
45 # beware that making the pdf file somehow overwrites the html
46 make -C doc PLCAPI.pdf 
47 rm -f doc/PLCAPI.html
48 make -C doc PLCAPI.html 
49 popd
50
51 pushd nodemanager
52 # beware that making the pdf file somehow overwrites the html
53 make -C doc NMAPI.pdf 
54 rm -f doc/NMAPI.html
55 make -C doc NMAPI.html 
56 popd
57
58 # not everyone rebuilds monitor, so make it optional
59 if [ -d monitor ] ; then
60 pushd monitor
61 # beware that making the pdf file somehow overwrites the html
62 make -C docs Monitor.pdf 
63 rm -f docs/Monitor.html
64 make -C docs Monitor.html 
65 popd
66 fi
67
68 %install
69
70 for ext in pdf html; do
71     install -D -m 444 plcapi/doc/PLCAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.$ext
72     install -D -m 444 nodemanager/doc/NMAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.$ext
73     if [ -d monitor ] ; then
74     install -D -m 444 monitor/docs/Monitor.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.$ext
75     fi
76 done
77
78 ./myplc/docbook2drupal.sh "PLC API Documentation (%{pldistro})" \
79     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.html \
80     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.php 
81 ./myplc/docbook2drupal.sh "Node Manager API Documentation (%{pldistro})" \
82     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.html \
83     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.php 
84 if [ -d monitor ] ; then
85 ./myplc/docbook2drupal.sh "Monitor API Documentation (%{pldistro})" \
86     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.html \
87     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.php 
88 fi
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %files
94 %defattr(-,root,root,-)
95 /var/www/html/planetlab/doc/
96
97 %changelog
98 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-17
99 - fixed changelog, no change from 5.0-16
100
101 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-16
102 - requires ed for the plc.d/packages step
103 - sirius initscript to handle stop and restart
104
105 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-15
106 - ignore steps in db-config.d if they have a '.' or '~' in their name
107
108 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-14
109 - can redo myplc-docs without the doc for monitor
110
111 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-13
112 - no semantic change - just fixed specfile for git URL
113
114 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
115 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
116
117 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
118 - add missing files to rpm package
119
120 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
121 - mtail.py -s for SFA
122 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
123
124 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
125 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
126
127 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
128 - plc-config-tty now has a validator on booleans
129 - e.g. entering 'True' now is rejected rather than silently recording 'false'
130
131 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
132 - disable mod_wsgi
133
134 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
135 - module name changes
136 - start wsgi support
137
138 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
139 - new setting PLC_RESERVATION_GRANULARITY
140
141 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
142 - * partial-repo.sh script
143 - * preserve key along with certificates
144
145 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
146 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
147
148 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
149 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
150 - new OMF category in the config
151 - create the drl system slice
152
153 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
154 - first working version of 5.0:
155 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
156 - nodefamily is 3-fold with pldistro-fcdistro-arch
157 - new PLC_FLAVOUR config category
158 - reviewed module layout
159 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
160
161 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
162 - support for fedora 12
163 - new package myplc-config for use by sfa
164 - drupal user registration turned off
165
166 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
167 - - fix to make sure when API, BOOT, MONITOR are on the same
168 - machine as WWW that the SSL key,cert for WWW takes precedence.
169 - - Do proper setup for SSL CA certficate to be used as the server
170 - chain.
171
172 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
173 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
174
175 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
176 - depend on pcucontrol
177
178 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
179 - * validate input according to type in plc_config
180 - * added the _genicw system slice
181 - * add tag types for sites and persons
182 - * add new tags for nodes and slices for exemption from myops
183
184 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
185 - turn off drupal on a box that acts as BOOT server but not as WWW server
186 - cleanup some obsolete code for old chroot-jail packaging in the process
187 - new bootcd-kernel script for keeping bootcd variants up2date
188
189 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
190 - Make the /etc/hosts manipulation optional.
191
192 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
193 - Fix SetRole.
194
195 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
196 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
197 - into the DB.
198 - - Added the root ssh key handling support back into plc.d/ssh and the
199 - default xml file.  This should be identical to the way it was in
200 - rc12.
201 - - Added support in the db-config.d/01-init script to register the root
202 - ssh public key with the default administrator.  In this way the root
203 - ssh key will make it into the root account on the nodes by means of
204 - NodeManager's specialaccounts plugin.
205
206 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
207 - db-config ignores sliver tags
208 - sirius's db-config script renamed (was sirious)
209
210 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
211 - fix for silverauth - missing tag types now created at plc startup time
212
213 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
214 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
215
216 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
217 - companion to NM's specialaccounts plugin
218 - do not generate /etc/planetlab/root_ssh_key* anymore
219 - remove related config. variables and conf_files
220
221 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
222 - clarified description text to refer only to plcrt and not other optional
223 - packages.
224
225 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
226 - fixed a bug setting slice multiple attributes with the same tag name
227
228 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
229 - SSL setup for monitor box, and related new config variables
230 - new conf_file for /etc/planetlab/extensions
231 - various tweaks in db-config internals, about initscripts among others
232 - also more messages defined in the db
233
234 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
235 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
236
237 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
238 - bugfix in db-config, tag 4.3-19 would not fly
239
240 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
241 - Refactored db-config into snippets in db-config.d/.
242
243 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
244 - oops, tag 4.3-17 was broken and would not work
245
246 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
247 - bugfix - escape sequences inserted in xml configs
248
249 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
250 - Handle db-config.d files properly.
251
252 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
253 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
254 - than the log file
255 - - Fix db-config to be a bit more cautious when
256 - /etc/planetlab/db-config.d doesn't exist
257 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
258 - .orig files.
259 - - Refactor generic plc-config-tty code into plc_config.py.
260 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
261 - and the list of validated variables and the corresponding
262 - validator() function. This refactoring lets one reuse plc_config.py
263 - as a generic cmdline configuration tool for highly customer MyPLC
264 - like software.
265
266 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
267 - update PCU Type descriptions.
268 - updates to init scripts
269
270 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
271 - requires monitor-pcucontrol so register-wizard can work
272
273 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
274 - cleaned up plc-config-tty, no more need to configure plc-devel
275
276 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
277 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
278
279 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
280 - tighter right permissions on site_admin's authorized keys for more robustness
281
282 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
283 - fix issue in db-config that prevented correct operation
284
285 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
286 - remove support for chroot-based packaging - no crond nor syslog step anymore
287 - plc init script now named plc.init instead of former guest.init
288
289 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
290 - add Monitor to docs build
291
292 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
293 - plc_config.py and plc-config-tty: generalized to work for more diverse
294 - MyPLC configurations.
295 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
296 - deployments and increase the memory limits in php.ini
297 - plc.d/crond: add --full option to vacuumdb
298
299 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
300 - avoid generating ssl certificates for disabled services among www api boot
301
302 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
303 - cleaned up old entries in db-config
304 - mtail more robust
305
306 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
307 - php include path tweaked for plekit includes
308 - reviewed myplc (fka native) packaging dependencies
309 - renumbered 4.3
310
311 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
312 - rename myplc into myplc-chroot and myplc-native into myplc
313 - new settings (shortname & hrn_root) for local peer
314
315 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
316 - First iteration of new data model
317 - Bunch of various fixes
318
319 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
320 - Removed proper ops from planetflow slice.
321
322 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
323 - myplc-native requires myplc-docs
324 - fixed doc build by locating locally installed DTDs at build-time
325
326 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
327 - turn myplc-docs off for now
328
329 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
330 - figures in doc package
331
332 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
333 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
334 - chroot packaging does not have docs anymore
335 - 'cvs' and 'dev' not required from myplc-native anymore
336 - cosmetic change in kml output
337
338
339 %define module_current_branch 4.3