Setting tag myplc-5.0-13
[myplc.git] / myplc-docs.spec
1 %define name myplc-docs
2 %define version 5.0
3 %define taglevel 13
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central (PLC) online documentation
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: Applications/Systems
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15 BuildArch: noarch
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21
22 BuildRequires: docbook-dtds, docbook-utils-pdf
23
24 %define debug_package %{nil}
25
26 %description
27 This package contains the online documentation for MyPLC, i.e. the
28 reference manuals for the two APIs provided: PLCAPI and NMAPI. A
29 more general introduction to the MyPLC system can be found at
30 http://svn.planet-lab.org/wiki/MyPLCUserGuide
31
32 %prep
33 %setup -q
34
35 %build
36 rm -rf $RPM_BUILD_ROOT
37
38 # using the new lowercase names, and handling legacy
39 [ -d plcapi ] || ln -s PLCAPI plcapi
40 [ -d monitor ] || ln -s Monitor monitor 
41 [ -d nodemanager ] || ln -s NodeManager nodemanager
42 [ -d myplc ] || ln -s MyPLC myplc
43
44 pushd plcapi
45 # beware that making the pdf file somehow overwrites the html
46 make -C doc PLCAPI.pdf 
47 rm -f doc/PLCAPI.html
48 make -C doc PLCAPI.html 
49 popd
50
51 pushd nodemanager
52 # beware that making the pdf file somehow overwrites the html
53 make -C doc NMAPI.pdf 
54 rm -f doc/NMAPI.html
55 make -C doc NMAPI.html 
56 popd
57
58 pushd monitor
59 # beware that making the pdf file somehow overwrites the html
60 make -C docs Monitor.pdf 
61 rm -f docs/Monitor.html
62 make -C docs Monitor.html 
63 popd
64
65 %install
66
67 for ext in pdf html; do
68     install -D -m 444 plcapi/doc/PLCAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.$ext
69     install -D -m 444 nodemanager/doc/NMAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.$ext
70     install -D -m 444 monitor/docs/Monitor.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.$ext
71 done
72
73 ./myplc/docbook2drupal.sh "PLC API Documentation (%{pldistro})" \
74     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.html \
75     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.php 
76 ./myplc/docbook2drupal.sh "Node Manager API Documentation (%{pldistro})" \
77     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.html \
78     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.php 
79 ./myplc/docbook2drupal.sh "Monitor API Documentation (%{pldistro})" \
80     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.html \
81     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.php 
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %files
87 %defattr(-,root,root,-)
88 /var/www/html/planetlab/doc/
89
90 %changelog
91 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-13
92 - no semantic change - just fixed specfile for git URL
93
94 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
95 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
96
97 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
98 - add missing files to rpm package
99
100 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
101 - mtail.py -s for SFA
102 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
103
104 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
105 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
106
107 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
108 - plc-config-tty now has a validator on booleans
109 - e.g. entering 'True' now is rejected rather than silently recording 'false'
110
111 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
112 - disable mod_wsgi
113
114 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
115 - module name changes
116 - start wsgi support
117
118 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
119 - new setting PLC_RESERVATION_GRANULARITY
120
121 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
122 - * partial-repo.sh script
123 - * preserve key along with certificates
124
125 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
126 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
127
128 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
129 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
130 - new OMF category in the config
131 - create the drl system slice
132
133 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
134 - first working version of 5.0:
135 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
136 - nodefamily is 3-fold with pldistro-fcdistro-arch
137 - new PLC_FLAVOUR config category
138 - reviewed module layout
139 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
140
141 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
142 - support for fedora 12
143 - new package myplc-config for use by sfa
144 - drupal user registration turned off
145
146 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
147 - - fix to make sure when API, BOOT, MONITOR are on the same
148 - machine as WWW that the SSL key,cert for WWW takes precedence.
149 - - Do proper setup for SSL CA certficate to be used as the server
150 - chain.
151
152 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
153 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
154
155 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
156 - depend on pcucontrol
157
158 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
159 - * validate input according to type in plc_config
160 - * added the _genicw system slice
161 - * add tag types for sites and persons
162 - * add new tags for nodes and slices for exemption from myops
163
164 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
165 - turn off drupal on a box that acts as BOOT server but not as WWW server
166 - cleanup some obsolete code for old chroot-jail packaging in the process
167 - new bootcd-kernel script for keeping bootcd variants up2date
168
169 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
170 - Make the /etc/hosts manipulation optional.
171
172 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
173 - Fix SetRole.
174
175 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
176 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
177 - into the DB.
178 - - Added the root ssh key handling support back into plc.d/ssh and the
179 - default xml file.  This should be identical to the way it was in
180 - rc12.
181 - - Added support in the db-config.d/01-init script to register the root
182 - ssh public key with the default administrator.  In this way the root
183 - ssh key will make it into the root account on the nodes by means of
184 - NodeManager's specialaccounts plugin.
185
186 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
187 - db-config ignores sliver tags
188 - sirius's db-config script renamed (was sirious)
189
190 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
191 - fix for silverauth - missing tag types now created at plc startup time
192
193 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
194 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
195
196 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
197 - companion to NM's specialaccounts plugin
198 - do not generate /etc/planetlab/root_ssh_key* anymore
199 - remove related config. variables and conf_files
200
201 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
202 - clarified description text to refer only to plcrt and not other optional
203 - packages.
204
205 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
206 - fixed a bug setting slice multiple attributes with the same tag name
207
208 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
209 - SSL setup for monitor box, and related new config variables
210 - new conf_file for /etc/planetlab/extensions
211 - various tweaks in db-config internals, about initscripts among others
212 - also more messages defined in the db
213
214 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
215 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
216
217 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
218 - bugfix in db-config, tag 4.3-19 would not fly
219
220 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
221 - Refactored db-config into snippets in db-config.d/.
222
223 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
224 - oops, tag 4.3-17 was broken and would not work
225
226 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
227 - bugfix - escape sequences inserted in xml configs
228
229 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
230 - Handle db-config.d files properly.
231
232 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
233 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
234 - than the log file
235 - - Fix db-config to be a bit more cautious when
236 - /etc/planetlab/db-config.d doesn't exist
237 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
238 - .orig files.
239 - - Refactor generic plc-config-tty code into plc_config.py.
240 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
241 - and the list of validated variables and the corresponding
242 - validator() function. This refactoring lets one reuse plc_config.py
243 - as a generic cmdline configuration tool for highly customer MyPLC
244 - like software.
245
246 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
247 - update PCU Type descriptions.
248 - updates to init scripts
249
250 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
251 - requires monitor-pcucontrol so register-wizard can work
252
253 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
254 - cleaned up plc-config-tty, no more need to configure plc-devel
255
256 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
257 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
258
259 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
260 - tighter right permissions on site_admin's authorized keys for more robustness
261
262 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
263 - fix issue in db-config that prevented correct operation
264
265 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
266 - remove support for chroot-based packaging - no crond nor syslog step anymore
267 - plc init script now named plc.init instead of former guest.init
268
269 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
270 - add Monitor to docs build
271
272 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
273 - plc_config.py and plc-config-tty: generalized to work for more diverse
274 - MyPLC configurations.
275 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
276 - deployments and increase the memory limits in php.ini
277 - plc.d/crond: add --full option to vacuumdb
278
279 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
280 - avoid generating ssl certificates for disabled services among www api boot
281
282 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
283 - cleaned up old entries in db-config
284 - mtail more robust
285
286 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
287 - php include path tweaked for plekit includes
288 - reviewed myplc (fka native) packaging dependencies
289 - renumbered 4.3
290
291 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
292 - rename myplc into myplc-chroot and myplc-native into myplc
293 - new settings (shortname & hrn_root) for local peer
294
295 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
296 - First iteration of new data model
297 - Bunch of various fixes
298
299 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
300 - Removed proper ops from planetflow slice.
301
302 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
303 - myplc-native requires myplc-docs
304 - fixed doc build by locating locally installed DTDs at build-time
305
306 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
307 - turn myplc-docs off for now
308
309 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
310 - figures in doc package
311
312 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
313 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
314 - chroot packaging does not have docs anymore
315 - 'cvs' and 'dev' not required from myplc-native anymore
316 - cosmetic change in kml output
317
318
319 %define module_current_branch 4.3