fix URL in specfile - rm svn-keywords
[myplc.git] / myplc-docs.spec
1 %define name myplc-docs
2 %define version 5.0
3 %define taglevel 12
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central (PLC) online documentation
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: Applications/Systems
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15 BuildArch: noarch
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21
22 BuildRequires: docbook-dtds, docbook-utils-pdf
23
24 %define debug_package %{nil}
25
26 %description
27 This package contains the online documentation for MyPLC, i.e. the
28 reference manuals for the two APIs provided: PLCAPI and NMAPI. A
29 more general introduction to the MyPLC system can be found at
30 http://svn.planet-lab.org/wiki/MyPLCUserGuide
31
32 %prep
33 %setup -q
34
35 %build
36 rm -rf $RPM_BUILD_ROOT
37
38 # using the new lowercase names, and handling legacy
39 [ -d plcapi ] || ln -s PLCAPI plcapi
40 [ -d monitor ] || ln -s Monitor monitor 
41 [ -d nodemanager ] || ln -s NodeManager nodemanager
42 [ -d myplc ] || ln -s MyPLC myplc
43
44 pushd plcapi
45 # beware that making the pdf file somehow overwrites the html
46 make -C doc PLCAPI.pdf 
47 rm -f doc/PLCAPI.html
48 make -C doc PLCAPI.html 
49 popd
50
51 pushd nodemanager
52 # beware that making the pdf file somehow overwrites the html
53 make -C doc NMAPI.pdf 
54 rm -f doc/NMAPI.html
55 make -C doc NMAPI.html 
56 popd
57
58 pushd monitor
59 # beware that making the pdf file somehow overwrites the html
60 make -C docs Monitor.pdf 
61 rm -f docs/Monitor.html
62 make -C docs Monitor.html 
63 popd
64
65 %install
66
67 for ext in pdf html; do
68     install -D -m 444 plcapi/doc/PLCAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.$ext
69     install -D -m 444 nodemanager/doc/NMAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.$ext
70     install -D -m 444 monitor/docs/Monitor.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.$ext
71 done
72
73 ./myplc/docbook2drupal.sh "PLC API Documentation (%{pldistro})" \
74     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.html \
75     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.php 
76 ./myplc/docbook2drupal.sh "Node Manager API Documentation (%{pldistro})" \
77     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.html \
78     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.php 
79 ./myplc/docbook2drupal.sh "Monitor API Documentation (%{pldistro})" \
80     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.html \
81     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.php 
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %files
87 %defattr(-,root,root,-)
88 /var/www/html/planetlab/doc/
89
90 %changelog
91 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
92 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
93
94 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
95 - add missing files to rpm package
96
97 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
98 - mtail.py -s for SFA
99 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
100
101 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
102 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
103
104 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
105 - plc-config-tty now has a validator on booleans
106 - e.g. entering 'True' now is rejected rather than silently recording 'false'
107
108 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
109 - disable mod_wsgi
110
111 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
112 - module name changes
113 - start wsgi support
114
115 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
116 - new setting PLC_RESERVATION_GRANULARITY
117
118 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
119 - * partial-repo.sh script
120 - * preserve key along with certificates
121
122 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
123 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
124
125 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
126 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
127 - new OMF category in the config
128 - create the drl system slice
129
130 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
131 - first working version of 5.0:
132 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
133 - nodefamily is 3-fold with pldistro-fcdistro-arch
134 - new PLC_FLAVOUR config category
135 - reviewed module layout
136 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
137
138 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
139 - support for fedora 12
140 - new package myplc-config for use by sfa
141 - drupal user registration turned off
142
143 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
144 - - fix to make sure when API, BOOT, MONITOR are on the same
145 - machine as WWW that the SSL key,cert for WWW takes precedence.
146 - - Do proper setup for SSL CA certficate to be used as the server
147 - chain.
148
149 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
150 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
151
152 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
153 - depend on pcucontrol
154
155 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
156 - * validate input according to type in plc_config
157 - * added the _genicw system slice
158 - * add tag types for sites and persons
159 - * add new tags for nodes and slices for exemption from myops
160
161 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
162 - turn off drupal on a box that acts as BOOT server but not as WWW server
163 - cleanup some obsolete code for old chroot-jail packaging in the process
164 - new bootcd-kernel script for keeping bootcd variants up2date
165
166 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
167 - Make the /etc/hosts manipulation optional.
168
169 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
170 - Fix SetRole.
171
172 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
173 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
174 - into the DB.
175 - - Added the root ssh key handling support back into plc.d/ssh and the
176 - default xml file.  This should be identical to the way it was in
177 - rc12.
178 - - Added support in the db-config.d/01-init script to register the root
179 - ssh public key with the default administrator.  In this way the root
180 - ssh key will make it into the root account on the nodes by means of
181 - NodeManager's specialaccounts plugin.
182
183 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
184 - db-config ignores sliver tags
185 - sirius's db-config script renamed (was sirious)
186
187 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
188 - fix for silverauth - missing tag types now created at plc startup time
189
190 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
191 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
192
193 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
194 - companion to NM's specialaccounts plugin
195 - do not generate /etc/planetlab/root_ssh_key* anymore
196 - remove related config. variables and conf_files
197
198 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
199 - clarified description text to refer only to plcrt and not other optional
200 - packages.
201
202 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
203 - fixed a bug setting slice multiple attributes with the same tag name
204
205 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
206 - SSL setup for monitor box, and related new config variables
207 - new conf_file for /etc/planetlab/extensions
208 - various tweaks in db-config internals, about initscripts among others
209 - also more messages defined in the db
210
211 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
212 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
213
214 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
215 - bugfix in db-config, tag 4.3-19 would not fly
216
217 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
218 - Refactored db-config into snippets in db-config.d/.
219
220 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
221 - oops, tag 4.3-17 was broken and would not work
222
223 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
224 - bugfix - escape sequences inserted in xml configs
225
226 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
227 - Handle db-config.d files properly.
228
229 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
230 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
231 - than the log file
232 - - Fix db-config to be a bit more cautious when
233 - /etc/planetlab/db-config.d doesn't exist
234 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
235 - .orig files.
236 - - Refactor generic plc-config-tty code into plc_config.py.
237 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
238 - and the list of validated variables and the corresponding
239 - validator() function. This refactoring lets one reuse plc_config.py
240 - as a generic cmdline configuration tool for highly customer MyPLC
241 - like software.
242
243 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
244 - update PCU Type descriptions.
245 - updates to init scripts
246
247 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
248 - requires monitor-pcucontrol so register-wizard can work
249
250 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
251 - cleaned up plc-config-tty, no more need to configure plc-devel
252
253 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
254 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
255
256 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
257 - tighter right permissions on site_admin's authorized keys for more robustness
258
259 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
260 - fix issue in db-config that prevented correct operation
261
262 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
263 - remove support for chroot-based packaging - no crond nor syslog step anymore
264 - plc init script now named plc.init instead of former guest.init
265
266 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
267 - add Monitor to docs build
268
269 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
270 - plc_config.py and plc-config-tty: generalized to work for more diverse
271 - MyPLC configurations.
272 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
273 - deployments and increase the memory limits in php.ini
274 - plc.d/crond: add --full option to vacuumdb
275
276 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
277 - avoid generating ssl certificates for disabled services among www api boot
278
279 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
280 - cleaned up old entries in db-config
281 - mtail more robust
282
283 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
284 - php include path tweaked for plekit includes
285 - reviewed myplc (fka native) packaging dependencies
286 - renumbered 4.3
287
288 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
289 - rename myplc into myplc-chroot and myplc-native into myplc
290 - new settings (shortname & hrn_root) for local peer
291
292 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
293 - First iteration of new data model
294 - Bunch of various fixes
295
296 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
297 - Removed proper ops from planetflow slice.
298
299 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
300 - myplc-native requires myplc-docs
301 - fixed doc build by locating locally installed DTDs at build-time
302
303 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
304 - turn myplc-docs off for now
305
306 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
307 - figures in doc package
308
309 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
310 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
311 - chroot packaging does not have docs anymore
312 - 'cvs' and 'dev' not required from myplc-native anymore
313 - cosmetic change in kml output
314
315
316 %define module_current_branch 4.3