Setting tag myplc-5.0-12
[myplc.git] / myplc-docs.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-docs
7 %define version 5.0
8 %define taglevel 12
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) online documentation
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 BuildRequires: docbook-dtds, docbook-utils-pdf
28
29 %define debug_package %{nil}
30
31 %description
32 This package contains the online documentation for MyPLC, i.e. the
33 reference manuals for the two APIs provided: PLCAPI and NMAPI. A
34 more general introduction to the MyPLC system can be found at
35 http://svn.planet-lab.org/wiki/MyPLCUserGuide
36
37 %prep
38 %setup -q
39
40 %build
41 rm -rf $RPM_BUILD_ROOT
42
43 # using the new lowercase names, and handling legacy
44 [ -d plcapi ] || ln -s PLCAPI plcapi
45 [ -d monitor ] || ln -s Monitor monitor 
46 [ -d nodemanager ] || ln -s NodeManager nodemanager
47 [ -d myplc ] || ln -s MyPLC myplc
48
49 pushd plcapi
50 # beware that making the pdf file somehow overwrites the html
51 make -C doc PLCAPI.pdf 
52 rm -f doc/PLCAPI.html
53 make -C doc PLCAPI.html 
54 popd
55
56 pushd nodemanager
57 # beware that making the pdf file somehow overwrites the html
58 make -C doc NMAPI.pdf 
59 rm -f doc/NMAPI.html
60 make -C doc NMAPI.html 
61 popd
62
63 pushd monitor
64 # beware that making the pdf file somehow overwrites the html
65 make -C docs Monitor.pdf 
66 rm -f docs/Monitor.html
67 make -C docs Monitor.html 
68 popd
69
70 %install
71
72 for ext in pdf html; do
73     install -D -m 444 plcapi/doc/PLCAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.$ext
74     install -D -m 444 nodemanager/doc/NMAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.$ext
75     install -D -m 444 monitor/docs/Monitor.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.$ext
76 done
77
78 ./myplc/docbook2drupal.sh "PLC API Documentation (%{pldistro})" \
79     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.html \
80     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.php 
81 ./myplc/docbook2drupal.sh "Node Manager API Documentation (%{pldistro})" \
82     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.html \
83     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.php 
84 ./myplc/docbook2drupal.sh "Monitor API Documentation (%{pldistro})" \
85     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.html \
86     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.php 
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %files
92 %defattr(-,root,root,-)
93 /var/www/html/planetlab/doc/
94
95 %changelog
96 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
97 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
98
99 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
100 - add missing files to rpm package
101
102 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
103 - mtail.py -s for SFA
104 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
105
106 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
107 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
108
109 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
110 - plc-config-tty now has a validator on booleans
111 - e.g. entering 'True' now is rejected rather than silently recording 'false'
112
113 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
114 - disable mod_wsgi
115
116 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
117 - module name changes
118 - start wsgi support
119
120 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
121 - new setting PLC_RESERVATION_GRANULARITY
122
123 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
124 - * partial-repo.sh script
125 - * preserve key along with certificates
126
127 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
128 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
129
130 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
131 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
132 - new OMF category in the config
133 - create the drl system slice
134
135 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
136 - first working version of 5.0:
137 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
138 - nodefamily is 3-fold with pldistro-fcdistro-arch
139 - new PLC_FLAVOUR config category
140 - reviewed module layout
141 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
142
143 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
144 - support for fedora 12
145 - new package myplc-config for use by sfa
146 - drupal user registration turned off
147
148 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
149 - - fix to make sure when API, BOOT, MONITOR are on the same
150 - machine as WWW that the SSL key,cert for WWW takes precedence.
151 - - Do proper setup for SSL CA certficate to be used as the server
152 - chain.
153
154 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
155 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
156
157 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
158 - depend on pcucontrol
159
160 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
161 - * validate input according to type in plc_config
162 - * added the _genicw system slice
163 - * add tag types for sites and persons
164 - * add new tags for nodes and slices for exemption from myops
165
166 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
167 - turn off drupal on a box that acts as BOOT server but not as WWW server
168 - cleanup some obsolete code for old chroot-jail packaging in the process
169 - new bootcd-kernel script for keeping bootcd variants up2date
170
171 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
172 - Make the /etc/hosts manipulation optional.
173
174 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
175 - Fix SetRole.
176
177 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
178 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
179 - into the DB.
180 - - Added the root ssh key handling support back into plc.d/ssh and the
181 - default xml file.  This should be identical to the way it was in
182 - rc12.
183 - - Added support in the db-config.d/01-init script to register the root
184 - ssh public key with the default administrator.  In this way the root
185 - ssh key will make it into the root account on the nodes by means of
186 - NodeManager's specialaccounts plugin.
187
188 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
189 - db-config ignores sliver tags
190 - sirius's db-config script renamed (was sirious)
191
192 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
193 - fix for silverauth - missing tag types now created at plc startup time
194
195 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
196 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
197
198 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
199 - companion to NM's specialaccounts plugin
200 - do not generate /etc/planetlab/root_ssh_key* anymore
201 - remove related config. variables and conf_files
202
203 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
204 - clarified description text to refer only to plcrt and not other optional
205 - packages.
206
207 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
208 - fixed a bug setting slice multiple attributes with the same tag name
209
210 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
211 - SSL setup for monitor box, and related new config variables
212 - new conf_file for /etc/planetlab/extensions
213 - various tweaks in db-config internals, about initscripts among others
214 - also more messages defined in the db
215
216 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
217 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
218
219 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
220 - bugfix in db-config, tag 4.3-19 would not fly
221
222 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
223 - Refactored db-config into snippets in db-config.d/.
224
225 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
226 - oops, tag 4.3-17 was broken and would not work
227
228 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
229 - bugfix - escape sequences inserted in xml configs
230
231 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
232 - Handle db-config.d files properly.
233
234 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
235 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
236 - than the log file
237 - - Fix db-config to be a bit more cautious when
238 - /etc/planetlab/db-config.d doesn't exist
239 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
240 - .orig files.
241 - - Refactor generic plc-config-tty code into plc_config.py.
242 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
243 - and the list of validated variables and the corresponding
244 - validator() function. This refactoring lets one reuse plc_config.py
245 - as a generic cmdline configuration tool for highly customer MyPLC
246 - like software.
247
248 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
249 - update PCU Type descriptions.
250 - updates to init scripts
251
252 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
253 - requires monitor-pcucontrol so register-wizard can work
254
255 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
256 - cleaned up plc-config-tty, no more need to configure plc-devel
257
258 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
259 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
260
261 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
262 - tighter right permissions on site_admin's authorized keys for more robustness
263
264 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
265 - fix issue in db-config that prevented correct operation
266
267 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
268 - remove support for chroot-based packaging - no crond nor syslog step anymore
269 - plc init script now named plc.init instead of former guest.init
270
271 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
272 - add Monitor to docs build
273
274 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
275 - plc_config.py and plc-config-tty: generalized to work for more diverse
276 - MyPLC configurations.
277 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
278 - deployments and increase the memory limits in php.ini
279 - plc.d/crond: add --full option to vacuumdb
280
281 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
282 - avoid generating ssl certificates for disabled services among www api boot
283
284 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
285 - cleaned up old entries in db-config
286 - mtail more robust
287
288 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
289 - php include path tweaked for plekit includes
290 - reviewed myplc (fka native) packaging dependencies
291 - renumbered 4.3
292
293 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
294 - rename myplc into myplc-chroot and myplc-native into myplc
295 - new settings (shortname & hrn_root) for local peer
296
297 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
298 - First iteration of new data model
299 - Bunch of various fixes
300
301 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
302 - Removed proper ops from planetflow slice.
303
304 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
305 - myplc-native requires myplc-docs
306 - fixed doc build by locating locally installed DTDs at build-time
307
308 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
309 - turn myplc-docs off for now
310
311 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
312 - figures in doc package
313
314 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
315 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
316 - chroot packaging does not have docs anymore
317 - 'cvs' and 'dev' not required from myplc-native anymore
318 - cosmetic change in kml output
319
320
321 %define module_current_branch 4.3