plc_config.py and plc-config-tty: generalized to work for more diverse
[myplc.git] / myplc-docs.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-docs
7 %define version 4.3
8 %define taglevel 6
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) online documentation
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 BuildRequires: docbook-dtds, docbook-utils-pdf
28
29 %define debug_package %{nil}
30
31 %description
32 This package contains the online documentation for MyPLC, i.e. the
33 reference manuals for the two APIs provided: PLCAPI and NMAPI. A
34 more general introduction to the MyPLC system can be found at
35 http://svn.planet-lab.org/wiki/MyPLCUserGuide
36
37 %prep
38 %setup -q
39
40 %build
41 rm -rf $RPM_BUILD_ROOT
42
43 pushd PLCAPI
44 # beware that making the pdf file somehow overwrites the html
45 make -C doc PLCAPI.pdf 
46 rm -f doc/PLCAPI.html
47 make -C doc PLCAPI.html 
48 popd
49
50 pushd NodeManager
51 # beware that making the pdf file somehow overwrites the html
52 make -C doc NMAPI.pdf 
53 rm -f doc/NMAPI.html
54 make -C doc NMAPI.html 
55 popd
56
57 %install
58
59 for ext in pdf html; do
60     install -D -m 444 PLCAPI/doc/PLCAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.$ext
61     install -D -m 444 NodeManager/doc/NMAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.$ext
62 done
63
64 ./MyPLC/docbook2drupal.sh "PLC API Documentation (%{pldistro})" \
65     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.html \
66     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.php 
67 ./MyPLC/docbook2drupal.sh "Node Manager API Documentation (%{pldistro})" \
68     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.html \
69     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.php 
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %files
75 %defattr(-,root,root,-)
76 /var/www/html/planetlab/doc/
77
78 %changelog
79 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
80 - plc_config.py and plc-config-tty: generalized to work for more diverse
81 - MyPLC configurations.
82 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
83 - deployments and increase the memory limits in php.ini
84 - plc.d/crond: add --full option to vacuumdb
85
86 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
87 - avoid generating ssl certificates for disabled services among www api boot
88
89 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
90 - cleaned up old entries in db-config
91 - mtail more robust
92
93 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
94 - php include path tweaked for plekit includes
95 - reviewed myplc (fka native) packaging dependencies
96 - renumbered 4.3
97
98 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
99 - rename myplc into myplc-chroot and myplc-native into myplc
100 - new settings (shortname & hrn_root) for local peer
101
102 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
103 - First iteration of new data model
104 - Bunch of various fixes
105
106 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
107 - Removed proper ops from planetflow slice.
108
109 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
110 - myplc-native requires myplc-docs
111 - fixed doc build by locating locally installed DTDs at build-time
112
113 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
114 - turn myplc-docs off for now
115
116 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
117 - figures in doc package
118
119 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
120 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
121 - chroot packaging does not have docs anymore
122 - 'cvs' and 'dev' not required from myplc-native anymore
123 - cosmetic change in kml output
124
125
126 %define module_current_branch 4.2