Merge branch 'master' of ssh://git.onelab.eu/git/myplc
[myplc.git] / myplc-docs.spec
1 %define name myplc-docs
2 %define version 5.0
3 %define taglevel 18
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central (PLC) online documentation
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: Applications/Systems
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15 BuildArch: noarch
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21
22 BuildRequires: docbook-dtds, docbook-utils-pdf
23
24 %define debug_package %{nil}
25
26 %description
27 This package contains the online documentation for MyPLC, i.e. the
28 reference manuals for the two APIs provided: PLCAPI and NMAPI. A
29 more general introduction to the MyPLC system can be found at
30 http://svn.planet-lab.org/wiki/MyPLCUserGuide
31
32 %prep
33 %setup -q
34
35 %build
36 rm -rf $RPM_BUILD_ROOT
37
38 # using the new lowercase names, and handling legacy
39 [ -d myplc ] || ln -s MyPLC myplc
40 [ -d plcapi ] || ln -s PLCAPI plcapi
41 [ -d nodemanager ] || ln -s NodeManager nodemanager
42 [ -d monitor ] || ln -s Monitor monitor 
43
44 pushd plcapi
45 # june2011 & f12, latex issues weird warnings, might need to try twice
46 make -C doc PLCAPI.pdf || make -C doc PLCAPI.pdf 
47 # beware that making the pdf file somehow overwrites the html
48 rm -f doc/PLCAPI.html
49 make -C doc PLCAPI.html || make -C doc PLCAPI.html 
50 popd
51
52 pushd nodemanager
53 # beware that making the pdf file somehow overwrites the html
54 make -C doc NMAPI.pdf || make -C doc NMAPI.pdf
55 rm -f doc/NMAPI.html
56 make -C doc NMAPI.html || make -C doc NMAPI.html 
57 popd
58
59 # not everyone rebuilds monitor, so make it optional
60 if [ -d monitor ] ; then
61 pushd monitor
62 # beware that making the pdf file somehow overwrites the html
63 make -C docs Monitor.pdf || make -C docs Monitor.pdf 
64 rm -f docs/Monitor.html
65 make -C docs Monitor.html || make -C docs Monitor.html 
66 popd
67 fi
68
69 %install
70
71 for ext in pdf html; do
72     install -D -m 444 plcapi/doc/PLCAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.$ext
73     install -D -m 444 nodemanager/doc/NMAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.$ext
74     if [ -d monitor ] ; then
75     install -D -m 444 monitor/docs/Monitor.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.$ext
76     fi
77 done
78
79 ./myplc/docbook2drupal.sh "PLC API Documentation (%{pldistro})" \
80     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.html \
81     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.php 
82 ./myplc/docbook2drupal.sh "Node Manager API Documentation (%{pldistro})" \
83     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.html \
84     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.php 
85 if [ -d monitor ] ; then
86 ./myplc/docbook2drupal.sh "Monitor API Documentation (%{pldistro})" \
87     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.html \
88     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.php 
89 fi
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %files
95 %defattr(-,root,root,-)
96 /var/www/html/planetlab/doc/
97
98 %changelog
99 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-18
100 - new settings for myslice (comon&tophat) and monitor (db)
101 - removed mentions of chroot in description
102 - can redo myplc-docs on broken f12-latex
103 - set short_open_tag in php.ini
104 - fixes in gen-sites-xml (is that still used ?)
105 - partial-repo.sh has moved to 'build' where it more belongs
106 - tweaks in convenience tool 'mtail'
107
108 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-17
109 - fixed changelog, no change from 5.0-16
110
111 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-16
112 - requires ed for the plc.d/packages step
113 - sirius initscript to handle stop and restart
114
115 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-15
116 - ignore steps in db-config.d if they have a '.' or '~' in their name
117
118 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-14
119 - can redo myplc-docs without the doc for monitor
120
121 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-13
122 - no semantic change - just fixed specfile for git URL
123
124 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
125 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
126
127 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
128 - add missing files to rpm package
129
130 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
131 - mtail.py -s for SFA
132 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
133
134 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
135 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
136
137 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
138 - plc-config-tty now has a validator on booleans
139 - e.g. entering 'True' now is rejected rather than silently recording 'false'
140
141 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
142 - disable mod_wsgi
143
144 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
145 - module name changes
146 - start wsgi support
147
148 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
149 - new setting PLC_RESERVATION_GRANULARITY
150
151 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
152 - * partial-repo.sh script
153 - * preserve key along with certificates
154
155 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
156 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
157
158 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
159 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
160 - new OMF category in the config
161 - create the drl system slice
162
163 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
164 - first working version of 5.0:
165 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
166 - nodefamily is 3-fold with pldistro-fcdistro-arch
167 - new PLC_FLAVOUR config category
168 - reviewed module layout
169 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
170
171 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
172 - support for fedora 12
173 - new package myplc-config for use by sfa
174 - drupal user registration turned off
175
176 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
177 - - fix to make sure when API, BOOT, MONITOR are on the same
178 - machine as WWW that the SSL key,cert for WWW takes precedence.
179 - - Do proper setup for SSL CA certficate to be used as the server
180 - chain.
181
182 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
183 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
184
185 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
186 - depend on pcucontrol
187
188 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
189 - * validate input according to type in plc_config
190 - * added the _genicw system slice
191 - * add tag types for sites and persons
192 - * add new tags for nodes and slices for exemption from myops
193
194 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
195 - turn off drupal on a box that acts as BOOT server but not as WWW server
196 - cleanup some obsolete code for old chroot-jail packaging in the process
197 - new bootcd-kernel script for keeping bootcd variants up2date
198
199 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
200 - Make the /etc/hosts manipulation optional.
201
202 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
203 - Fix SetRole.
204
205 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
206 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
207 - into the DB.
208 - - Added the root ssh key handling support back into plc.d/ssh and the
209 - default xml file.  This should be identical to the way it was in
210 - rc12.
211 - - Added support in the db-config.d/01-init script to register the root
212 - ssh public key with the default administrator.  In this way the root
213 - ssh key will make it into the root account on the nodes by means of
214 - NodeManager's specialaccounts plugin.
215
216 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
217 - db-config ignores sliver tags
218 - sirius's db-config script renamed (was sirious)
219
220 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
221 - fix for silverauth - missing tag types now created at plc startup time
222
223 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
224 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
225
226 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
227 - companion to NM's specialaccounts plugin
228 - do not generate /etc/planetlab/root_ssh_key* anymore
229 - remove related config. variables and conf_files
230
231 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
232 - clarified description text to refer only to plcrt and not other optional
233 - packages.
234
235 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
236 - fixed a bug setting slice multiple attributes with the same tag name
237
238 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
239 - SSL setup for monitor box, and related new config variables
240 - new conf_file for /etc/planetlab/extensions
241 - various tweaks in db-config internals, about initscripts among others
242 - also more messages defined in the db
243
244 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
245 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
246
247 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
248 - bugfix in db-config, tag 4.3-19 would not fly
249
250 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
251 - Refactored db-config into snippets in db-config.d/.
252
253 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
254 - oops, tag 4.3-17 was broken and would not work
255
256 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
257 - bugfix - escape sequences inserted in xml configs
258
259 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
260 - Handle db-config.d files properly.
261
262 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
263 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
264 - than the log file
265 - - Fix db-config to be a bit more cautious when
266 - /etc/planetlab/db-config.d doesn't exist
267 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
268 - .orig files.
269 - - Refactor generic plc-config-tty code into plc_config.py.
270 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
271 - and the list of validated variables and the corresponding
272 - validator() function. This refactoring lets one reuse plc_config.py
273 - as a generic cmdline configuration tool for highly customer MyPLC
274 - like software.
275
276 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
277 - update PCU Type descriptions.
278 - updates to init scripts
279
280 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
281 - requires monitor-pcucontrol so register-wizard can work
282
283 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
284 - cleaned up plc-config-tty, no more need to configure plc-devel
285
286 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
287 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
288
289 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
290 - tighter right permissions on site_admin's authorized keys for more robustness
291
292 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
293 - fix issue in db-config that prevented correct operation
294
295 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
296 - remove support for chroot-based packaging - no crond nor syslog step anymore
297 - plc init script now named plc.init instead of former guest.init
298
299 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
300 - add Monitor to docs build
301
302 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
303 - plc_config.py and plc-config-tty: generalized to work for more diverse
304 - MyPLC configurations.
305 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
306 - deployments and increase the memory limits in php.ini
307 - plc.d/crond: add --full option to vacuumdb
308
309 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
310 - avoid generating ssl certificates for disabled services among www api boot
311
312 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
313 - cleaned up old entries in db-config
314 - mtail more robust
315
316 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
317 - php include path tweaked for plekit includes
318 - reviewed myplc (fka native) packaging dependencies
319 - renumbered 4.3
320
321 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
322 - rename myplc into myplc-chroot and myplc-native into myplc
323 - new settings (shortname & hrn_root) for local peer
324
325 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
326 - First iteration of new data model
327 - Bunch of various fixes
328
329 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
330 - Removed proper ops from planetflow slice.
331
332 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
333 - myplc-native requires myplc-docs
334 - fixed doc build by locating locally installed DTDs at build-time
335
336 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
337 - turn myplc-docs off for now
338
339 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
340 - figures in doc package
341
342 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
343 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
344 - chroot packaging does not have docs anymore
345 - 'cvs' and 'dev' not required from myplc-native anymore
346 - cosmetic change in kml output
347
348
349 %define module_current_branch 4.3