Setting tag MyPLC-5.0-4
[myplc.git] / myplc-docs.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-docs
7 %define version 5.0
8 %define taglevel 4
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) online documentation
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 BuildRequires: docbook-dtds, docbook-utils-pdf
28
29 %define debug_package %{nil}
30
31 %description
32 This package contains the online documentation for MyPLC, i.e. the
33 reference manuals for the two APIs provided: PLCAPI and NMAPI. A
34 more general introduction to the MyPLC system can be found at
35 http://svn.planet-lab.org/wiki/MyPLCUserGuide
36
37 %prep
38 %setup -q
39
40 %build
41 rm -rf $RPM_BUILD_ROOT
42
43 pushd PLCAPI
44 # beware that making the pdf file somehow overwrites the html
45 make -C doc PLCAPI.pdf 
46 rm -f doc/PLCAPI.html
47 make -C doc PLCAPI.html 
48 popd
49
50 pushd NodeManager
51 # beware that making the pdf file somehow overwrites the html
52 make -C doc NMAPI.pdf 
53 rm -f doc/NMAPI.html
54 make -C doc NMAPI.html 
55 popd
56
57 pushd Monitor
58 # beware that making the pdf file somehow overwrites the html
59 make -C docs Monitor.pdf 
60 rm -f docs/Monitor.html
61 make -C docs Monitor.html 
62 popd
63
64 %install
65
66 for ext in pdf html; do
67     install -D -m 444 PLCAPI/doc/PLCAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.$ext
68     install -D -m 444 NodeManager/doc/NMAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.$ext
69     install -D -m 444 Monitor/docs/Monitor.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.$ext
70 done
71
72 ./MyPLC/docbook2drupal.sh "PLC API Documentation (%{pldistro})" \
73     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.html \
74     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.php 
75 ./MyPLC/docbook2drupal.sh "Node Manager API Documentation (%{pldistro})" \
76     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.html \
77     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.php 
78 ./MyPLC/docbook2drupal.sh "Monitor API Documentation (%{pldistro})" \
79     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.html \
80     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.php 
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %files
86 %defattr(-,root,root,-)
87 /var/www/html/planetlab/doc/
88
89 %changelog
90 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
91 - * partial-repo.sh script
92 - * preserve key along with certificates
93
94 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
95 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
96
97 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
98 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
99 - new OMF category in the config
100 - create the drl system slice
101
102 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
103 - first working version of 5.0:
104 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
105 - nodefamily is 3-fold with pldistro-fcdistro-arch
106 - new PLC_FLAVOUR config category
107 - reviewed module layout
108 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
109
110 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
111 - support for fedora 12
112 - new package myplc-config for use by sfa
113 - drupal user registration turned off
114
115 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
116 - - fix to make sure when API, BOOT, MONITOR are on the same
117 - machine as WWW that the SSL key,cert for WWW takes precedence.
118 - - Do proper setup for SSL CA certficate to be used as the server
119 - chain.
120
121 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
122 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
123
124 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
125 - depend on pcucontrol
126
127 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
128 - * validate input according to type in plc_config
129 - * added the _genicw system slice
130 - * add tag types for sites and persons
131 - * add new tags for nodes and slices for exemption from myops
132
133 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
134 - turn off drupal on a box that acts as BOOT server but not as WWW server
135 - cleanup some obsolete code for old chroot-jail packaging in the process
136 - new bootcd-kernel script for keeping bootcd variants up2date
137
138 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
139 - Make the /etc/hosts manipulation optional.
140
141 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
142 - Fix SetRole.
143
144 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
145 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
146 - into the DB.
147 - - Added the root ssh key handling support back into plc.d/ssh and the
148 - default xml file.  This should be identical to the way it was in
149 - rc12.
150 - - Added support in the db-config.d/01-init script to register the root
151 - ssh public key with the default administrator.  In this way the root
152 - ssh key will make it into the root account on the nodes by means of
153 - NodeManager's specialaccounts plugin.
154
155 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
156 - db-config ignores sliver tags
157 - sirius's db-config script renamed (was sirious)
158
159 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
160 - fix for silverauth - missing tag types now created at plc startup time
161
162 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
163 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
164
165 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
166 - companion to NM's specialaccounts plugin
167 - do not generate /etc/planetlab/root_ssh_key* anymore
168 - remove related config. variables and conf_files
169
170 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
171 - clarified description text to refer only to plcrt and not other optional
172 - packages.
173
174 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
175 - fixed a bug setting slice multiple attributes with the same tag name
176
177 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
178 - SSL setup for monitor box, and related new config variables
179 - new conf_file for /etc/planetlab/extensions
180 - various tweaks in db-config internals, about initscripts among others
181 - also more messages defined in the db
182
183 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
184 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
185
186 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
187 - bugfix in db-config, tag 4.3-19 would not fly
188
189 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
190 - Refactored db-config into snippets in db-config.d/.
191
192 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
193 - oops, tag 4.3-17 was broken and would not work
194
195 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
196 - bugfix - escape sequences inserted in xml configs
197
198 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
199 - Handle db-config.d files properly.
200
201 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
202 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
203 - than the log file
204 - - Fix db-config to be a bit more cautious when
205 - /etc/planetlab/db-config.d doesn't exist
206 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
207 - .orig files.
208 - - Refactor generic plc-config-tty code into plc_config.py.
209 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
210 - and the list of validated variables and the corresponding
211 - validator() function. This refactoring lets one reuse plc_config.py
212 - as a generic cmdline configuration tool for highly customer MyPLC
213 - like software.
214
215 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
216 - update PCU Type descriptions.
217 - updates to init scripts
218
219 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
220 - requires monitor-pcucontrol so register-wizard can work
221
222 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
223 - cleaned up plc-config-tty, no more need to configure plc-devel
224
225 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
226 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
227
228 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
229 - tighter right permissions on site_admin's authorized keys for more robustness
230
231 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
232 - fix issue in db-config that prevented correct operation
233
234 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
235 - remove support for chroot-based packaging - no crond nor syslog step anymore
236 - plc init script now named plc.init instead of former guest.init
237
238 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
239 - add Monitor to docs build
240
241 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
242 - plc_config.py and plc-config-tty: generalized to work for more diverse
243 - MyPLC configurations.
244 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
245 - deployments and increase the memory limits in php.ini
246 - plc.d/crond: add --full option to vacuumdb
247
248 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
249 - avoid generating ssl certificates for disabled services among www api boot
250
251 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
252 - cleaned up old entries in db-config
253 - mtail more robust
254
255 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
256 - php include path tweaked for plekit includes
257 - reviewed myplc (fka native) packaging dependencies
258 - renumbered 4.3
259
260 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
261 - rename myplc into myplc-chroot and myplc-native into myplc
262 - new settings (shortname & hrn_root) for local peer
263
264 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
265 - First iteration of new data model
266 - Bunch of various fixes
267
268 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
269 - Removed proper ops from planetflow slice.
270
271 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
272 - myplc-native requires myplc-docs
273 - fixed doc build by locating locally installed DTDs at build-time
274
275 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
276 - turn myplc-docs off for now
277
278 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
279 - figures in doc package
280
281 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
282 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
283 - chroot packaging does not have docs anymore
284 - 'cvs' and 'dev' not required from myplc-native anymore
285 - cosmetic change in kml output
286
287
288 %define module_current_branch 4.3