Setting tag myplc-5.0-9
[myplc.git] / myplc-docs.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-docs
7 %define version 5.0
8 %define taglevel 9
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) online documentation
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 BuildRequires: docbook-dtds, docbook-utils-pdf
28
29 %define debug_package %{nil}
30
31 %description
32 This package contains the online documentation for MyPLC, i.e. the
33 reference manuals for the two APIs provided: PLCAPI and NMAPI. A
34 more general introduction to the MyPLC system can be found at
35 http://svn.planet-lab.org/wiki/MyPLCUserGuide
36
37 %prep
38 %setup -q
39
40 %build
41 rm -rf $RPM_BUILD_ROOT
42
43 # using the new lowercase names, and handling legacy
44 [ -d plcapi ] || ln -s PLCAPI plcapi
45 [ -d monitor ] || ln -s Monitor monitor 
46 [ -d nodemanager ] || ln -s NodeManager nodemanager
47 [ -d myplc ] || ln -s MyPLC myplc
48
49 pushd plcapi
50 # beware that making the pdf file somehow overwrites the html
51 make -C doc PLCAPI.pdf 
52 rm -f doc/PLCAPI.html
53 make -C doc PLCAPI.html 
54 popd
55
56 pushd nodemanager
57 # beware that making the pdf file somehow overwrites the html
58 make -C doc NMAPI.pdf 
59 rm -f doc/NMAPI.html
60 make -C doc NMAPI.html 
61 popd
62
63 pushd monitor
64 # beware that making the pdf file somehow overwrites the html
65 make -C docs Monitor.pdf 
66 rm -f docs/Monitor.html
67 make -C docs Monitor.html 
68 popd
69
70 %install
71
72 for ext in pdf html; do
73     install -D -m 444 plcapi/doc/PLCAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.$ext
74     install -D -m 444 nodemanager/doc/NMAPI.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.$ext
75     install -D -m 444 monitor/docs/Monitor.$ext $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.$ext
76 done
77
78 ./myplc/docbook2drupal.sh "PLC API Documentation (%{pldistro})" \
79     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.html \
80     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/PLCAPI.php 
81 ./myplc/docbook2drupal.sh "Node Manager API Documentation (%{pldistro})" \
82     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.html \
83     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/NMAPI.php 
84 ./myplc/docbook2drupal.sh "Monitor API Documentation (%{pldistro})" \
85     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.html \
86     $RPM_BUILD_ROOT/var/www/html/planetlab/doc/Monitor.php 
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %files
92 %defattr(-,root,root,-)
93 /var/www/html/planetlab/doc/
94
95 %changelog
96 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
97 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
98
99 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
100 - plc-config-tty now has a validator on booleans
101 - e.g. entering 'True' now is rejected rather than silently recording 'false'
102
103 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
104 - disable mod_wsgi
105
106 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
107 - module name changes
108 - start wsgi support
109
110 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
111 - new setting PLC_RESERVATION_GRANULARITY
112
113 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
114 - * partial-repo.sh script
115 - * preserve key along with certificates
116
117 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
118 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
119
120 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
121 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
122 - new OMF category in the config
123 - create the drl system slice
124
125 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
126 - first working version of 5.0:
127 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
128 - nodefamily is 3-fold with pldistro-fcdistro-arch
129 - new PLC_FLAVOUR config category
130 - reviewed module layout
131 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
132
133 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
134 - support for fedora 12
135 - new package myplc-config for use by sfa
136 - drupal user registration turned off
137
138 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
139 - - fix to make sure when API, BOOT, MONITOR are on the same
140 - machine as WWW that the SSL key,cert for WWW takes precedence.
141 - - Do proper setup for SSL CA certficate to be used as the server
142 - chain.
143
144 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
145 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
146
147 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
148 - depend on pcucontrol
149
150 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
151 - * validate input according to type in plc_config
152 - * added the _genicw system slice
153 - * add tag types for sites and persons
154 - * add new tags for nodes and slices for exemption from myops
155
156 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
157 - turn off drupal on a box that acts as BOOT server but not as WWW server
158 - cleanup some obsolete code for old chroot-jail packaging in the process
159 - new bootcd-kernel script for keeping bootcd variants up2date
160
161 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
162 - Make the /etc/hosts manipulation optional.
163
164 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
165 - Fix SetRole.
166
167 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
168 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
169 - into the DB.
170 - - Added the root ssh key handling support back into plc.d/ssh and the
171 - default xml file.  This should be identical to the way it was in
172 - rc12.
173 - - Added support in the db-config.d/01-init script to register the root
174 - ssh public key with the default administrator.  In this way the root
175 - ssh key will make it into the root account on the nodes by means of
176 - NodeManager's specialaccounts plugin.
177
178 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
179 - db-config ignores sliver tags
180 - sirius's db-config script renamed (was sirious)
181
182 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
183 - fix for silverauth - missing tag types now created at plc startup time
184
185 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
186 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
187
188 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
189 - companion to NM's specialaccounts plugin
190 - do not generate /etc/planetlab/root_ssh_key* anymore
191 - remove related config. variables and conf_files
192
193 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
194 - clarified description text to refer only to plcrt and not other optional
195 - packages.
196
197 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
198 - fixed a bug setting slice multiple attributes with the same tag name
199
200 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
201 - SSL setup for monitor box, and related new config variables
202 - new conf_file for /etc/planetlab/extensions
203 - various tweaks in db-config internals, about initscripts among others
204 - also more messages defined in the db
205
206 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
207 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
208
209 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
210 - bugfix in db-config, tag 4.3-19 would not fly
211
212 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
213 - Refactored db-config into snippets in db-config.d/.
214
215 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
216 - oops, tag 4.3-17 was broken and would not work
217
218 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
219 - bugfix - escape sequences inserted in xml configs
220
221 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
222 - Handle db-config.d files properly.
223
224 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
225 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
226 - than the log file
227 - - Fix db-config to be a bit more cautious when
228 - /etc/planetlab/db-config.d doesn't exist
229 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
230 - .orig files.
231 - - Refactor generic plc-config-tty code into plc_config.py.
232 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
233 - and the list of validated variables and the corresponding
234 - validator() function. This refactoring lets one reuse plc_config.py
235 - as a generic cmdline configuration tool for highly customer MyPLC
236 - like software.
237
238 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
239 - update PCU Type descriptions.
240 - updates to init scripts
241
242 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
243 - requires monitor-pcucontrol so register-wizard can work
244
245 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
246 - cleaned up plc-config-tty, no more need to configure plc-devel
247
248 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
249 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
250
251 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
252 - tighter right permissions on site_admin's authorized keys for more robustness
253
254 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
255 - fix issue in db-config that prevented correct operation
256
257 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
258 - remove support for chroot-based packaging - no crond nor syslog step anymore
259 - plc init script now named plc.init instead of former guest.init
260
261 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
262 - add Monitor to docs build
263
264 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
265 - plc_config.py and plc-config-tty: generalized to work for more diverse
266 - MyPLC configurations.
267 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
268 - deployments and increase the memory limits in php.ini
269 - plc.d/crond: add --full option to vacuumdb
270
271 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
272 - avoid generating ssl certificates for disabled services among www api boot
273
274 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
275 - cleaned up old entries in db-config
276 - mtail more robust
277
278 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
279 - php include path tweaked for plekit includes
280 - reviewed myplc (fka native) packaging dependencies
281 - renumbered 4.3
282
283 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
284 - rename myplc into myplc-chroot and myplc-native into myplc
285 - new settings (shortname & hrn_root) for local peer
286
287 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-1
288 - First iteration of new data model
289 - Bunch of various fixes
290
291 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
292 - Removed proper ops from planetflow slice.
293
294 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
295 - myplc-native requires myplc-docs
296 - fixed doc build by locating locally installed DTDs at build-time
297
298 * Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
299 - turn myplc-docs off for now
300
301 * Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
302 - figures in doc package
303
304 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
305 - no more doc packaged outside of myplc-docs - doc/ cleaned up 
306 - chroot packaging does not have docs anymore
307 - 'cvs' and 'dev' not required from myplc-native anymore
308 - cosmetic change in kml output
309
310
311 %define module_current_branch 4.3