drop PLC_OMF_XMPP_USER and PLC_OMF_XMPP_PASSWORD from config
[myplc.git] / myplc-release.spec
1 %define name myplc-release
2 %define version 5.2
3 %define taglevel 3
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central (PLC) release file
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: Applications/Systems
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15 BuildArch: noarch
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21
22 %define debug_package %{nil}
23
24 %description 
25 This package contains in /etc/myplc-release the details of the
26 contents of that release. This is used by the GetPlcRelease API call.
27
28 %prep
29 %setup -q
30
31 %build
32
33 # fetch the release stamp from the build if any
34 if [ -f ../../myplc-release ] ; then
35   cp ../../myplc-release myplc-release
36 else
37   echo "Cannot find release information." > myplc-release
38   date >> myplc-release
39   echo "$HeadURL$" >> myplc-release
40 fi
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 # install it in /etc/myplc-release 
45 install -D -m 444 myplc-release ${RPM_BUILD_ROOT}/etc/myplc-release
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(-,root,root,-)
52 /etc/myplc-release
53
54 %changelog
55 * Tue Apr 23 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-3
56 - plc.d/gpg now does not rm /dev/random but preserves it
57 - this is because libvirt won't let us run mknod
58
59 * Wed Apr 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-2
60 - fix typo in check-hrns - used to print 'host' while dealing with persons
61
62 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-1
63 - supports httpd config for either mod_python (preferred) or mod_wsgi
64 - requires mod_wsgi on f18 only, otherwise mod_python
65 - supports httpd config for apache 2.4 (f18)
66 - new config variable PLC_FLAVOUR_VIRT_MAP to set 'virt' from fcdistro
67
68 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-6
69 - bugfix in check-vsys-defaults.py
70
71 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-5
72 - define open_basedir in php.ini to stop confidentiality leak
73 - new utility slice_ssh_keys.py for showing sliver keys (OMF interop)
74 - new config setting PLC_VSYS_DEFAULTS for vsys tags granted to all
75 - new utilities check-hrns.py and check-vsys-defaults.py
76
77 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-4
78 - set TimeoutSec to 300 in plc.service
79 - remove ref to deprecated svn $URL$ in db-config usage
80
81 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-3
82 - expose mtail.py as simply mtail
83
84 * Mon May 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-2
85 - plc-kml.py now has support for nodegroups
86
87 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-1
88 - use nodeimage package instead of deprecated bootstrapfs
89 - has systemd-friendly startup script
90 - plc_reload moved to functions/ - no more service plc reload
91 - no svn keywords anymore
92
93 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-19
94 - new maintenance/monitoring script spot-aliens to look for glitches in refreshpeer+sfa
95
96 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-18
97 - new settings for myslice (comon&tophat) and monitor (db)
98 - removed mentions of chroot in description
99 - can redo myplc-docs on broken f12-latex
100 - set short_open_tag in php.ini
101 - fixes in gen-sites-xml (is that still used ?)
102 - partial-repo.sh has moved to 'build' where it more belongs
103 - tweaks in convenience tool 'mtail'
104
105 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-17
106 - fixed changelog, no change from 5.0-16
107
108 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-16
109 - requires ed for the plc.d/packages step
110 - sirius initscript to handle stop and restart
111
112 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-15
113 - ignore steps in db-config.d if they have a '.' or '~' in their name
114
115 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-14
116 - can redo myplc-docs without the doc for monitor
117
118 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-13
119 - no semantic change - just fixed specfile for git URL
120
121 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
122 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
123
124 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
125 - add missing files to rpm package
126
127 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
128 - mtail.py -s for SFA
129 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
130
131 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
132 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
133
134 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
135 - plc-config-tty now has a validator on booleans
136 - e.g. entering 'True' now is rejected rather than silently recording 'false'
137
138 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
139 - disable mod_wsgi
140
141 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
142 - module name changes
143 - start wsgi support
144
145 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
146 - new setting PLC_RESERVATION_GRANULARITY
147
148 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
149 - * partial-repo.sh script
150 - * preserve key along with certificates
151
152 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
153 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
154
155 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
156 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
157 - new OMF category in the config
158 - create the drl system slice
159
160 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
161 - first working version of 5.0:
162 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
163 - nodefamily is 3-fold with pldistro-fcdistro-arch
164 - new PLC_FLAVOUR config category
165 - reviewed module layout
166 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
167
168 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
169 - support for fedora 12
170 - new package myplc-config for use by sfa
171 - drupal user registration turned off
172
173 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
174 - - fix to make sure when API, BOOT, MONITOR are on the same
175 - machine as WWW that the SSL key,cert for WWW takes precedence.
176 - - Do proper setup for SSL CA certficate to be used as the server
177 - chain.
178
179 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
180 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
181
182 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
183 - depend on pcucontrol
184
185 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
186 - * validate input according to type in plc_config
187 - * added the _genicw system slice
188 - * add tag types for sites and persons
189 - * add new tags for nodes and slices for exemption from myops
190
191 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
192 - turn off drupal on a box that acts as BOOT server but not as WWW server
193 - cleanup some obsolete code for old chroot-jail packaging in the process
194 - new bootcd-kernel script for keeping bootcd variants up2date
195
196 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
197 - Make the /etc/hosts manipulation optional.
198
199 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
200 - Fix SetRole.
201
202 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
203 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
204 - into the DB.
205 - - Added the root ssh key handling support back into plc.d/ssh and the
206 - default xml file.  This should be identical to the way it was in
207 - rc12.
208 - - Added support in the db-config.d/01-init script to register the root
209 - ssh public key with the default administrator.  In this way the root
210 - ssh key will make it into the root account on the nodes by means of
211 - NodeManager's specialaccounts plugin.
212
213 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
214 - db-config ignores sliver tags
215 - sirius's db-config script renamed (was sirious)
216
217 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
218 - fix for silverauth - missing tag types now created at plc startup time
219
220 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
221 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
222
223 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
224 - companion to NM's specialaccounts plugin
225 - do not generate /etc/planetlab/root_ssh_key* anymore
226 - remove related config. variables and conf_files
227
228 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
229 - clarified description text to refer only to plcrt and not other optional
230 - packages.
231
232 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
233 - fixed a bug setting slice multiple attributes with the same tag name
234
235 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
236 - SSL setup for monitor box, and related new config variables
237 - new conf_file for /etc/planetlab/extensions
238 - various tweaks in db-config internals, about initscripts among others
239 - also more messages defined in the db
240
241 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
242 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
243
244 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
245 - bugfix in db-config, tag 4.3-19 would not fly
246
247 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
248 - Refactored db-config into snippets in db-config.d/.
249
250 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
251 - oops, tag 4.3-17 was broken and would not work
252
253 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
254 - bugfix - escape sequences inserted in xml configs
255
256 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
257 - Handle db-config.d files properly.
258
259 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
260 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
261 - than the log file
262 - - Fix db-config to be a bit more cautious when
263 - /etc/planetlab/db-config.d doesn't exist
264 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
265 - .orig files.
266 - - Refactor generic plc-config-tty code into plc_config.py.
267 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
268 - and the list of validated variables and the corresponding
269 - validator() function. This refactoring lets one reuse plc_config.py
270 - as a generic cmdline configuration tool for highly customer MyPLC
271 - like software.
272
273 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
274 - update PCU Type descriptions.
275 - updates to init scripts
276
277 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
278 - requires monitor-pcucontrol so register-wizard can work
279
280 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
281 - cleaned up plc-config-tty, no more need to configure plc-devel
282
283 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
284 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
285
286 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
287 - tighter right permissions on site_admin's authorized keys for more robustness
288
289 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
290 - fix issue in db-config that prevented correct operation
291
292 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
293 - remove support for chroot-based packaging - no crond nor syslog step anymore
294 - plc init script now named plc.init instead of former guest.init
295
296 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
297 - add Monitor to docs build
298
299 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
300 - plc_config.py and plc-config-tty: generalized to work for more diverse
301 - MyPLC configurations.
302 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
303 - deployments and increase the memory limits in php.ini
304 - plc.d/crond: add --full option to vacuumdb
305
306 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
307 - avoid generating ssl certificates for disabled services among www api boot
308
309 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
310 - cleaned up old entries in db-config
311 - mtail more robust
312
313 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
314 - php include path tweaked for plekit includes
315 - reviewed myplc (fka native) packaging dependencies
316 - renumbered 4.3
317
318 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
319 - rename myplc into myplc-chroot and myplc-native into myplc
320 - new settings (shortname & hrn_root) for local peer
321
322
323 %define module_current_branch 4.3