Setting tag myplc-5.0-14
[myplc.git] / myplc-release.spec
1 %define name myplc-release
2 %define version 5.0
3 %define taglevel 14
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central (PLC) release file
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: Applications/Systems
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15 BuildArch: noarch
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21
22 %define debug_package %{nil}
23
24 %description 
25 This package contains in /etc/myplc-release the details of the
26 contents of that release. This is used by the GetPlcRelease API call.
27
28 %prep
29 %setup -q
30
31 %build
32
33 # fetch the release stamp from the build if any
34 if [ -f ../../myplc-release ] ; then
35   cp ../../myplc-release myplc-release
36 else
37   echo "Cannot find release information." > myplc-release
38   date >> myplc-release
39   echo "$HeadURL$" >> myplc-release
40 fi
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 # install it in /etc/myplc-release 
45 install -D -m 444 myplc-release ${RPM_BUILD_ROOT}/etc/myplc-release
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(-,root,root,-)
52 /etc/myplc-release
53
54 %changelog
55 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-14
56 - can redo myplc-docs without the doc for monitor
57
58 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-13
59 - no semantic change - just fixed specfile for git URL
60
61 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
62 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
63
64 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
65 - add missing files to rpm package
66
67 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
68 - mtail.py -s for SFA
69 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
70
71 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
72 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
73
74 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
75 - plc-config-tty now has a validator on booleans
76 - e.g. entering 'True' now is rejected rather than silently recording 'false'
77
78 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
79 - disable mod_wsgi
80
81 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
82 - module name changes
83 - start wsgi support
84
85 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
86 - new setting PLC_RESERVATION_GRANULARITY
87
88 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
89 - * partial-repo.sh script
90 - * preserve key along with certificates
91
92 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
93 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
94
95 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
96 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
97 - new OMF category in the config
98 - create the drl system slice
99
100 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
101 - first working version of 5.0:
102 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
103 - nodefamily is 3-fold with pldistro-fcdistro-arch
104 - new PLC_FLAVOUR config category
105 - reviewed module layout
106 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
107
108 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
109 - support for fedora 12
110 - new package myplc-config for use by sfa
111 - drupal user registration turned off
112
113 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
114 - - fix to make sure when API, BOOT, MONITOR are on the same
115 - machine as WWW that the SSL key,cert for WWW takes precedence.
116 - - Do proper setup for SSL CA certficate to be used as the server
117 - chain.
118
119 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
120 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
121
122 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
123 - depend on pcucontrol
124
125 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
126 - * validate input according to type in plc_config
127 - * added the _genicw system slice
128 - * add tag types for sites and persons
129 - * add new tags for nodes and slices for exemption from myops
130
131 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
132 - turn off drupal on a box that acts as BOOT server but not as WWW server
133 - cleanup some obsolete code for old chroot-jail packaging in the process
134 - new bootcd-kernel script for keeping bootcd variants up2date
135
136 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
137 - Make the /etc/hosts manipulation optional.
138
139 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
140 - Fix SetRole.
141
142 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
143 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
144 - into the DB.
145 - - Added the root ssh key handling support back into plc.d/ssh and the
146 - default xml file.  This should be identical to the way it was in
147 - rc12.
148 - - Added support in the db-config.d/01-init script to register the root
149 - ssh public key with the default administrator.  In this way the root
150 - ssh key will make it into the root account on the nodes by means of
151 - NodeManager's specialaccounts plugin.
152
153 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
154 - db-config ignores sliver tags
155 - sirius's db-config script renamed (was sirious)
156
157 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
158 - fix for silverauth - missing tag types now created at plc startup time
159
160 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
161 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
162
163 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
164 - companion to NM's specialaccounts plugin
165 - do not generate /etc/planetlab/root_ssh_key* anymore
166 - remove related config. variables and conf_files
167
168 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
169 - clarified description text to refer only to plcrt and not other optional
170 - packages.
171
172 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
173 - fixed a bug setting slice multiple attributes with the same tag name
174
175 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
176 - SSL setup for monitor box, and related new config variables
177 - new conf_file for /etc/planetlab/extensions
178 - various tweaks in db-config internals, about initscripts among others
179 - also more messages defined in the db
180
181 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
182 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
183
184 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
185 - bugfix in db-config, tag 4.3-19 would not fly
186
187 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
188 - Refactored db-config into snippets in db-config.d/.
189
190 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
191 - oops, tag 4.3-17 was broken and would not work
192
193 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
194 - bugfix - escape sequences inserted in xml configs
195
196 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
197 - Handle db-config.d files properly.
198
199 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
200 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
201 - than the log file
202 - - Fix db-config to be a bit more cautious when
203 - /etc/planetlab/db-config.d doesn't exist
204 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
205 - .orig files.
206 - - Refactor generic plc-config-tty code into plc_config.py.
207 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
208 - and the list of validated variables and the corresponding
209 - validator() function. This refactoring lets one reuse plc_config.py
210 - as a generic cmdline configuration tool for highly customer MyPLC
211 - like software.
212
213 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
214 - update PCU Type descriptions.
215 - updates to init scripts
216
217 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
218 - requires monitor-pcucontrol so register-wizard can work
219
220 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
221 - cleaned up plc-config-tty, no more need to configure plc-devel
222
223 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
224 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
225
226 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
227 - tighter right permissions on site_admin's authorized keys for more robustness
228
229 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
230 - fix issue in db-config that prevented correct operation
231
232 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
233 - remove support for chroot-based packaging - no crond nor syslog step anymore
234 - plc init script now named plc.init instead of former guest.init
235
236 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
237 - add Monitor to docs build
238
239 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
240 - plc_config.py and plc-config-tty: generalized to work for more diverse
241 - MyPLC configurations.
242 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
243 - deployments and increase the memory limits in php.ini
244 - plc.d/crond: add --full option to vacuumdb
245
246 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
247 - avoid generating ssl certificates for disabled services among www api boot
248
249 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
250 - cleaned up old entries in db-config
251 - mtail more robust
252
253 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
254 - php include path tweaked for plekit includes
255 - reviewed myplc (fka native) packaging dependencies
256 - renumbered 4.3
257
258 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
259 - rename myplc into myplc-chroot and myplc-native into myplc
260 - new settings (shortname & hrn_root) for local peer
261
262
263 %define module_current_branch 4.3